CODES HELP! 97 F350 - Ford Truck Enthusiasts Forums



1994.5 - 1997 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

CODES HELP! 97 F350

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-26-2016, 10:10 AM
sca91ford's Avatar
sca91ford sca91ford is offline
New User
Thread Starter
 
Join Date: Sep 2009
Location: Tucson, AZ
Posts: 13
sca91ford is starting off with a positive reputation.
CODES HELP! 97 F350

The truck has been idling a little funny, intermittently. Sometimes it idles perfect others it's rough and choppy.

I checked the DCTs before I left work and I had a P0603 code (Internal Ctrl Mod KAM error) which I cleared.

I just checked the DCT's after being home for a while and I am getting the following codes...

P0221: Throttle switch B circuit performance
Possible Cause: Failed pedal assembly

P0344: Camshaft position sensor ckt. intermittent
Possible Cause: Harness routing, charging ckt., sensor, int. ckt., improper gap

P0606: PCM processor fault
Possible cause: Internal PCM failure

P1118: Manifold air temp sensor out of range low
Possible Cause: Short to GND MAT circuit, MAT sensor

Any connection to these code showing up at the same time in a 14mi in town trip home?

I do have a ts performance 6pos chip installed. I'm not partial to it but I do like the extra power. Side note, I don't have the chip turned all the way up nor am I romping on the truck. The chip stays at the 50hp mark. But if you all think it's a problem I'll take it out.

Im getting ready to head out of town with the truck and I'd like to clear these up before I leave.

Thanks for all your help!!
Reply With Quote
  #2  
Old 07-27-2016, 08:31 AM
oldbird1965's Avatar
oldbird1965 oldbird1965 is offline
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 18,376
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
Just pull the chip for a test. Easy to do.
Reply With Quote
  #3  
Old 07-27-2016, 12:21 PM
knottyrope's Avatar
knottyrope knottyrope is offline
Posting Guru
 
Join Date: Apr 2016
Location: Bahstun
Posts: 2,204
knottyrope has a good reputation on FTE.knottyrope has a good reputation on FTE.knottyrope has a good reputation on FTE.
Pull chip and then look for codes again.


CPS is cheap to replace and you should keep a spare one handy.
Reply With Quote
  #4  
Old 07-27-2016, 12:54 PM
cowmilker08's Avatar
cowmilker08 cowmilker08 is offline
Postmaster
 
Join Date: Oct 2008
Location: Avilla, IN
Posts: 4,811
cowmilker08 has a very good reputation on FTE.cowmilker08 has a very good reputation on FTE.cowmilker08 has a very good reputation on FTE.cowmilker08 has a very good reputation on FTE.
And a wonky CPS can cause all sorts of strange issues. Although a rough idle can be caused by numerous things.

First step: Make sure your oi, oil filter, and fuel filter aren't over due for a change
Second step: temporarily remove the chip - see if your issues go away
Third step: try a new Ford/IH cps

We'll go from there if that doesn't clear it up.
Reply With Quote
  #5  
Old 08-03-2016, 01:23 AM
sca91ford's Avatar
sca91ford sca91ford is offline
New User
Thread Starter
 
Join Date: Sep 2009
Location: Tucson, AZ
Posts: 13
sca91ford is starting off with a positive reputation.
Thank you guys for the input. I cleared those codes before my trip and it has not reset them. My trip was just shy of 600 miles with a 7500ft elevation change. (up and then down) The weird idle persisted through the trip up and around at the high altitude. But now I'm back down to 2500ft and back in to the 100+ Temps the idle is back to normal. I contacted TS Performance and I am sending the chip in. (it's a plain ts 6pos with the stock, high idle, 50hp, 75hp, 100hp and 140hp.) the stock and 75hp settings aren't working and that should have been my first clue that the chip could be the culprit. I'm also going to change the fuel filter this week. This truck is a new purchase to me so I have yet to do all my own fluid changes. According to the pervious owners log book he was using amsoil products for the trans, diffs, and engine oil and amsoil filters as well. Now, it says the amsoil is rated for 25k miles (I think that's crazy, any input would be great!) and it has about 4000k miles since the last oil/ fuel filter change so in my mind I dismissed those as issues as well. (still, any input on that would be great) other wise the truck performed fantastically pulling a little pop up camper and a couple hundred pounds of gear. I'm really pleased! I'm probably over thinking the idle issue but then again you can never be too careful. I will follow up with you all as soon as the above mentioned are taken care of. Thank you again for all your input!
Reply With Quote
  #6  
Old 08-03-2016, 08:31 AM
oldbird1965's Avatar
oldbird1965 oldbird1965 is offline
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 18,376
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
Maybe its not the chip, it might be that its not making good contact. Don't over clean the contacts but you might check to see if they are clean. Sounds like canned tunes, custom tunes are always better.


Do you have any idea if the engine has a oil bypass system on it? Amsoil is a good product even though I've never used it. I run Schaeffer's oil with a FS2500 bypass and if I get to 7K without a oil change I don't like it. I would never go 25K but if it has a Amsoil bypass that filters down the oil you could go farther then the normal oil change, how far is up to you.
Reply With Quote
  #7  
Old 08-04-2016, 04:17 PM
mcali2's Avatar
mcali2 mcali2 is offline
Posting Guru
 
Join Date: Aug 2013
Location: Fallon NV
Posts: 1,307
mcali2 is gaining momentum as a positive member of FTE.mcali2 is gaining momentum as a positive member of FTE.
Oh great another toy to add to the list. better oil filter!
Reply With Quote
  #8  
Old 08-04-2016, 06:03 PM
helifixer's Avatar
helifixer helifixer is offline
Post Fiend
 
Join Date: Dec 2005
Location: Chino Valley, Arizona
Posts: 6,495
helifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputation
definitely check the pcm connections to make sure all the sealant was cleaned off.
also check on the driver side valve cover where the engine harness rubs on it, I see a lot of issues from chaffed wires there.
as mentioned before run it with out the chip and see what happens.
as for the idle is it just hunting or does it act like a miss?
My truck has hunted for idle since I bought it at 60,000 miles (now at 260,000) and it still does. the only thing I haven't changed is the pcm. I have changed the HPOP, IPR, IPC, Injectors, UVC gaskets and harnesses, turbo, idm Throttle pedal and the engine, and it has always idled the same.
Reply With Quote
  #9  
Old 08-04-2016, 07:30 PM
knottyrope's Avatar
knottyrope knottyrope is offline
Posting Guru
 
Join Date: Apr 2016
Location: Bahstun
Posts: 2,204
knottyrope has a good reputation on FTE.knottyrope has a good reputation on FTE.knottyrope has a good reputation on FTE.
Quote:
Originally Posted by helifixer View Post
definitely check the pcm connections to make sure all the sealant was cleaned off.
also check on the driver side valve cover where the engine harness rubs on it, I see a lot of issues from chaffed wires there.
as mentioned before run it with out the chip and see what happens.
as for the idle is it just hunting or does it act like a miss?
My truck has hunted for idle since I bought it at 60,000 miles (now at 260,000) and it still does. the only thing I haven't changed is the pcm. I have changed the HPOP, IPR, IPC, Injectors, UVC gaskets and harnesses, turbo, idm Throttle pedal and the engine, and it has always idled the same.
I think the idle cure is HPX or efuel. I could be wrong but the pulses from the pump cause rough idle. I thought about an accumulator of some sort for this.
Reply With Quote
  #10  
Old 08-04-2016, 09:44 PM
z31freakify's Avatar
z31freakify z31freakify is online now
Post Fiend
 
Join Date: Dec 2012
Location: Las Cruces New Mexico
Posts: 5,249
z31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to all
For me it was the bb mod or in my case a Mardi Gras bead and cured the idle surge and smooth out the engine.
Reply With Quote
  #11  
Old 08-06-2016, 07:43 PM
helifixer's Avatar
helifixer helifixer is offline
Post Fiend
 
Join Date: Dec 2005
Location: Chino Valley, Arizona
Posts: 6,495
helifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputationhelifixer has a superb reputation
I had hpx on last engine, bb shim years ago.
like I said the only thing I haven't changed is the pcm. gotta love having a spare truck when you are bored! except I change stuff for something to do!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check engine light code help needed 89 f250 Kyle Campbell 1987 - 1996 F150 & Larger F-Series Trucks 6 06-08-2017 04:26 PM
Rough idle help needed wyoclint 1999 - 2003 7.3L Power Stroke Diesel 11 12-15-2016 06:02 PM
PSD trouble codes DRRXR 1994.5 - 1997 7.3L Power Stroke Diesel 6 10-30-2016 02:22 PM
Help please!! 18 codes after I shorted my battery accidently paradox78 1997 - 2003 F150 9 07-20-2016 10:07 PM
1995 F-150 Code 173 & Poor Drivability omar1746 1987 - 1996 F150 & Larger F-Series Trucks 4 03-15-2016 09:43 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: