2003 F250 6.0 Problems - Ford Truck Enthusiasts Forums



6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van

2003 F250 6.0 Problems

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-12-2012, 09:08 PM
phlsimpson phlsimpson is offline
New User
Thread Starter
 
Join Date: Jan 2012
Posts: 5
phlsimpson is starting off with a positive reputation.
2003 F250 6.0 Problems

I have a 2003 F250 6.0 that is currently having a couple of issues. First being that it idles around 1,000 rpm when in park all the time. Second being when in drive and stopped it idles all over the place. Tends to surge forward also. The idling issue is erratic. It tends to jump all over the place and almost sounds like it's going to stall. I pulled out the EGR valve and it was dirty. Cleaned and installed with no change. Any suggestions? Thanks in advance.
Reply With Quote
  #2  
Old 01-12-2012, 09:10 PM
powerstroke72's Avatar
powerstroke72 powerstroke72 is offline
Super Moderator
 
Join Date: Oct 2005
Location: SW Virginia
Posts: 24,268
powerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputationpowerstroke72 has a superb reputation
Moved to the 6.0L Power Stroke Diesel forum.
Reply With Quote
  #3  
Old 01-12-2012, 09:18 PM
wulfman wulfman is offline
Posting Guru
 
Join Date: Aug 2010
Location: knox Tn
Posts: 1,919
wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.
Well first off need to have it scaned for codes , there can be codes with out a check engine light on. Next the surging most likely ICP sensor located behind the turbo.
Reply With Quote
  #4  
Old 01-12-2012, 09:20 PM
wulfman wulfman is offline
Posting Guru
 
Join Date: Aug 2010
Location: knox Tn
Posts: 1,919
wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.wulfman has a great reputation on FTE.
OH and almost forgot welcome to FTE you will find a lot of helpful people here .
Reply With Quote
  #5  
Old 01-12-2012, 09:28 PM
BLADE35's Avatar
BLADE35 BLADE35 is offline
Post Fiend
 
Join Date: Apr 2010
Location: Saratoga Springs,UT
Posts: 18,136
BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.
Im with David

unplug the ICP sensor start the truck and see if problem persists
if not you just found the Culprit
Reply With Quote
  #6  
Old 01-12-2012, 09:28 PM
phlsimpson phlsimpson is offline
New User
Thread Starter
 
Join Date: Jan 2012
Posts: 5
phlsimpson is starting off with a positive reputation.
Thanks. I scanned and got insufficent exhaust gas flow. That's when I cleaned the EGR valve with no change. I almost forgot to mention that I'm having issues with the tranny. lol. It shift hard when down shifting from 2nd to first when I'm coming to a stop. The high idling went away after the first EGR valve cleaning but after the 4th it just doesn't make a difference anymor. I think it might be time to buy a new valve. Would that also cause the idle to fluctuate irradically also?
Reply With Quote
  #7  
Old 01-12-2012, 10:10 PM
BLADE35's Avatar
BLADE35 BLADE35 is offline
Post Fiend
 
Join Date: Apr 2010
Location: Saratoga Springs,UT
Posts: 18,136
BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.
shure egr valve could cause similair symtoms
Reply With Quote
  #8  
Old 01-13-2012, 10:59 AM
cartmanea cartmanea is offline
Post Fiend
 
Join Date: Jun 2007
Location: Corvallis, OR
Posts: 6,749
cartmanea is a name known to allcartmanea is a name known to allcartmanea is a name known to allcartmanea is a name known to allcartmanea is a name known to allcartmanea is a name known to all
Sounds like ICP sensor. I'm replacing the one in my dad's '03 this weekend for the same symptoms.
Reply With Quote
  #9  
Old 01-13-2012, 08:28 PM
phlsimpson phlsimpson is offline
New User
Thread Starter
 
Join Date: Jan 2012
Posts: 5
phlsimpson is starting off with a positive reputation.
Thanks guys. So it is possible for the ICP sensor to cause this without throwing a code? I started tearing into it and this is a beotch. Getting ready to put the new one in. Is it possible to just rig your current EGR valve as a delete but leave the cooler in? What would be the pros and cons to this?
Reply With Quote
  #10  
Old 01-13-2012, 08:42 PM
BLADE35's Avatar
BLADE35 BLADE35 is offline
Post Fiend
 
Join Date: Apr 2010
Location: Saratoga Springs,UT
Posts: 18,136
BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.
If you want a EGR deleate its best to get a kit

Unplugging the EGR valve just causes other problems
Reply With Quote
  #11  
Old 01-13-2012, 08:44 PM
phlsimpson phlsimpson is offline
New User
Thread Starter
 
Join Date: Jan 2012
Posts: 5
phlsimpson is starting off with a positive reputation.
I've been looking at a couple. What's the best out there for the money?
Reply With Quote
  #12  
Old 01-13-2012, 09:01 PM
BLADE35's Avatar
BLADE35 BLADE35 is offline
Post Fiend
 
Join Date: Apr 2010
Location: Saratoga Springs,UT
Posts: 18,136
BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.BLADE35 has a spectacular reputation.
Quote:
Originally Posted by phlsimpson View Post
I've been looking at a couple. What's the best out there for the money?

or if you can Tig weld then weld caps on both ends of the egr cooler they have to be Good welds though or they will crack with the Hot/cold cycles

I went with a Full egr deleate a Sinister
6.0 Upgraded EGR Cooler | MKM Customs 6.0L Ford Powerstroke EGR Delete Kit


They have cheaper knock off kits now that wernt advalible when I did it
If you look around you can get the same thing for like 150.00
Reply With Quote
  #13  
Old 01-14-2012, 12:46 PM
phlsimpson phlsimpson is offline
New User
Thread Starter
 
Join Date: Jan 2012
Posts: 5
phlsimpson is starting off with a positive reputation.
So, they gave me the wrong ICP sensor. What would be the damage of driving around with it disconnected?
Reply With Quote
  #14  
Old 01-14-2012, 05:31 PM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 15,980
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
I wouldn't do it - I would think that you are going to have poor combustion by doing so.
Reply With Quote
  #15  
Old 01-14-2012, 05:34 PM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 15,980
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
How do you know it is the wrong sensor?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
03 Expedition Random Power Loss/Backfire Under Hood therealtomlapp 1997-2006 Expedition & Navigator 0 06-27-2016 07:24 PM
6.0 has started surging at idle StoneZone 6.0L Power Stroke Diesel 16 12-23-2015 12:24 AM
2003 f250 random idle shake evan1242 6.0L Power Stroke Diesel 64 10-20-2014 03:58 AM
Black smoke Godfather1 6.0L Power Stroke Diesel 10 09-13-2011 01:01 PM
mileage VS hours blong 6.0L Power Stroke Diesel 5 12-29-2005 12:26 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2003, 250, 60, blue, cheapest, chips, cons, f250, ford, ftor, fx4, issues, list, performance, problems, spring

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:48 AM.