Cruise control not working... - Page 4 - Ford Truck Enthusiasts Forums

Notices
1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Cruise control not working...

Reply

 
 
 
  #46  
Old 04-27-2013, 06:38 PM
husky390
husky390 is offline
Senior User
Join Date: Mar 2007
Posts: 228
husky390 is starting off with a positive reputation.
Thanks, so basically I need to start with the module and make sure that is not frozen? Also, would the reverse lights not working have anything to do with the cruise not working?
 
Reply With Quote
  #47  
Old 04-27-2013, 10:27 PM
DALEDIESEL
DALEDIESEL is offline
Senior User
Join Date: Dec 2006
Location: INYOKERN, CALIFORNIA
Posts: 160
DALEDIESEL is starting off with a positive reputation.
Speed control

Wait a second, if your truck is a 1990 you don't have the module! You have the vacuum/electric type. Sorry! Dale
 
Reply With Quote
  #48  
Old 04-27-2013, 10:51 PM
subford's Avatar
subford
subford is offline
Post Fiend
Join Date: Aug 2005
Location: Easton,Ks
Posts: 21,352
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
He still has a module under the dash but it does not look like what he is thinking above.
 
Reply With Quote
  #49  
Old 06-13-2015, 01:16 PM
JSavens
JSavens is offline
New User
Join Date: Jun 2015
Posts: 1
JSavens is starting off with a positive reputation.
Clock Spring

[QUOTE=redlightning93;7699388]Does your horn blow?

If not it sounds like a Clock Spring.


Does it also affect cruise control and make your airbag light activate? Only a great relationship with a mechanic kept my truck i inspection current. I didn't tell him and he didn't ask! That's a great relationship! He knows I'll fix it.
 
Reply With Quote
  #50  
Old 09-14-2015, 04:30 PM
jim&i
jim&i is offline
New User
Join Date: Sep 2015
Posts: 5
jim&i is starting off with a positive reputation.
cruise control not working and can not get into gear after starting

hey master minds this one has got me stumped! have a 2002 f250 4x4 . number 34 fuse (10amp) blows when replaced. cruise stopped working and can not get into gear from park after starting but turn ignition swtch to 1 click forward and put into nuetral then start and go on about my business? cruise recall completed in 06, brake lights work horn works/ any help on this would be great.
 
Reply With Quote
  #51  
Old 09-14-2015, 05:41 PM
rla2005's Avatar
rla2005
rla2005 is online now
Post Fiend
Join Date: Oct 2005
Location: Illinois
Posts: 14,410
rla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud of
Originally Posted by jim&i View Post
hey master minds this one has got me stumped! have a 2002 f250 4x4 . number 34 fuse (10amp) blows when replaced. cruise stopped working and can not get into gear from park after starting but turn ignition swtch to 1 click forward and put into nuetral then start and go on about my business? cruise recall completed in 06, brake lights work horn works/ any help on this would be great.
Try posting in the correct forum: Super Duty & Heavy Duty - Ford Truck Enthusiasts Forums
 
Reply With Quote
  #52  
Old 09-14-2015, 07:11 PM
mrollings53's Avatar
mrollings53
mrollings53 is offline
Posting Guru
Join Date: Oct 2014
Location: Washington
Posts: 1,140
mrollings53 is gaining momentum as a positive member of FTE.
You've got a short to ground on whatever that fuse controls.
 
Reply With Quote
  #53  
Old 01-27-2018, 02:31 PM
ragtop69's Avatar
ragtop69
ragtop69 is offline
New User
Join Date: Oct 2017
Posts: 18
ragtop69 is starting off with a positive reputation.
My '95 Bronco cruise control doesn't work. I've checked the relevant fuses in both boxes and performed the shut off switch replacement. Had the top off the servo and it moves smoothly without any binding. There was power indicated at the plug to the servo. My brake lights work and my horn works. I understand there is a cruise control relay. Where would I find that? Also, despite moving the big gear on the servo manually, I didn't see any movement at the throttle body. Could the cable be broken or bound? If so, how would the servo mechanism be able to move?

Two further questions: 1) Does a '95 Bronco have a dash light to indicate that the cruise control is on? Where would that be located and, for the record, if it does have one mine isn't working. 2) I found a video on cleaning the steering wheel switches with electrical cleaner, but the featured Ford vehicle was a later model. Can the steering wheel buttons be removed from the switches to permit access with a cleaning solution?
 
Reply With Quote
  #54  
Old 01-31-2018, 09:40 PM
Trail_Rider
Trail_Rider is offline
Posting Guru
Join Date: Nov 1999
Location: Lower 48
Posts: 1,387
Trail_Rider is starting off with a positive reputation.
Originally Posted by redlightning93 View Post
Does your horn blow?

If not it sounds like a Clock Spring.
What has the horn got to do with anything? My horn has never worked and until recently the cruise worked just fine.
 
Reply With Quote
  #55  
Old 02-04-2018, 01:51 PM
jason90f150's Avatar
jason90f150
jason90f150 is offline
Senior User
Join Date: Apr 2015
Location: Colorado
Posts: 206
jason90f150 is starting off with a positive reputation.
For some reason my speed controll only works when I get a brake light when I apply the parking brake. Sometimes it works sometimes it doesnt. If I wiggle the parking break pedal it'll come on then my cruise control will work. If it doesnt light up cruise doesnt work
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Orlie
1999 to 2016 Super Duty
119
11-22-2017 08:19 PM
blue66tang95f150
1987 - 1996 F150 & Larger F-Series Trucks
3
08-14-2017 08:17 AM
1997Aerostar
Aerostar
10
04-30-2017 08:41 PM
svastano
1999 to 2016 Super Duty
10
04-27-2017 09:12 PM
Larboy
General Diesel Discussion
2
03-02-2017 01:17 AM


Thread Tools
Search this Thread
Quick Reply: Cruise control not working...


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.