Sway Bar end links after Ready Lift 2.5 Level - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > 2017+ Super Duty
Reload this Page >

Sway Bar end links after Ready Lift 2.5 Level

Notices
2017+ Super Duty The 2017+ Ford F250, F350, F450 and F550 Super Duty Pickup and Chassis Cab

Sway Bar end links after Ready Lift 2.5 Level

 
  #1  
Old 01-21-2019, 08:25 PM
Angry Tomato's Avatar
Angry Tomato
Angry Tomato is offline
Junior User
Thread Starter
Join Date: Oct 2018
Posts: 74
Angry Tomato is starting off with a positive reputation.
Sway Bar end links after Ready Lift 2.5 Level

Anyone had any issues with knocking noise over small bumps at low speeds after having this level installed? I have the caster corrected with bushings, running 37's with, blistein shocks, track bar relo bracket installed/ spring swap not spacers.

Noise is coming from the front driver's side footwell and it sounds almost like its end links on the sway bar. Truck has 1500 miles on it. I've checked every bolt on its all tight. Is it likely to be the end links with so little miles on it?
 
  #2  
Old 01-21-2019, 09:18 PM
Snowman 8's Avatar
Snowman 8
Snowman 8 is offline
Senior User
Join Date: Sep 2011
Location: Minnesota
Posts: 379
Snowman 8 is starting off with a positive reputation.
Just a guess, but is the bolt on the end of the track bar tight enough? I think that its the one that needs to be torqued to 450lbft. Mine was loose after my level was installed and I had a clunk in the front end.
I’ve also had shocks cause clunks while hitting bumps. It took some convincing to get a nearly brand new shock covered by warranty but once they were replaced the clunks were gone... good luck
 
  #3  
Old 01-21-2019, 09:24 PM
bobv60
bobv60 is offline
Posting Guru
Join Date: May 2011
Location: Rainier OR
Posts: 1,199
bobv60 has a very good reputation on FTE.bobv60 has a very good reputation on FTE.bobv60 has a very good reputation on FTE.
lower shock mount bolts is the first place I would look, they need to be TIGHT
 
  #4  
Old 01-21-2019, 09:31 PM
Angry Tomato's Avatar
Angry Tomato
Angry Tomato is offline
Junior User
Thread Starter
Join Date: Oct 2018
Posts: 74
Angry Tomato is starting off with a positive reputation.
Thanks Snowman 8 . I did remind them to torque it up to the 405ftlb and not the 250 in the instructions. Whether they did I've no idea but if thats it I'll be a bit pissed. I have new Blisteins with the kit so i hope it isn't the shocks. I'll pull the shocks off and see if it disappears.
 
  #5  
Old 01-21-2019, 09:38 PM
Snowman 8's Avatar
Snowman 8
Snowman 8 is offline
Senior User
Join Date: Sep 2011
Location: Minnesota
Posts: 379
Snowman 8 is starting off with a positive reputation.
Originally Posted by Angry Tomato View Post
Thanks Snowman 8 . I did remind them to torque it up to the 405ftlb and not the 250 in the instructions. Whether they did I've no idea but if thats it I'll be a bit pissed. I have new Blisteins with the kit so i hope it isn't the shocks. I'll pull the shocks off and see if it disappears.
As bobv60 said I would for sure check the lower shock bolts also. Now that I had a chance to think about it my 17 had a couple noises, one was the track bar bolt and the other was the drivers side lower shock bolt. I put my impact wrench on it and just let it hammer away for a few seconds then the noises were gone.
 
  #6  
Old 01-21-2019, 10:00 PM
Angry Tomato's Avatar
Angry Tomato
Angry Tomato is offline
Junior User
Thread Starter
Join Date: Oct 2018
Posts: 74
Angry Tomato is starting off with a positive reputation.
Originally Posted by bobv60 View Post
lower shock mount bolts is the first place I would look, they need to be TIGHT
Thanks bobv60 . I'll stick my big impact on it and get them snugged up some more.
 
  #7  
Old 01-22-2019, 08:17 AM
2017-350's Avatar
2017-350
2017-350 is offline
Junior User
Join Date: Aug 2017
Location: Galvston, Texas
Posts: 99
2017-350 is starting off with a positive reputation.
Mine had a knocking noise and it was the puck in between the spring and the top of the housing. It shifted a hair in installation and wasn't sitting correctly in the spring.
 
  #8  
Old 01-22-2019, 09:03 PM
Angry Tomato's Avatar
Angry Tomato
Angry Tomato is offline
Junior User
Thread Starter
Join Date: Oct 2018
Posts: 74
Angry Tomato is starting off with a positive reputation.
Originally Posted by 2017-350 View Post
Mine had a knocking noise and it was the puck in between the spring and the top of the housing. It shifted a hair in installation and wasn't sitting correctly in the spring.
Mines a spring/coil replacement.
 

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.