2018 F250 6.2L gas pump clicks off prematurely - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > 2017+ Super Duty
Reload this Page >

2018 F250 6.2L gas pump clicks off prematurely

Notices
2017+ Super Duty The 2017+ Ford F250, F350, F450 and F550 Super Duty Pickup and Chassis Cab

2018 F250 6.2L gas pump clicks off prematurely

  #1  
Old 11-08-2018, 07:08 PM
adgjqetuo
adgjqetuo is online now
Freshman User
Thread Starter
Join Date: Sep 2016
Posts: 28
adgjqetuo is starting off with a positive reputation.
2018 F250 6.2L gas pump clicks off prematurely

This has been happening since my very first fill up (now has 2k miles on it). Whenever I go to get gas the nozzle clicks off numerious times before itís fully filled up. Some gas stations as much as every 2-3 gallons. Any ideas??

Maybe a blocked or kinked vent hose somewhere?
 
  #2  
Old 11-08-2018, 07:13 PM
Heathen Dave
Heathen Dave is online now
Freshman User
Join Date: Aug 2018
Posts: 34
Heathen Dave is starting off with a positive reputation.
Could be a blocked filter on the vent line?

Do you overfill the tank or do you normally stop once the pump shuts itself off? I had a similar issue with my F150 and I was told the inside of the vent filter collapsed, probaly from getting wet because of overfilling. Not sure if it would happen that quickly to you though.
 
  #3  
Old 11-08-2018, 07:23 PM
adgjqetuo
adgjqetuo is online now
Freshman User
Thread Starter
Join Date: Sep 2016
Posts: 28
adgjqetuo is starting off with a positive reputation.
Not sure - itís done it since my very first fill up at 300 miles so itís hard to tell when itís actually full vs false clicking off.

I was hoping to get some direction with places to look before taking it to the dealer.
 
  #4  
Old 11-08-2018, 07:42 PM
Heathen Dave
Heathen Dave is online now
Freshman User
Join Date: Aug 2018
Posts: 34
Heathen Dave is starting off with a positive reputation.
I'd try and find the location of your charcoal filter. I think its above the spare tire, if I'm wrong someone else here will hopefully correct me. Its alot larger then you would think.

But honestly if it is that new I would take it in before trying to do anything yourself. No reason to have a dealership say it's not under warranty because you broke something.
 
  #5  
Old 11-08-2018, 07:44 PM
TCNashville
TCNashville is offline
Senior User
Join Date: Mar 2018
Location: South Central Indiana
Posts: 190
TCNashville is starting off with a positive reputation.
Originally Posted by adgjqetuo View Post
This has been happening since my very first fill up (now has 2k miles on it). Whenever I go to get gas the nozzle clicks off numerious times before itís fully filled up. Some gas stations as much as every 2-3 gallons. Any ideas??

Maybe a blocked or kinked vent hose somewhere?
Unfortunately this is a common problem and there are a number of threads about it. My '17 F-250 6.2 still does this occasionally and it's very annoying. What I do now is when it does it, I restart the pump and gently grab the fuel hose about a foot behind the nozzle and change the angle of the nozzle and let go of the hose and more times than not it fills the rest of the way without shutting off.
 
  #6  
Old 11-08-2018, 08:11 PM
JackalAR
JackalAR is online now
Freshman User
Join Date: Oct 2018
Posts: 38
JackalAR is starting off with a positive reputation.
I filled up about 5 times after purchase at 8200 mi. and it worked perfectly. Went to top off (15.5 gal) yesterday and had to struggle with it.
 
  #7  
Old 11-08-2018, 08:15 PM
Tankclimber18
Tankclimber18 is offline
Freshman User
Join Date: Sep 2018
Location: Littleton NC
Posts: 34
Tankclimber18 is starting off with a positive reputation.
My first fill up was like this, but no problems since almost 7k
 
  #8  
Old 11-08-2018, 09:44 PM
slip knot
slip knot is offline
Junior User
Join Date: Jul 2018
Posts: 69
slip knot is starting off with a positive reputation.
My 2019 does this every now and then. Moving the nozzle in or out just a bit seems to help.
 
  #9  
Old 11-09-2018, 09:57 AM
LadderDogV10
LadderDogV10 is offline
Senior User
Join Date: May 2009
Location: The Buckeye State
Posts: 315
LadderDogV10 is gaining momentum as a positive member of FTE.
Mine does it too. I just donít insert the nozzle all the way. Try backing it out just a bit and try it that way. Mine doesnít click off when I do it that way. I think the angle causes somewhat of a bottle neck when the nozzle is in bone deep.
 
  #10  
Old 11-09-2018, 10:14 AM
JackalAR
JackalAR is online now
Freshman User
Join Date: Oct 2018
Posts: 38
JackalAR is starting off with a positive reputation.
When mine acted up, nothing short of throttling WAY back helped, tried all angles, even pull it completely out of the hole and shot it in.
 
  #11  
Old 11-09-2018, 10:40 AM
Krabill
Krabill is offline
Junior User
Join Date: Sep 2008
Posts: 83
Krabill is starting off with a positive reputation.
Mine does it too
 
  #12  
Old 11-09-2018, 10:44 AM
GoldenDomer's Avatar
GoldenDomer
GoldenDomer is offline
Senior User
Join Date: Apr 2017
Location: Outside of Austin
Posts: 301
GoldenDomer is starting off with a positive reputation.
I've had my 17' for close to a year and half now and I've noticed that when I run it down close it empty it seems to happen more than if I'm still around 1/4 tank. Also, it really only seems to happen when I first start pumping. After I get going it doesn't seem to happen. As was previously said the only thing I have been able to do to is just throttle back and let it fill on up.
 
  #13  
Old 11-09-2018, 10:47 AM
GoldenDomer's Avatar
GoldenDomer
GoldenDomer is offline
Senior User
Join Date: Apr 2017
Location: Outside of Austin
Posts: 301
GoldenDomer is starting off with a positive reputation.
Originally Posted by JackalAR View Post
When mine acted up, nothing short of throttling WAY back helped, tried all angles, even pull it completely out of the hole and shot it in.
Quote of the day.....
 
  #14  
Old 11-09-2018, 10:57 AM
GoldenDomer's Avatar
GoldenDomer
GoldenDomer is offline
Senior User
Join Date: Apr 2017
Location: Outside of Austin
Posts: 301
GoldenDomer is starting off with a positive reputation.
Originally Posted by JackalAR View Post
When mine acted up, nothing short of throttling WAY back helped, tried all angles, even pull it completely out of the hole and shot it in.
Quote of the day.....
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.