95 tranny - Ford Truck Enthusiasts Forums

Notices
Explorer, Sport Trac, Mountaineer & Aviator 1991-1994, 1995-2001, 2002-2005, 2006-2010 Ford Explorer

95 tranny

  #1  
Old 03-05-2004, 08:02 PM
dlhazel
dlhazel is offline
New User
Thread Starter
Join Date: Mar 2004
Location: south carolina
Posts: 7
dlhazel is starting off with a positive reputation.
95 tranny

I have a 95 x 2wd 4.0 that the od off light has been flashing. It displays a code 628 (excessive converter clutch slippage). I have been told I need a torque converter. I put in a vss, tps, & that differential thingy near the egr valve , with no change. Help I,m a woman out here at the mercy of shop quacks, although I DO KNOW A LITTLE. Someone told me to check my modulator valve but I cannot find it. Oh yes they have already installed the tss solenoid and changed fluid & filter. It was real dirty but no metal. I am still having the same problems. ANY IDEAS.
 
  #2  
Old 03-06-2004, 04:32 PM
prcrboy's Avatar
prcrboy
prcrboy is offline
Elder User
Join Date: Feb 2004
Posts: 772
prcrboy is starting off with a positive reputation.
How many miles on your exploder? Does it effect the driveability of the car?
 
  #3  
Old 03-07-2004, 12:16 PM
dlhazel
dlhazel is offline
New User
Thread Starter
Join Date: Mar 2004
Location: south carolina
Posts: 7
dlhazel is starting off with a positive reputation.
180,000 iT RUNS FINE UNTIL THAT LIGHT COMES ON IT STARTS SHIFTING HARD. i WAS ALSO GETTING CODES 332, 335, & 412, ( EGR & iDLE) BUT I PUT SOME ADDITVE IN THE THROTTLE BODY AND REPLACED THAT DIFFERENTIAL THINGY AND NOW I ONLY GET 628 THE TRANNY CODE. IT DOES CUT OFF ON ME SOMETIMES AFTER I FIRST START IT UP.
THIS IS THE FIRST PROBLEM I HAVE HAD WITH THIS ITS BEEN A GOOD ONE. I CHANGE THE OIL REG. AND THE TRANS FLUID FAIRLY REG.
 
  #4  
Old 03-08-2004, 05:24 AM
marragtop's Avatar
marragtop
marragtop is offline
Posting Guru
Join Date: May 2002
Location: Baltimore
Posts: 2,450
marragtop is starting off with a positive reputation.
Try disconnecting the battery for 5 minutes. This will reset the codes and cause the light to go out. If it comes back on, you need to get it fixed. When the light is blinking, the trans goes into 'cripple' mode which makes it shift hard which is not good for it. Many times, disconnecting the battery will keep the light off for monthis.

Mike
 
  #5  
Old 03-08-2004, 06:04 AM
dlhazel
dlhazel is offline
New User
Thread Starter
Join Date: Mar 2004
Location: south carolina
Posts: 7
dlhazel is starting off with a positive reputation.
No this has been done also I have erased the codes with a scanner. Do you think this could be the torque converter?
 
  #6  
Old 03-08-2004, 08:45 AM
phonebem
phonebem is offline
Senior User
Join Date: Oct 2003
Posts: 178
phonebem is starting off with a positive reputation.
I had this problem with my '95. Replace the EGR sensor, it is the culprit. Once your engine warms-up the EGR throws a code which screws up your tranny shift points. The EGR sensor costs like $20 and is a 10 minute fix.
 
  #7  
Old 03-08-2004, 09:02 AM
luckild
luckild is offline
Senior User
Join Date: Jun 2003
Posts: 400
luckild is starting off with a positive reputation.
My thoughts are that it is the Torque Converter. What kind of shop did you take it to? Most Trans shops will road test for free and give you and estimate. Let us know and good luck.
 
  #8  
Old 03-08-2004, 10:36 AM
dlhazel
dlhazel is offline
New User
Thread Starter
Join Date: Mar 2004
Location: south carolina
Posts: 7
dlhazel is starting off with a positive reputation.
I just put that on and it did not fix it. While I was installing it one of the vac. lines broke, so I replaced it and now I will go ahead and replace the other one since one of them was so brittle. Do you know where the pcv valve is ? I can't seem to find it on this model.
 
  #9  
Old 03-09-2004, 08:46 PM
dlhazel
dlhazel is offline
New User
Thread Starter
Join Date: Mar 2004
Location: south carolina
Posts: 7
dlhazel is starting off with a positive reputation.
the egr sensor helped a little but the light still comes on . It may just take a little longer.
I took it to a shop that did a test drive and said it is definitely the converter.

A friend told me to check the modulator. Does this model have one and if so does anyone know where it is? Or is it all electrical?
 
  #10  
Old 05-11-2004, 02:31 PM
heathnson
heathnson is offline
New User
Join Date: May 2004
Posts: 7
heathnson is starting off with a positive reputation.
This model does not have a vac modulator.
 
  #11  
Old 05-11-2004, 02:36 PM
heathnson
heathnson is offline
New User
Join Date: May 2004
Posts: 7
heathnson is starting off with a positive reputation.
You may want to check or have someone check to make sure the valve body bolts are tight. These tranys are notorious for having loose valve body bolts, which can cause many problems.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bruno2
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
158
02-21-2014 06:34 PM
freaks97
1994.5 - 1997 7.3L Power Stroke Diesel
141
01-09-2013 08:30 AM
serving_time
Clutch, Transmission, Differential, Axle & Transfer Case
4
11-02-2005 06:52 PM
lashk
Cooling, Heating, Ventilation & A/C
1
02-13-2004 09:43 PM
albertaguy
1978 - 1996 Big Bronco
3
02-21-2002 07:17 PM


Thread Tools
Search this Thread
Quick Reply: 95 tranny


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.