Notices
6.7L Power Stroke Diesel 2011-current Ford Powerstroke 6.7 L turbo diesel engine
Sponsored by:
Sponsored by:

help please

 
  #1  
Old 11-10-2018, 08:00 PM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
help please

i have a 2016 f350 powestroke with dual climate control i seem to have no heat on the drivers side of the truck both accuators are working and so is the blend door not sure where to look next thanks in advance also just deleted the truck with a patriot tuner egr delete
 
  #2  
Old 11-10-2018, 10:10 PM
Superdave71
Superdave71 is offline
Senior User
Join Date: Dec 2016
Location: Knightstown Indiana
Posts: 321
Superdave71 is gaining momentum as a positive member of FTE.
Itís possible that you have a big slug of air in the coolant. As you deleted, did you refill under vacuum? You may just need to drive it awhile and check coolant level.
 
  #3  
Old 11-11-2018, 06:01 AM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
no i didnt refill under vaccum just trying to figure out why there isfull heat on the passeger side and not the drivers side is there two heater cores? the ford dealer i talked to yesterday said that they would need to pull the full dash out and pull the heaterbox out as well. i wasnt sure how many acctuators there are on the heater box. the diagram i found showed 2 that control the heat heat and you can see them both working. I put a bore camera down the vent and can see all the doors moving when the controls are turned
 
  #4  
Old 11-11-2018, 07:12 AM
Superdave71
Superdave71 is offline
Senior User
Join Date: Dec 2016
Location: Knightstown Indiana
Posts: 321
Superdave71 is gaining momentum as a positive member of FTE.
There was another guy on here this week with the same problem after flushing his coolant. It was mentioned there are separate heater cores for the split heat, you might have air in one. Drive it awhile and see if it burps. I did. It refill mine under vacuum and after a thousand miles or so I had to add a couple quarts more distilled water.
 
  #5  
Old 11-11-2018, 07:44 AM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
ok i will try that i dont have alot of miles on it after the delete and see if it burps
 
  #6  
Old 11-11-2018, 02:24 PM
ajorn's Avatar
ajorn
ajorn is offline
Senior User
Join Date: Nov 2005
Location: Houghton, MI
Posts: 311
ajorn is starting off with a positive reputation.
I'm having the same issue. I applied vacuum to my coolant system and saw no change. Good heat on passenger side, none on driver. I'm not sure either.


I've driven about 150 miles since the coolant flush, no changes in level.
 
  #7  
Old 11-11-2018, 02:35 PM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
yeah me either drove about 150 miles today to see if that would help but no change either all the parts diagrams i have looked at show only 2 doors to control heat mine are both working i am not sure if i messed somethimg up on the egr delete or what after idid the delete i had to keep putting coolant in for a few days like a couple of quarts or so but the levels have been good for a week or so. is it possible for the right side thermostat could be stuck?
 
  #8  
Old 11-13-2018, 01:07 PM
ajorn's Avatar
ajorn
ajorn is offline
Senior User
Join Date: Nov 2005
Location: Houghton, MI
Posts: 311
ajorn is starting off with a positive reputation.
I'm not sure. In the next week or so in going to drain the radiator and then pull vacuum and fill again to see if that helps.
 
  #9  
Old 11-13-2018, 03:09 PM
Readgriff
Readgriff is offline
Senior User
Join Date: May 2017
Location: Michigan
Posts: 140
Readgriff is starting off with a positive reputation.
I had a Chevy truck the battery went dead and did all kinds of things to the heating / cooling in cab.
Would of never thought that this was the problem had to disconnect the battery turn key on and reconnect battery.
Something like that worked fine after that.
Running battery dead does funny things.
 
  #10  
Old 01-25-2019, 03:04 PM
ajorn's Avatar
ajorn
ajorn is offline
Senior User
Join Date: Nov 2005
Location: Houghton, MI
Posts: 311
ajorn is starting off with a positive reputation.
Just got back from the dealer, they have seen multiple plugged heater cores - that is probably what my issue is. *No heat on driver side, heat on passenger side.
 
  #11  
Old 01-25-2019, 03:32 PM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
help please

The dealer found that my heater core was plugged also and put a new one in and also I had a control door was bad as well but know I am having the oil temps running very high so I am going to flush and replace the oil cooler
 
  #12  
Old 01-25-2019, 04:13 PM
ajorn's Avatar
ajorn
ajorn is offline
Senior User
Join Date: Nov 2005
Location: Houghton, MI
Posts: 311
ajorn is starting off with a positive reputation.
What did they charge you for the core replacement? I had a tech tell me he could get it done in about 3 hours but the book calls for 12 so that's what they will charge.

My buddy works at a shop and has a flushing machine, I may try that first...
 
  #13  
Old 01-25-2019, 04:44 PM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
Help please

the dealer replaced the the core they told me the dash had to come out the dealer where I went to did charge me for 10 hours
 
  #14  
Old 01-25-2019, 04:45 PM
benny1068
benny1068 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 7
benny1068 is starting off with a positive reputation.
Help please

the cost of the core was like 110 dollars
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: