1978 Bronco Custom T/S - Ford Truck Enthusiasts Forums



1978 - 1996 Big Bronco  
Sponsored by:
Sponsored by:

1978 Bronco Custom T/S

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-15-2017, 12:03 AM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
1978 Bronco Custom T/S

Three days ago I acquired a 1978 Bronco Custom Trailer Special. Prior to buying it, I had mentioned to my wife that I saw a "cheap" Bronco and thought it might be cool to get it. She proceeded to give me an earful citing the fact I've been spending a lot of money fixing up my '77 F100 SWB 2wd. Needless to say, she told me no and to save my other ear from getting full, I said ok. A Couple days later I meet the guy selling the Bronco at a gas station nearby and I give it a once over. He takes me for a spin in it. I took him for a spin in it. He complimented me by saying I was the first "normal" person to contact him about it and that I actually had cash. Others had offered him things such as a four wheeler or a 7mm rifle in trade for it and cash ended up being king. He signed over the title and gave it to me along with the key, I gave him $700 and had him park it in front of his house which was a couple blocks away and told him I'd be back later to get it.

The next day I went and got it while my wife was out of the house. I parked it out front where my F100 normally sits. She came home and you would have thought she caught me cheating on her with someone in our house or something. "We talked about this! I said no!" "Yeah, you did." Followed by a few closed fists and tears. I was not expecting that. At all. It took about 30 minutes and she calmed down. I have a fiery wife, maybe it's the red hair, I don't know. She refers to the Bronco and I as "You and your Mojón!". She's half Mexican, he father is Mexican, and apparently that's slang for... a big torpedo shaped s-word. I think it's very fitting. I don't normally name vehicles, but I think I'll be referring to my Bronco as el mojón. My wife's finally coming around to the idea of it, she made me take her for a ride in it and I pointed out the rear seat and how all the kids can fit in the back if we ever want to go play off-road together. You really gotta sell this stuff guys! I even loaded them all up and buckled them in and saw how excited they got.

I don't have any pictures of el mojón that I've taken myself, yet, but I'll put the ones from the ad the guy posted. It needs a lot of work and since I have more reliable transportation than I did about 6 months ago, I'll be able to take my time, figure out how to do things I haven't in the past, and do as much of the major work myself instead of having shops handle it. Usually when my sole mode of transportation needs work, that's what I do since I can't risk having it taken apart and not getting it back together in time to go to work. I'll have to start making a list of stuff to go through.
Reply With Quote
  #2  
Old 09-15-2017, 12:04 AM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.










Reply With Quote
  #3  
Old 09-15-2017, 08:48 PM
grumpin's Avatar
grumpin grumpin is offline
Senior User
 
Join Date: Feb 2017
Location: Oregon
Posts: 181
grumpin is gaining momentum as a positive member of FTE.
Looks like your wife is good at naming things! What does she call you?

Just kidding! She's a beauty!
Reply With Quote
  #4  
Old 09-15-2017, 09:00 PM
walter white walter white is offline
Junior User
 
Join Date: Apr 2015
Location: charlotte nc
Posts: 76
walter white is starting off with a positive reputation.
congrats-- that has a ton of potential
Reply With Quote
  #5  
Old 09-16-2017, 11:16 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
Well I've had a little bit of time to fiddle with it and investigate things. The warranty tag's telling me it was ordered out of Dallas. It came with a 351m, NP205 t-case, and a NP435 4 speed. Fordification's database says the 9" rear has 3.50 gears, but the PO said it was 4.10. I'll spin the wheels and count the drive shaft turns to find out what's in there. The t-case goes into all ranges, but 4 low likes to pop out into neutral constantly. The engine runs well. I think there's an exhaust leak somewhere. It got an edelbrock intake and carb at some point. The underhood wiring makes me let out a huge sigh. I keep grabbing stuff and wondering why its just dangling. Found a three prong plug dangling by the grill, I hope its a block heater and nothing hokey. Its missing about half the factory ac components as far as I can tell. The heater controls work, you can hear vacuum opening and closing doors, but the fan doesn't kick on. Might be a loose plug behind the dash. The steering column is tight with no play, but I think there's a lot of play in the steering box itself, other than that it drives super straight. There appears to be work needed in the brake department, it feels like only the rear drums are trying to slow this beast down. Sounds like a nightmare to some, but I'm really excited although this is the first time I'll be dealing with a 4x4. I love working on these old trucks.
Reply With Quote
  #6  
Old 09-21-2017, 12:54 AM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I got both axles up today and spun the wheels. I locked the front hubs and both wheels went in different directions, so open diff there. Spun the rear and same deal, open front and back. I guess that makes sense, its a custom, not a high trim package, and its a T/S. Unless you're pulling trailers through some rough terrain you're probably not needing limited slip. So open diff means spin the tire twice and count drive shaft rotations, limited slips you only spin once. I got exactly 3 1/2 driveshaft rotations, so 3.50 gearing, which matches the warranty tag. Gotta love sellers lying through their teeth, although I didn't buy it for the alleged 4.10 gearing. Just means there's at least one thing that hasn't been f'd with on this 39 year old.

I have a question if anyone cares to answer. This Bronco will chirp the rear tires while turning at slow speeds at full or near full lock, I've gotten a few looks from people when it happens as if its intentional. My '77 F100 doesn't do that with its open diff. Isn't that something a locker would do? I'm confused because of the way the wheels spun when I was checking the rear end gearing suggested an open differential. Again, I'm new to 4x4's, so I don't know if its something inherent to this old 4x4 setup.

P.S. I'm LOVIN' the stick shift, wish my '77 had one!
Reply With Quote
  #7  
Old 09-21-2017, 06:48 AM
schwim's Avatar
schwim schwim is offline
Freshman User
 
Join Date: Apr 2016
Posts: 31
schwim is starting off with a positive reputation.
Are you sure it's the rear making the noise? On certain types of asphalt, mine will do a bit of chirping at full lock from the inner front wheel. These 4x4's have quite a wonky track and alignment on the front a full lock, it seems.
Reply With Quote
  #8  
Old 09-21-2017, 07:19 AM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I'll have to check again next time I drive it when its dry out. We're experiencing a lot of rain and you can't really hear chirps when its slick out. It sure seemed like the rear, but I've been wrong before and I'll be wrong again.
Reply With Quote
  #9  
Old 09-22-2017, 08:43 PM
RalphXL RalphXL is offline
Junior User
 
Join Date: Nov 2015
Posts: 57
RalphXL is starting off with a positive reputation.
Think I have more than $700 in just patch panels for my '79. Sigh.

Jess
Reply With Quote
  #10  
Old 09-24-2017, 09:25 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I haven't driven it to check if it's the front or rear chirping yet. It's getting pretty cold here now and I wanted to see if I could get the heater working. The doors move when you change the selector and you can hear vacuum, so from past experience I figure a loose/unplugged connection on the fan switch. Well! It wasn't loose or unplugged! Worse. It was burnt/melted. Not sure what happened, but it's toast. I'll have to find another switch for it. My 75 F150 has one, but it's a different style than this 78. I was able to find a new connector for the harness side of things though. The fuel selector switch on my 75 uses the same plug style so I popped it off and I'll use that to see if I can salvage the harness, I don't want to cut and splice. What do you guys think, any ideas on what might have caused this? I'm going over the wiring slowly. I don't want to get a new one in and have it burn up immediately because of something screwy in there. I'm taking out the aftermarket stereo that someone put in it. I really hate it when these dashes get cut up. I did that to my 75 when I first got it at 15 and I have regretted it since.











Reply With Quote
  #11  
Old 09-24-2017, 10:53 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I had a bad case of hyperblink/hyperflash along with very dim blinkers at that. Blinking problem was bad flashers. One says Motorcraft and the other is Ford, might be originals, who knows. The hazards still don't work, I'll investigate further. I think corroded sockets is contributing to the dim lights. I took out the driver side bulb and the ground looks bad similar to how my 77 was and I had to eventually replace the ones on my 77. I left the blinker going and it'd be dim and when I'd push the bulb in as far as I could it would start flashing brighter and when I'd let go it'd go dim again. It was blinking with the parking light filament and would switch filaments when I'd push it in. Weird stuff. I'll mess with it some more later.



Reply With Quote
  #12  
Old 09-24-2017, 10:55 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I think the back seat is about the "nicest" thing in the interior.




Reply With Quote
  #13  
Old 09-24-2017, 10:56 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I'm guessing it had some KC lights on it at some point. Just more wires to trace and remove for now. Gotta tidy things up!




Reply With Quote
  #14  
Old 09-24-2017, 10:58 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I'll see if I can use the e-brake release from my 75 to fix this.




Reply With Quote
  #15  
Old 09-24-2017, 11:03 PM
75BigBlock's Avatar
75BigBlock 75BigBlock is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Southern Idaho
Posts: 356
75BigBlock is starting off with a positive reputation.
I'll need to source a new hood latch/cable/release. I don't know if I can just replace the cable or not. The latch seems to work pretty good, though it's ghetto for now. It's creative I guess. lol. I don't think I would have done it that way.






Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Larry Flip4ford Kansas Chapter 15 08-31-2017 04:15 PM
second chance? wallster 1948 - 1956 F1, F100 & Larger F-Series Trucks 37 06-27-2017 07:07 AM
$750 Private Cash Florit17 2017+ Super Duty 10 11-13-2016 06:58 AM
will a bad turbo cause constant smoke? Etone Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 5 02-13-2016 07:34 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:59 PM.