Turn signal problems/ needs fixed ASAP!! - Ford Truck Enthusiasts Forums

Notices
1973 - 1979 F-100 & Larger F-Series Trucks Discuss the Dentsides Ford Truck

Turn signal problems/ needs fixed ASAP!!

 
  #1  
Old 03-24-2012, 02:37 PM
NW 150's Avatar
NW 150
NW 150 is offline
Posting Guru
Thread Starter
Join Date: Jun 2007
Location: Ohio
Posts: 1,929
NW 150 is starting off with a positive reputation.
Turn signal problems/ needs fixed ASAP!!

My 75 f100 has problems with the turn signals:
  1. The front signals do nothing.
  2. The rear signals work from time to time, but have a sporadic pulse and are not very bright when they do work.
  3. If I press the brake pedal and select the left signal, that brake light will go out and do nothing, and won't come back on until I turn off the signal. Same goes for the other side.
I need to know where/what to look at, what I should replace, etc. This needs to be fixed ASAP or obviously I can't drive it, and that's not acceptable.
 
  #2  
Old 03-24-2012, 03:50 PM
devino246's Avatar
devino246
devino246 is offline
Post Fiend
Join Date: Mar 2011
Location: Lynchburg, VA
Posts: 8,501
devino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputationdevino246 has a superb reputation
Check your grounds with a multi-meter or test light.
 
  #3  
Old 03-24-2012, 06:00 PM
NW 150's Avatar
NW 150
NW 150 is offline
Posting Guru
Thread Starter
Join Date: Jun 2007
Location: Ohio
Posts: 1,929
NW 150 is starting off with a positive reputation.
I Sanded down all of the ground connections and covered them with electrical grease and they worked again. The only problem that remains is that when the parking lights are on, the blink of the turn signals are so faint that it's pointless to even use them. If the parking lights are off though, the blinks are as bright as they will ever need to be for someone to see them. Any suggestions?
 
  #4  
Old 03-24-2012, 07:14 PM
fmc400's Avatar
fmc400
fmc400 is offline
MSEE
Join Date: Apr 2004
Location: Austin, TX
Posts: 10,386
fmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud offmc400 has much to be proud of
Originally Posted by NW 150 View Post
The only problem that remains is that when the parking lights are on, the blink of the turn signals are so faint that it's pointless to even use them. If the parking lights are off though, the blinks are as bright as they will ever need to be for someone to see them.
This means it's time to replace the sockets.
 
  #5  
Old 03-24-2012, 11:07 PM
NW 150's Avatar
NW 150
NW 150 is offline
Posting Guru
Thread Starter
Join Date: Jun 2007
Location: Ohio
Posts: 1,929
NW 150 is starting off with a positive reputation.
So just get two new ones and cut/connect the wires and that should fix it?
 
  #6  
Old 03-25-2012, 11:56 AM
Ohiocrewcab's Avatar
Ohiocrewcab
Ohiocrewcab is offline
Senior User
Join Date: Jan 2012
Posts: 393
Ohiocrewcab is gaining momentum as a positive member of FTE.
You might want to make sure everything is connected right when yo put the new sockets in. I had an issue with my old 77 that the p.o. wired it wrong and the parking lights were comming on as the bright side of the bulb and the turn signals were the dim side. You couldnt see them at all at night.
 
  #7  
Old 03-25-2012, 01:05 PM
NW 150's Avatar
NW 150
NW 150 is offline
Posting Guru
Thread Starter
Join Date: Jun 2007
Location: Ohio
Posts: 1,929
NW 150 is starting off with a positive reputation.
I'll have to look into that, although none of the wires have ever been switched, all are the same color going to the same color wire.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rworld
Excursion - King of SUVs
12
12-28-2016 10:42 PM
Harleyford700
2004 - 2008 F150
0
02-26-2016 02:28 PM
AADAD
1999 to 2016 Super Duty
4
07-30-2015 07:26 AM
mweeks
1961 - 1966 F-100 & Larger F-Series Trucks
0
05-20-2015 08:46 AM
MyMalteseFalcon
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
8
03-01-2014 06:29 PM


Thread Tools
Search this Thread
Quick Reply: Turn signal problems/ needs fixed ASAP!!


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.