Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Ahhhh chit

 
  #1  
Old 11-28-2011, 02:33 PM
A/Ox4's Avatar
A/Ox4
A/Ox4 is online now
9 ECHO 1
Thread Starter
Join Date: Aug 2009
Location: Missouri
Posts: 12,213
A/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputation
Ahhhh chit

So I'm sitting at a stop light, no big deal. Light turns green and I press the go pedal.

Truck dies for 1/4 of a second and then comes back like nothing happened.

Sound like a CPS?
I don't have a spare right now. Don't even know which I have in right now. But I'll bet I have the recall replacement.
 
  #2  
Old 11-28-2011, 02:52 PM
woodnthings's Avatar
woodnthings
woodnthings is offline
Postmaster
Join Date: May 2010
Location: Lake Stevens, WA
Posts: 2,948
woodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud of
Throttle pedal assy would be my guess. Probably the IVS is sticking.
 
  #3  
Old 11-28-2011, 02:54 PM
Milwaukee1979F150's Avatar
Milwaukee1979F150
Milwaukee1979F150 is offline
Posting Guru
Join Date: Jan 2008
Location: Trenton, MI
Posts: 2,408
Milwaukee1979F150 is gaining momentum as a positive member of FTE.
Originally Posted by woodnthings View Post
Throttle pedal ***'t would be my guess. Probably the IVS is sticking.

I believe that for 02-03 it had lawsuit on it.

Is it rain in your area when it died? It could be cps.

Mine would running but cut off on highway it pause for 3-4 then run again. It does that during rain.
 
  #4  
Old 11-28-2011, 03:11 PM
Robert6401's Avatar
Robert6401
Robert6401 is offline
Postmaster
Join Date: Feb 2005
Location: Gilbert, SC
Posts: 2,837
Robert6401 is a splendid one to beholdRobert6401 is a splendid one to beholdRobert6401 is a splendid one to beholdRobert6401 is a splendid one to beholdRobert6401 is a splendid one to beholdRobert6401 is a splendid one to behold
Could also be impending IDM failure. Mine did that shortly before dying completely. I would get home or to a shop.
 
  #5  
Old 11-28-2011, 03:15 PM
A/Ox4's Avatar
A/Ox4
A/Ox4 is online now
9 ECHO 1
Thread Starter
Join Date: Aug 2009
Location: Missouri
Posts: 12,213
A/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputation
It's not raining right now. Also, when it happened I think my tach died. But it was fast and wasn't looking right at it so im not sure
 
  #6  
Old 11-28-2011, 07:44 PM
woodnthings's Avatar
woodnthings
woodnthings is offline
Postmaster
Join Date: May 2010
Location: Lake Stevens, WA
Posts: 2,948
woodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud ofwoodnthings has much to be proud of
Thinking about it more it could be an ICP or IPR issue more than the throttle pedal. Earlier I missed the fact that it stumbled too. Have you checked the ICP sensor for oil on the connector?
 
  #7  
Old 11-28-2011, 08:59 PM
A/Ox4's Avatar
A/Ox4
A/Ox4 is online now
9 ECHO 1
Thread Starter
Join Date: Aug 2009
Location: Missouri
Posts: 12,213
A/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputationA/Ox4 has a superb reputation
Originally Posted by woodnthings View Post
Thinking about it more it could be an ICP or IPR issue more than the throttle pedal. Earlier I missed the fact that it stumbled too. Have you checked the ICP sensor for oil on the connector?
Nope. Should I? haha
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chiefsfootball
1967 - 1972 F-100 & Larger F-Series Trucks
7
11-18-2014 04:21 PM
1980302windsor
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
10
02-28-2011 06:06 PM
Tacswa3
6.7L Power Stroke Diesel
19
11-04-2010 09:03 PM
countryboy116
1997 - 2003 F150
8
03-25-2008 01:50 PM
captain p4
1997 - 2003 F150
3
07-27-2005 04:02 PM


Thread Tools
Search this Thread
Quick Reply: Ahhhh chit


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.