Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Computer Chips & Tuners
Sign in using an external account
Register Forgot Password?


Computer Chips & Tuners SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-27-2014, 12:02 AM
2002exPSD's Avatar
2002exPSD 2002exPSD is offline
Elder User
 
Join Date: Nov 2008
Location: Kenner LA
Posts: 676
2002exPSD has a good reputation on FTE.2002exPSD has a good reputation on FTE.
Edge cts fried my ECM and itself

So went out to the ex today and decided to put it on extreme mode. Went threw the programming and the program got to bank 4 of 4 98% then shut off and smoke came out the unit. I quickly disconnected it and let it sit for an hour. Plugged it back in and was amazed it turned on. Went threw the setup process and it gives me a voltage error. Checked voltage at batteries and have 12.6 on each. Tried to start the truck and cranks no start. Theft light flashing fast. So something wrong with the pats module. Checked all fuses and relays. Tried my other original key to no avail. Hooked up my genisis evo scan tool and I can't communicate with the ECM or the pats system. Calling my ford buddy (35 years exp) comming over tomorrow. He thinks the ECM is fried. What can edge do about this? Buy me another ECM and give me my money back on their programmer? Going dp tuner after this.
__________________
2002 ford excursion 7.3 diesel 4x4 edge evolution, mbrp 4'' SS straight piped, afe stage 2 true cold air intake with zoodad mod, thruster II turbo, adrenaline hpop, John woods valve body, +8 deep trans pan, 6.0 trans cooler, 6.0 intercooler, 2004 Harley davidson wheels, ebc greenstuff brake pads, x-codes, ranchhand grille guard, and one badazz sound system.
2001 ford ranger 4.0 4x4 2003 4.0 swap, dual flowmaster exhaust. Just the play truck
Reply With Quote
  #2  
Old 07-27-2014, 09:06 AM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,579
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
Quote:
Originally Posted by 2002exPSD View Post
What can edge do about this? Buy me another ECM and give me my money back on their programmer?
In my non-legal minded opinion, in order to get Edge to do remotely anything, you would have to show definitively that it did indeed cause this issue. I'm not saying it didn't, but I don't know that it did either.

I find it strange that you didn't find any fuses that were blown, particularly the one to the cigarette lighter as that is shared with the OBD-II port for power (at least on the 6.0 it is). I have seen the lighter blow fuses and ruin itself as well (I had to replace one myself on my 02 dodge). You would never know unless you tried to plug something up into either the lighter or the OBD-II port, so depending on how often you plug up to any of those ports, it could have happened a long time ago. I know, I sold an xCal 2 to a user from the 6.0 forums here and we couldn't get the unit to power up in his truck, but it would for mine, turned out to be a blown fuse. Everything else operated as it should.


I would check that fuse again and make sure that there isn't a small crack, burn in that and make sure that it's the correct fuse for that spot. I just find it surprising that you hadn't found a blown fuse, that's the whole point of having fuses is to help prevent an electronic device from pulling too much juice, which is an inherent risk of any electronic device.

Although, I have heard of one other person on this group that was blaming Edge for a situation like this. I don't know what became of that, I don't recall him saying. So there is that.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
  #3  
Old 07-27-2014, 10:22 AM
2002exPSD's Avatar
2002exPSD 2002exPSD is offline
Elder User
 
Join Date: Nov 2008
Location: Kenner LA
Posts: 676
2002exPSD has a good reputation on FTE.2002exPSD has a good reputation on FTE.
Checked fuse 12 already 20 amp fuse. Replaced fuse 12,19,36,44. All fuses were good. Just took a precaution. Cigarette lighter always has gps plugged in it. Gps still working.
__________________
2002 ford excursion 7.3 diesel 4x4 edge evolution, mbrp 4'' SS straight piped, afe stage 2 true cold air intake with zoodad mod, thruster II turbo, adrenaline hpop, John woods valve body, +8 deep trans pan, 6.0 trans cooler, 6.0 intercooler, 2004 Harley davidson wheels, ebc greenstuff brake pads, x-codes, ranchhand grille guard, and one badazz sound system.
2001 ford ranger 4.0 4x4 2003 4.0 swap, dual flowmaster exhaust. Just the play truck
Reply With Quote
  #4  
Old 07-27-2014, 11:19 AM
2002exPSD's Avatar
2002exPSD 2002exPSD is offline
Elder User
 
Join Date: Nov 2008
Location: Kenner LA
Posts: 676
2002exPSD has a good reputation on FTE.2002exPSD has a good reputation on FTE.
My buddy ken came over with his IDS scan tool. ECM is done. Totally fried.
__________________
2002 ford excursion 7.3 diesel 4x4 edge evolution, mbrp 4'' SS straight piped, afe stage 2 true cold air intake with zoodad mod, thruster II turbo, adrenaline hpop, John woods valve body, +8 deep trans pan, 6.0 trans cooler, 6.0 intercooler, 2004 Harley davidson wheels, ebc greenstuff brake pads, x-codes, ranchhand grille guard, and one badazz sound system.
2001 ford ranger 4.0 4x4 2003 4.0 swap, dual flowmaster exhaust. Just the play truck
Reply With Quote
  #5  
Old 07-28-2014, 07:29 AM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,579
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
I'm not surprised that the ECM is fried considering that you said the Edge tuner was smoking. I'm just surprised that it was so localized of an issue and fuses didn't blow. Fuses should below before you have uses like that, that's the point of fuses, otherwise you have issues like that.

Unfortunately, I can see that being used against you though. I don't know though, I might be surprised, especially if it is more of a widespread problem then just the two that I've heard about.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
  #6  
Old 07-28-2014, 11:58 AM
DP-Tuner's Avatar
DP-Tuner DP-Tuner is offline
PREMIUM SPONSOR
 
Join Date: Mar 2005
Location: Hoschton,GA
Posts: 1,798
DP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to beholdDP-Tuner is a splendid one to behold
Quote:
Originally Posted by 2002exPSD View Post
So went out to the ex today and decided to put it on extreme mode. Went threw the programming and the program got to bank 4 of 4 98% then shut off and smoke came out the unit. I quickly disconnected it and let it sit for an hour. Plugged it back in and was amazed it turned on. Went threw the setup process and it gives me a voltage error. Checked voltage at batteries and have 12.6 on each. Tried to start the truck and cranks no start. Theft light flashing fast. So something wrong with the pats module. Checked all fuses and relays. Tried my other original key to no avail. Hooked up my genisis evo scan tool and I can't communicate with the ECM or the pats system. Calling my ford buddy (35 years exp) comming over tomorrow. He thinks the ECM is fried. What can edge do about this? Buy me another ECM and give me my money back on their programmer? Going dp tuner after this.

Excursions are temperamental for sure. Do you know if the Edge preformed the PATS re-program. If not it probable got pissed off enough to not let the truck start and is why you are sitting with a dead truck. Before you do anything expensive call Edge tech support for their advice.

~Diane
__________________
Jody & Diane Tipton- DP-Tuner®
FTE Legacy Sponsors since 2006
Custom tuning for 7.3l, 6.0l, 6.4l and 6.7l
Get Tuned! 828-221-0076 ext. 802
Become our Facebook Fan
Reply With Quote
  #7  
Old 07-28-2014, 09:04 PM
2002exPSD's Avatar
2002exPSD 2002exPSD is offline
Elder User
 
Join Date: Nov 2008
Location: Kenner LA
Posts: 676
2002exPSD has a good reputation on FTE.2002exPSD has a good reputation on FTE.
Edge told me to grab the cts plug it into computer and download the software they emailed. Then hook it to truck and try to reconnect to the truck. Same message displayed voltage failure. Told me to send the tuner to them they think there's something wrong with it. I kept trying to tell them the ECM is fried. They said it's the tuner not the ECM. What am I supposed to do in the meantime? Pull my 9000 lb work trailer with my ranger?

Yanked the ECM out in the meantime. Took it apart. Smelled burnt and there's a spot that's melted. So both the cts and my ECM is fried.
__________________
2002 ford excursion 7.3 diesel 4x4 edge evolution, mbrp 4'' SS straight piped, afe stage 2 true cold air intake with zoodad mod, thruster II turbo, adrenaline hpop, John woods valve body, +8 deep trans pan, 6.0 trans cooler, 6.0 intercooler, 2004 Harley davidson wheels, ebc greenstuff brake pads, x-codes, ranchhand grille guard, and one badazz sound system.
2001 ford ranger 4.0 4x4 2003 4.0 swap, dual flowmaster exhaust. Just the play truck
Reply With Quote
  #8  
Old 07-28-2014, 09:29 PM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,579
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
Quote:
Originally Posted by 2002exPSD View Post
Pull my 9000 lb work trailer with my ranger?
I see people around here do far worse then that. It's downright scary.

Quote:
Originally Posted by 2002exPSD View Post
Yanked the ECM out in the meantime. Took it apart. Smelled burnt and there's a spot that's melted. So both the cts and my ECM is fried.
Yea, I sure wouldn't trust it, that's for sure.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
Old 07-28-2014, 09:29 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
P1639 Question cgouldy 1997 - 2003 F150 1 06-21-2013 01:27 AM
HELP With A Ford 460 ECM Computer kennyr 1987 - 1996 F150 & Larger F-Series Trucks 2 07-10-2011 12:25 AM
Evolution programmer killed ECM?? stubborn66 1994.5 - 1997 7.3L Power Stroke Diesel 19 02-18-2011 02:02 PM
ECM issues? or programmer issues? Oversize 1994.5 - 1997 7.3L Power Stroke Diesel 1 02-24-2009 08:49 PM
Ranger ECM help please? Duh_Vinci Ranger & B-Series 2 04-20-2008 02:57 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Computer Chips & Tuners

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 09:02 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup