Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

01 7.3 starting problem

 
  #1  
Old 05-07-2010, 08:39 PM
wyattwie
wyattwie is offline
New User
Thread Starter
Join Date: May 2010
Posts: 3
wyattwie is starting off with a positive reputation.
01 7.3 starting problem

My o1 wont cyle the glow plugs, if I jump the gpr it fires up. I have changed the relay no change. There is power to the timer and the relay but with the key on the relay wont power up the glowplug side and there is power to the small terminals with the key on. Checked all the fuses and fuseable links around the timer and the relay. What is next?
Thanks
 
  #2  
Old 05-07-2010, 09:12 PM
F350-6's Avatar
F350-6
F350-6 is offline
Post Fiend
Join Date: Mar 2007
Location: Texas
Posts: 26,923
F350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputation
Welcome to FTE. There are 4 posts on the GPR (glow plug relay) 1 large post is battery voltage in that is always hot. The other large post is voltage out to the glow plugs. The smaller posts sound like the ones you're having issues with. The way the GPR works is one of the small posts that reads hot with the key off will receive a ground signal from the PCM (computer) to activate the relay. Sounds like you've lost the ground signal from the PCM.

If you've got a volt meter, check the voltage both key on and key off at each of the 4 posts on the GPR and report back.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HollowayDoc
1999 - 2003 7.3L Power Stroke Diesel
32
03-20-2015 03:49 PM
med-care-guy
1999 - 2003 7.3L Power Stroke Diesel
7
06-07-2012 02:48 PM
Bwag608
6.0L Power Stroke Diesel
11
04-23-2012 11:58 AM
woodie92250
1994.5 - 1997 7.3L Power Stroke Diesel
3
02-16-2012 02:08 PM
Daewoo
Excursion - King of SUVs
8
02-10-2012 09:28 PM


Thread Tools
Search this Thread
Quick Reply: 01 7.3 starting problem


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.