Driver's heated/cool seat doesn't work properly - Page 2 - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997-2006 Expedition & Navigator
Reload this Page >

Driver's heated/cool seat doesn't work properly

Notices
1997-2006 Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator Discussion

Driver's heated/cool seat doesn't work properly

 
  #16  
Old 10-28-2009, 02:41 PM
fprodget
fprodget is offline
New User
Join Date: Jun 2006
Location: Lancaster PA
Posts: 10
fprodget is starting off with a positive reputation.
Thanks

What is a good source for inexpensive Ford Factory parts?

John H
2005 Eddie Bauer Expedition
2008 Honda Civic Hybrid
Lola T640 Formula Ford <!-- / sig -->
 
  #17  
Old 10-28-2009, 03:00 PM
FTE/PARTS-GUY
FTE/PARTS-GUY is offline
Former Vendor
Join Date: May 2007
Posts: 1,811
FTE/PARTS-GUY has a great reputation on FTE.FTE/PARTS-GUY has a great reputation on FTE.FTE/PARTS-GUY has a great reputation on FTE.FTE/PARTS-GUY has a great reputation on FTE.FTE/PARTS-GUY has a great reputation on FTE.
inexpensive ford parts

check out our website WWW.FTEPARTSGUY.COM
 
  #18  
Old 10-29-2009, 08:48 AM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Join Date: Feb 2008
Posts: 2,309
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
It was p/n 5L1Z-19N550-AA Blower Asy - Vent Air - CCS
 
  #19  
Old 10-29-2009, 09:09 AM
fprodget
fprodget is offline
New User
Join Date: Jun 2006
Location: Lancaster PA
Posts: 10
fprodget is starting off with a positive reputation.
Originally Posted by alwaysfords41 View Post
It was p/n 5L1Z-19N550-AA Blower Asy - Vent Air - CCS

Thanks Much! I have one on order from Tasca Ford. I ordered from Tasca as they were much closer to PA than the dealer from Washington State.

________________________
John H
2005 Eddie Bauer Expedition
2008 Honda Civic Hybrid
Lola T640 Formula Ford <!-- / sig -->
 
  #20  
Old 11-08-2009, 05:14 PM
fprodget
fprodget is offline
New User
Join Date: Jun 2006
Location: Lancaster PA
Posts: 10
fprodget is starting off with a positive reputation.
Okay...What next??? I installed new fan today and still same symptoms. Fan starts and turns off maybe in 15 seconds. it does this for both heat and cool functions.



______________________________
John H
2005 Eddie Bauer Expedition
2008 Honda Civic Hybrid
Lola T640 Formula Ford <!-- / sig -->
 
  #21  
Old 11-09-2009, 09:05 AM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Join Date: Feb 2008
Posts: 2,309
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
That's not good, or what I expected. When I was chasing mine down the fan took care of it. Your passenger side is fine, right? Maybe a relay for the d/s is shot somewhere? I believe they are fused separately too - maybe some poor contact on the d/s that opens a circuit after a little current flows?
 
  #22  
Old 11-09-2009, 01:11 PM
fprodget
fprodget is offline
New User
Join Date: Jun 2006
Location: Lancaster PA
Posts: 10
fprodget is starting off with a positive reputation.
Yes the passenger side works fine. I will look again at the facotry shop manual, but it seems many of the tests indicated require the Ford Diagnostic system to verify proper functions.


______________________________
John H
2005 Eddie Bauer Expedition
2008 Honda Civic Hybrid
Lola T640 Formula Ford
 
  #23  
Old 07-16-2014, 01:26 PM
KleetusF250's Avatar
KleetusF250
KleetusF250 is offline
New User
Join Date: Jun 2014
Posts: 7
KleetusF250 is starting off with a positive reputation.
So what was the final outcome of this? The blower didn't fix it, so what was the culprit?

Thanks!
 
  #24  
Old 07-16-2014, 02:25 PM
fprodget
fprodget is offline
New User
Join Date: Jun 2006
Location: Lancaster PA
Posts: 10
fprodget is starting off with a positive reputation.
I never solved it. I traded the expedition on a V8 Volvo XX90 years ago and haven't looked back.
 
  #25  
Old 07-16-2014, 04:54 PM
KleetusF250's Avatar
KleetusF250
KleetusF250 is offline
New User
Join Date: Jun 2014
Posts: 7
KleetusF250 is starting off with a positive reputation.
Augh.... I love my LS, but since Lincoln is more worried about playing 'me too' with the lame *** crossovers and old fart cars, instead of building a car for 40 something professionals, my next ride is going to be the LS 2.0... aka Jaguar XFR.

Rest of the car still works great with 142k on the clock, transmission gets a little dippy from time to time, but WOT it never disappoints. Maybe I'll keep her as my beater.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ROADRUNNER1
2017+ Super Duty
3
06-03-2017 02:07 PM
AMCHARRIS
Excursion - King of SUVs
3
05-22-2017 01:55 PM
Markyboy
1999 to 2016 Super Duty
5
06-30-2016 10:28 AM
sandroost
2007 - 2014 Expedition & Navigator
6
01-22-2016 02:49 PM
mhopton
2007 - 2014 Expedition & Navigator
3
10-09-2013 06:53 AM


Thread Tools
Search this Thread
Quick Reply: Driver's heated/cool seat doesn't work properly


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.