Possible turbo problem - Ford Truck Enthusiasts Forums

Notices
6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van

Possible turbo problem

 
  #1  
Old 03-14-2019, 03:23 PM
dr103
dr103 is offline
Freshman User
Thread Starter
Join Date: Jul 2008
Location: Raleigh NC
Posts: 27
dr103 is starting off with a positive reputation.
Possible turbo problem

It seems as though my 6.0 is losing some power. I use it to pull my skid steer around. Weigh approx 28000 lbs. I use a Scan Gauge 2 to monitor stuff. Water & oil temps are within 12 degrees. EBP & MAP are around 14.5 when cold. My VGT cold are at 85. I run a SCT tuner in the tow mode. While pulling on flat ground EBP will be in the 30s. VGT will be in the 50s. On a hard pull the EBP will be in the high 40s. The VGT will be in the 30s. Today I noticed my VGT dropped to 14 on a hard pull. It was there just a few seconds.

The 6.0 is studded & also have 4" MBRP Cool Duals from turbo back. No cat. My turbo is Powermax stage 1. It has been on about 7 years.

Any help is greatly appreciated.
 
  #2  
Old 03-19-2019, 08:33 PM
dr103
dr103 is offline
Freshman User
Thread Starter
Join Date: Jul 2008
Location: Raleigh NC
Posts: 27
dr103 is starting off with a positive reputation.
Thanks everyone for all the help
 
  #3  
Old 03-19-2019, 08:37 PM
dr103
dr103 is offline
Freshman User
Thread Starter
Join Date: Jul 2008
Location: Raleigh NC
Posts: 27
dr103 is starting off with a positive reputation.
Thanks for all the help
 
  #4  
Old 03-20-2019, 04:46 AM
RAHRAH
RAHRAH is online now
Freshman User
Join Date: Oct 2010
Posts: 26
RAHRAH is starting off with a positive reputation.
I wish I could be of some help. apologies
 
  #5  
Old 03-20-2019, 06:01 AM
bismic's Avatar
bismic
bismic is offline
Post Fiend
Join Date: Nov 2003
Posts: 18,325
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
To be honest, if it still pulls 28,000 lbs I just don't see a problem. That said, low power is hard to troubleshoot, especially if it is an issue that is not very pronounced.

I am not familiar at all with what to expect from a Powermax coupled with an SCT tow tune (we don't even know whose tune or what tune it is). If you have around 200k miles on the truck, then you probably are going to have a little less power than new, just due to age and wear. If the VGT numbers are unusual for the conditions, then I guess it could be low power.

People probably don't have enough to go on, I doubt that you are just being ignored.. If a person can't help, most won't post up simply to say they can't help .... shouldn't need to.

Have you searched for DieselTechRon's video on low power? I don't know if it would apply to a tuned engine, but maybe it would.

Do the standard stuff -
Scan for codes (ForScan)
Verify the accuracy of MAP, EBP, and Baro (KOEO)
Check for plugging on the EBP tube or in the sensor itself
Check MAP sensor hose for holes or loose fit, as well as plugging (and check for plugging at the intake manifold)
Look for boost or CAC leaks (including inspecting the seals on the CAC itself).
Maybe the CAT is plugging up.
 
 


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.