flat batteries - Ford Truck Enthusiasts Forums

Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

flat batteries

  #1  
Old 01-01-2019, 08:25 PM
Alex5.2008
Alex5.2008 is offline
New User
Thread Starter
Join Date: Aug 2010
Location: midcoast maine
Posts: 7
Alex5.2008 is starting off with a positive reputation.
Unhappy flat batteries

08f350 xlt 6.4 Bat. were 7 years old. started really slow,not charging well lights dim plow slow up and down etc.stepped on brake put in gear stalled.... a lot of clicking no go got a boost started right up. then dach said ( entering factory test mode) then says trip A MILAGE odometer showing wont clear back to normal dash avg. milage .whatever. Took all day to get 2 new batterys (disconnected 6-7 hours) runs great now. show regen cycle but then back to trip A and odometer. Any why to reset with out dealer. Oh hooked up code reader no codes.
 
  #2  
Old 01-03-2019, 08:55 PM
Alex5.2008
Alex5.2008 is offline
New User
Thread Starter
Join Date: Aug 2010
Location: midcoast maine
Posts: 7
Alex5.2008 is starting off with a positive reputation.
Question nobody can help?

I drove it today. runs just fine. still when starting it quickly said entering engineering mode. flash right off the locked on trip meter A and odometer. pushed dash reset while starting still not clearing.
 
  #3  
Old 01-04-2019, 12:01 PM
speakerfritz's Avatar
speakerfritz
speakerfritz is offline
Postmaster
Join Date: Jul 2013
Posts: 3,962
speakerfritz has a good reputation on FTE.speakerfritz has a good reputation on FTE.
im having trouble determining if you are asking questions or just reporting on an experience
 
  #4  
Old 01-04-2019, 02:52 PM
seville009
seville009 is offline
Postmaster
Join Date: Nov 2004
Posts: 2,699
seville009 has a good reputation on FTE.seville009 has a good reputation on FTE.
Are you changing the “display mode” (or whatever it’s called) using the left hand menu button on the steering wheel?
 
  #5  
Old 01-05-2019, 08:51 PM
Alex5.2008
Alex5.2008 is offline
New User
Thread Starter
Join Date: Aug 2010
Location: midcoast maine
Posts: 7
Alex5.2008 is starting off with a positive reputation.
Smile

I got it. I also at the same time installed an LED dome light.(2 NEW BATTERIES) Auto parts store said it was correct one. Tonight after dark got in truck. dome light just barley on. took out the new LED bulb. and the dash went crazy, and went out of engineering mode and works as should. I forgot about putting in the dome light when replacing the batteries oh the little things!!!!!!!! who would think a bulb would mess with the (smart junction box). I guess do one thing at a time from now on. Thank you for the reply's. sorry I was no clear enough Ill try to do better in the future. I'm an old man ya know!!! . Oh I had an old regular bulb in the draw that I put in.
 
  #6  
Old 01-07-2019, 08:03 AM
bubbasz1's Avatar
bubbasz1
bubbasz1 is offline
Posting Guru
Join Date: Dec 2003
Location: Redford, Mi.
Posts: 1,935
bubbasz1 has a very good reputation on FTE.bubbasz1 has a very good reputation on FTE.bubbasz1 has a very good reputation on FTE.
That is weird as I have had LED cabin lights for a couple of years now with no issues.
 


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: