Notices

302 shudder

 
  #1  
Old 07-26-2017, 08:55 PM
Thunder_pipes66
Thunder_pipes66 is offline
New User
Thread Starter
Join Date: Jul 2017
Posts: 10
Thunder_pipes66 is starting off with a positive reputation.
302 shudder

1988 f150 custom 302 efi. Let me give a little side story. Bought the truck and needed lots of work. Pulled motor and did a rebuild. Comp cams 268h w/ matching lifter set, water pump, timing chain, timing cover, 4 hole 215cc bosch 19lb injectors, block honed and cleaned, heads have comp cams upgraded springs, perf valve grind, long tube headers and more. Fired truck up and ran great. Decided to pull the engine codes and popped up MAF sensor out of range. Bought a new map senson and truck runs like a beast on the road but wont idle worth a dang. Un plug new map and swap with old map and idlea great but the afr is off. I have confirmed there is NO vaccum leaks. Replaced throttle postion sensor and still idles crappy. Ive invested alot of moeny into this rebuild and cant hunt down this efi idle problem. Any help would be great. Thanks
 
  #2  
Old 07-26-2017, 11:36 PM
Conanski's Avatar
Conanski
Conanski is offline
Post Fiend
Join Date: Jun 2006
Location: Ottawa, Ontario
Posts: 26,599
Conanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant futureConanski has a brilliant future
What are the exact code numbers are you getting? It will never idle like stock with that cam.
 
  #3  
Old 07-27-2017, 06:04 AM
Thunder_pipes66
Thunder_pipes66 is offline
New User
Thread Starter
Join Date: Jul 2017
Posts: 10
Thunder_pipes66 is starting off with a positive reputation.
Ive got a code 22- map sensor out of range, code 31-egr sensor out of range (egr deleted) and a code 96- fuel pump curcuit open, battery to pcm. I just want to figure out why its hunting to find idle at a stop but runs great on the road. Ive also got a slight shudder/miss when im barely touching the gas. Thought maybe timing was off, nope set at 10 btdc. Running on 93 pump gas thinking it would help but no. Only thing i can think is the truck cant keep up with the cam at idle
 
  #4  
Old 07-27-2017, 07:45 AM
Thunder_pipes66
Thunder_pipes66 is offline
New User
Thread Starter
Join Date: Jul 2017
Posts: 10
Thunder_pipes66 is starting off with a positive reputation.
Could it be possible that when the bad map sensor is installed it is making the computer throw more fuel in than needed at idle to keep it going and when the new good map sensor is installed its making the truck run the way it should and afr ratios are off? At this point I'm leaving the bad map sensor in until I can figure out why it wont idle with the new one.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PowerstrokeJunkie
1999 - 2003 7.3L Power Stroke Diesel
16
08-03-2008 11:47 PM
twisted limb
1978 - 1996 Big Bronco
6
06-14-2006 07:37 PM
RMARTIN
1997 - 2003 F150
6
03-18-2004 02:42 PM
oldstylefseries
Clutch, Transmission, Differential, Axle & Transfer Case
1
02-17-2004 11:09 AM
CharlesB
1997 - 2003 F150
7
07-23-2000 10:53 AM


Thread Tools
Search this Thread
Quick Reply: 302 shudder


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.