2003 expedition electrical problems - Ford Truck Enthusiasts Forums

Notices
1997-2006 Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator Discussion

2003 expedition electrical problems

  #1  
Old 11-09-2016, 12:15 PM
donbrasher
donbrasher is offline
New User
Thread Starter
Join Date: Nov 2016
Posts: 1
donbrasher is starting off with a positive reputation.
2003 expedition electrical problems

been working on 2003 expedition 5.4 had fuel pump relay problem ,
so replaced fuse box as per ford recommended , bought from dealer.
also replaced pump and filter. starts and runs fine for about 15 - 20 min then dies . turn ignition off and crank and will start run for 1-2 min die again. I think new relay in fuse box is getting hot and shutting down .
if anyone has ran into this and knows of a fix any help would be appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Strider007
1997-2006 Expedition & Navigator
53
10-09-2018 03:55 PM
dpl2003_88
Explorer, Sport Trac, Mountaineer & Aviator
2
06-27-2017 07:08 AM
Khalif Burroughs
1997-2006 Expedition & Navigator
5
08-31-2016 03:41 PM
Bigdonn
1997-2006 Expedition & Navigator
16
02-29-2016 01:27 AM
Brokenchains
1997-2006 Expedition & Navigator
5
02-18-2016 11:17 AM


Thread Tools
Search this Thread
Quick Reply: 2003 expedition electrical problems


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.