Notices
2009 - 2014 F150 Discuss the 2009, 2010, 2011, 2012, 2013 and 2014 Ford F150
Sponsored by:
Sponsored by:

question about display

 
  #1  
Old 10-28-2015, 09:44 PM
MSF350
MSF350 is offline
Junior User
Thread Starter
Join Date: Dec 2005
Location: Vicksburg, MS
Posts: 51
MSF350 is starting off with a positive reputation.
question about display

I bought my son a 2010 f150 lariet with about 98000 on it about a month ago. Never really noticed but the dash speedometer and rpm gauges light up at night or when lights are on but not if they are not. They are hard to see even during the day. Others I have seen light up at all times if truck is on. Is this the way it is suppose to be or is there something I can look at to correct it?
 
  #2  
Old 10-29-2015, 05:58 AM
meborder's Avatar
meborder
meborder is offline
Moderator
Join Date: Jul 2011
Location: Sioux Falls Area
Posts: 5,102
meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.
It is working as it should.My 2010 at work is the same way, though I've never found them hard to read during the day.

The stupid "gauge lights on all the time" feature started in MY2011.

I'm not a fan.
 
  #3  
Old 10-29-2015, 10:33 AM
gDMJoe's Avatar
gDMJoe
gDMJoe is offline
Elder User
Join Date: Dec 2010
Location: Timbuk3, MI
Posts: 764
gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.
Lightbulb

MSF350 - I bought my son a 2010 f150 lariet with about 98000 on it about a month ago. Never really noticed but the dash speedometer and rpm gauges light up at night or when lights are on but not if they are not. They are hard to see even during the day. Others I have seen light up at all times if truck is on. Is this the way it is suppose to be or is there something I can look at to correct it?
Try covering-up the daylight sensor. *Middle of the dash, up-next-to the windshield.

If that resolves your issue, a more permanent fix could be to disconnect it ...
.

.

-click- the pic'
Goth 150
< This space intentionally -blank- >
 
  #4  
Old 10-29-2015, 12:35 PM
meborder's Avatar
meborder
meborder is offline
Moderator
Join Date: Jul 2011
Location: Sioux Falls Area
Posts: 5,102
meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.
Only if you want your headlights on all the time, though.
And only if you have auto headlights, which a lariat should
 
  #5  
Old 10-29-2015, 03:53 PM
MNGolfer
MNGolfer is offline
New User
Join Date: Mar 2004
Posts: 15
MNGolfer is starting off with a positive reputation.
This problem was irritating to me also, so rather than disconnect the light sensor, I painted the outside of it with black magic marker. Certainly works a lot better now in low light conditions. The daytime visibility of the instruments on the 2010 is really poor.
 
  #6  
Old 10-29-2015, 10:08 PM
MSF350
MSF350 is offline
Junior User
Thread Starter
Join Date: Dec 2005
Location: Vicksburg, MS
Posts: 51
MSF350 is starting off with a positive reputation.
Thanks guys
 
  #7  
Old 10-30-2015, 08:12 PM
gDMJoe's Avatar
gDMJoe
gDMJoe is offline
Elder User
Join Date: Dec 2010
Location: Timbuk3, MI
Posts: 764
gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.gDMJoe has a great reputation on FTE.
Post

meborder - Only if you want your headlights on all the time, though. And only if you have auto headlights, which a lariat should
Only IF you have your headlamps set to/for autolamp control. *Me - NEVER use it.
.
.

-click- the pic'
Goth 150
< This space intentionally -blank- >
 
  #8  
Old 10-31-2015, 04:20 AM
meborder's Avatar
meborder
meborder is offline
Moderator
Join Date: Jul 2011
Location: Sioux Falls Area
Posts: 5,102
meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.meborder has a spectacular reputation.
Fair enough. I forget there are people in this world who are too stubborn to use things like automatic headlights and cruise control.

You and my wife would get along well.

Drives me friggin NUTS!
 
  #9  
Old 11-06-2015, 06:08 PM
lakedweller's Avatar
lakedweller
lakedweller is offline
Elder User
Join Date: Mar 2011
Location: Maryville (Mur Vul), TN
Posts: 824
lakedweller is starting off with a positive reputation.
My 14 has dash lights all the time and I love it. When the headlights come on the dash lights dim to my desired setting. Hate not seeing the gauges a problem I had with the Jeep Wrangler Limited Sport I traded in for my truck. Many times turned the lights on in order to see the gauges.
 
  #10  
Old 11-08-2015, 06:41 AM
pdqracer
pdqracer is offline
New User
Join Date: Jun 2015
Posts: 18
pdqracer is starting off with a positive reputation.
Originally Posted by MSF350 View Post
I bought my son a 2010 f150 lariet with about 98000 on it about a month ago. Never really noticed but the dash speedometer and rpm gauges light up at night or when lights are on but not if they are not. They are hard to see even during the day. Others I have seen light up at all times if truck is on. Is this the way it is suppose to be or is there something I can look at to correct it?
I have the same problem, it' not just you. I read down the relies, I'm going to try the magic marker cure.
 
  #11  
Old 11-16-2015, 09:20 PM
wilcam47's Avatar
wilcam47
wilcam47 is offline
Senior User
Join Date: Feb 2013
Location: Idaho
Posts: 266
wilcam47 is starting off with a positive reputation.
Originally Posted by pdqracer View Post
I have the same problem, it' not just you. I read down the relies, I'm going to try the magic marker cure.
maybe electrical tape over it
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stuckstudent
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
13
10-25-2018 03:48 PM
ToolmakerRob
Excursion - King of SUVs
7
03-29-2016 08:28 PM
Doubleubar
1999 - 2003 7.3L Power Stroke Diesel
7
02-24-2016 06:33 AM
tbruz
1973 - 1979 F-100 & Larger F-Series Trucks
5
11-15-2015 02:43 PM
bcaughhorn
1999 - 2003 7.3L Power Stroke Diesel
3
11-13-2015 09:17 PM


Thread Tools
Search this Thread
Quick Reply: question about display


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: