Antenna advice - Ford Truck Enthusiasts Forums



1997-2006 Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator Discussion

Antenna advice

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-05-2012, 11:59 PM
wastingas wastingas is offline
Senior User
Thread Starter
 
Join Date: Dec 2011
Posts: 204
wastingas is starting off with a positive reputation.
Antenna advice

06 Navi has a Alpine double din the radio gets awful reception lots of static and only picks up a few channels. The antenna is hooked up to the head unit and the connection near the fuse box is good. Any after martket antennas you guys recommend. Or reason why the window antenna isn't working well?
Reply With Quote
  #2  
Old 12-06-2012, 12:26 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 14,321
alloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud of
Quote:
Originally Posted by wastingas View Post
06 Navi has a Alpine double din the radio gets awful reception lots of static and only picks up a few channels.
The factory antenna should work great without modifications of any kind.

1. It could be a bad head unit.
2. It could be a broken antenna wire.
Reply With Quote
  #3  
Old 12-08-2012, 02:21 AM
GreenExpo GreenExpo is offline
New User
 
Join Date: Dec 2012
Posts: 11
GreenExpo is starting off with a positive reputation.
The stock antennas usually work better than aftermarket. May be just some bad wiring like mentioned above or possibly some interference from another unshielded cable?
Reply With Quote
  #4  
Old 12-08-2012, 11:50 AM
r2millers's Avatar
r2millers r2millers is offline
Postmaster
 
Join Date: Sep 2010
Location: Southern Cal
Posts: 3,442
r2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud of
Quote:
Originally Posted by wastingas View Post
06 Navi has a Alpine double din the radio gets awful reception lots of static and only picks up a few channels. The antenna is hooked up to the head unit and the connection near the fuse box is good. Any after martket antennas you guys recommend. Or reason why the window antenna isn't working well?
Check the back of the Alpine unit for the reception fine tuning screw. Many times you need to adjust this for your antenna type to get optimum reception. Until then, you will have limited access to channels.
Reply With Quote
  #5  
Old 12-08-2012, 01:11 PM
wastingas wastingas is offline
Senior User
Thread Starter
 
Join Date: Dec 2011
Posts: 204
wastingas is starting off with a positive reputation.
I have never heard of this.... Kinda sounds like a muffler bearing if you catch my drift. Ill take a look though. Thanks
Reply With Quote
  #6  
Old 12-08-2012, 04:00 PM
r2millers's Avatar
r2millers r2millers is offline
Postmaster
 
Join Date: Sep 2010
Location: Southern Cal
Posts: 3,442
r2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud of
Quote:
Originally Posted by wastingas View Post
I have never heard of this.... Kinda sounds like a muffler bearing if you catch my drift. Ill take a look though. Thanks
Well of course you have never heard of this... otherwise you wouldn't be asking. I would not send you that way, knowing you might have to remove the unit to find the adjustment.
You know how I know... I had to do the same thing.
Never a muffler bearing... maybe a wood stretcher though.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ham antenna install johndeerefarmer 1999 to 2016 Super Duty 3 07-30-2014 08:53 PM
1956 antenna thomc 1948 - 1956 F1, F100 & Larger F-Series Trucks 1 01-17-2013 08:40 PM
2007 Expedition EL Limited - Sirius antenna? SickPup404 2007 - 2014 Expedition & Navigator 7 04-06-2011 10:06 PM
Anybody cut their antenna T.Mainus 1999 to 2016 Super Duty 9 03-27-2010 12:24 PM
AM antenna problems Cadence8 2007 - 2014 Expedition & Navigator 2 07-30-2009 11:17 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 04:38 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.