2007 Expy Starting issue - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

2007 Expy Starting issue

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-04-2012, 08:28 PM
D-Rock D-Rock is offline
Freshman User
Thread Starter
 
Join Date: Feb 2004
Posts: 46
D-Rock is starting off with a positive reputation.
2007 Expy Starting issue

Looking for help - I experienced a no start with my 65k mile Expy. Here is what I am seeing and I think I may be having 2 issues at once. I went to leave my in-laws after dinner tonight and the truck wouldn't start.

The truck cranks fine, but won't start. I get no sound from fuel pump and no residual fuel pressure on the schraeder valve on the fuel rail. I checked the inertia switch and it was in the on position. I think this may be the fuel pump control module (it seems to be a common issue for Expys and F150s), but is there a known way to test these before replacing? I'd rather not drop $100 on a part that is not the source.

As if that wasn't a big enough pain, the starter will not disengage when I release the key - it keeps cranking, unless I turn to full off. I am assuming this is a shorted solenoid, but also wonder if it may be the ignition switch. Again, looking for any way to isolate which may be the culprit. FWIW, battery only 4 months old and is at 12+ volts. Also, ran a scan tool and there are no DTC codes.

Any help or thoughts are appreciated.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help - Engine stumbles / No Codes DEMIGOD 1997-2006 Expedition & Navigator 27 01-22-2014 09:31 PM
2007 Expy Starting issue - Also posted in Expy side D-Rock 2004 - 2008 F150 1 03-06-2012 01:57 PM
Fuel pump wouldn't run [also a guide to troubleshooting] expy37at 1997-2006 Expedition & Navigator 2 12-12-2011 04:16 PM
Intermittent P0181 Code - 03 Expedition 4.6L randinow 1997-2006 Expedition & Navigator 6 01-08-2010 11:09 PM
2003 EXPY Hard Starting When Warmed Up mjpmn 1997-2006 Expedition & Navigator 7 08-10-2008 05:50 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2007, expedition, fuel, pump, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 02:07 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send