Notices
1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage

Turn signals won't work!!!!

 
  #1  
Old 08-14-2000, 09:19 PM
FTE Ken's Avatar
FTE Ken
FTE Ken is offline
Post Fiend
Thread Starter
Join Date: Jan 1997
Location: Enjoying the real world.
Posts: 23,166
FTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputationFTE Ken has a superb reputation
Turn signals won't work!!!!

 
  #2  
Old 11-24-2002, 01:29 PM
mack3233
mack3233 is offline
New User
Join Date: Nov 2002
Posts: 4
mack3233 is starting off with a positive reputation.
Turn signals won't work!!!!

I have a 98 F150. My turn signals work about half of the time. When they don't work, I don't get any indication on the dash. The hazards still work all of the time. And when they aren't working, if I have a signal on and brake, that brake light won't wotk.

I replaced the bulbs first, then the flasher and just replaced the multi function switch and still have the problem. Has anyone else had this problem or have any suggestions that might help?
 
  #3  
Old 11-24-2002, 01:47 PM
94van
94van is offline
Posting Guru
Join Date: Oct 2000
Location: Southern MD
Posts: 1,577
94van is starting off with a positive reputation.
Turn signals won't work!!!!

Did you replace the turn signal flasher, or the 4-way flasher? There are 2 flashers under the dash.


-------------------------
http://easyad.net/images/94vanavitar.jpg http://www.easyad.net/images/mustang1.gif


'94 E-150 Conversion Van 4.9 / C-6 -- '89 Mustang LX 5.0

 
  #4  
Old 11-24-2002, 02:13 PM
mack3233
mack3233 is offline
New User
Join Date: Nov 2002
Posts: 4
mack3233 is starting off with a positive reputation.
Turn signals won't work!!!!

Yeah, I replaced both of them. Still same problem.
 
  #5  
Old 12-08-2002, 04:53 PM
gwinters
gwinters is offline
New User
Join Date: Jul 2002
Posts: 7
gwinters is starting off with a positive reputation.
Turn signals won't work!!!!

My 98 F150 behaves similarly right after I've used the hazards(ie. the blinkers quit working). In my case I believe something is screwy with the hazard switch on the steering colunm. I wind up pressing that switch really fast a few times to get everything to "unstick" or whatever, then I have no more problems with turn signals. (I do try to avoid EVER using those #%$&@! hazards though!


 
  #6  
Old 12-09-2002, 05:12 AM
mack3233
mack3233 is offline
New User
Join Date: Nov 2002
Posts: 4
mack3233 is starting off with a positive reputation.
Turn signals won't work!!!!

Well, a Ford tech finally told me that my fuses might be loose as they have a tendency to get that way. I followed my wire diagran and found out that the turn signals go through the blower relay. I wiggled that fuse (#23 I think) and they immediately worked. I removed the fuse, bent the prongs back down and they have worked ever since. If you had this problem, hopefully this can help.
 
  #7  
Old 11-28-2003, 08:04 PM
757mech1
757mech1 is offline
New User
Join Date: Nov 2003
Posts: 19
757mech1 is starting off with a positive reputation.
I am have a simular problem with my 98. When I went to use the hazards they didnt work and now the turn siginals, the hazards and the 2 brake lights on either side of the tailget dont work but the brake light on the cab does. I found this relay under the dash in the fuse panel. I took it out on my other truck and it did the exact same thing but i didnt swap the relays from truck to truck because the were differnt part numbers.
 
  #8  
Old 11-28-2003, 08:42 PM
98f1504x4ohio
98f1504x4ohio is offline
Junior User
Join Date: Nov 2003
Location: Ohio
Posts: 87
98f1504x4ohio is starting off with a positive reputation.
well, try this one on for size... I just got my '98 a month ago with 61K miles. when the weather was cold (mornings before, but now it's all the time in ohio) the left turn signal wouldn't work until the truck warmed up. then, last week one day, it quit working all together. blinked twice as fast as normal. What I found was that if I didn't push the lever all the way down to the auto latch, and just held the signal on manually, it would work. this week it has straightened itself out and works all the time (knock on wood)!!!
HTH
Clint
 
  #9  
Old 11-29-2003, 12:18 AM
Racerguy's Avatar
Racerguy
Racerguy is offline
Post Fiend
Join Date: Aug 2002
Location: BC, Canada
Posts: 12,674
Racerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to beholdRacerguy is a splendid one to behold
Hi 757mech1 and welcome to the forum

It sounds to me like you need a new multifunction (signal/wiper) switch. The turn signals, hazard flashers and rear brake lights all work through it. The 3rd brake light doesnt which explains why it still works.
 
  #10  
Old 05-12-2014, 06:49 PM
757mech1
757mech1 is offline
New User
Join Date: Nov 2003
Posts: 19
757mech1 is starting off with a positive reputation.
Originally Posted by Racerguy View Post
Hi 757mech1 and welcome to the forum

It sounds to me like you need a new multifunction (signal/wiper) switch. The turn signals, hazard flashers and rear brake lights all work through it. The 3rd brake light doesnt which explains why it still works.
Yes Sir, Racerguy.. You were right.. I was the multifunction signal/wiper switch. I think I got a new one from ebay because Fords price was outrageous.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bradphx
1973 - 1979 F-100 & Larger F-Series Trucks
63
09-24-2018 11:19 AM
Aerostar
5
01-14-2015 03:16 AM
miko6810
Modular V10 (6.8l)
9
06-04-2014 06:14 AM
1978 - 1996 Big Bronco
6
05-25-2002 03:08 PM
broom
FE & FT Big Block V8 (332, 352, 360, 390, 406, 410, 427, 428)
8
11-24-2001 12:46 PM


Thread Tools
Search this Thread
Quick Reply: Turn signals won't work!!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.