Hypertech chip? - Ford Truck Enthusiasts Forums

Notices
1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Hypertech chip?

 
  #1  
Old 04-27-2004, 04:09 PM
No_BS's Avatar
No_BS
No_BS is offline
Senior User
Thread Starter
Join Date: Apr 2003
Location: Southeastern PA
Posts: 438
No_BS is starting off with a positive reputation.
Question Hypertech chip?

I have a chance to get a hypertech chip for real cheap from someone. First question is if it will work in my '91, it was origininally on an '89 with the same engine (302), so I think it would. Second, what types of increases in power can be expected? Third, is there anything else other than running premium that I'll have to change? Thanks for any info.
 
  #2  
Old 04-27-2004, 09:31 PM
JohnSacF-250
JohnSacF-250 is offline
Freshman User
Join Date: Apr 2004
Posts: 26
JohnSacF-250 is new and has a neutral reputation at this point.
I originally bought the chip for more power. I got increases that I can feel, plus the truck runs better overall. Unanticipated great news that my towing mpg went up from 5.5 to 7.5! That meant I could drive another 95 miles before fill-up. My truck is a 1989 F-250 4X4, 7.5 gas, C-6 transmission and 4.10 rear end. I have a fifth wheel trailer weighing 12,500# and truck scales out at 7200#. The Ford manual indicates a GCVW of 18,500#. The truck also uses a couple of quarts between oil changes of 4,000 miles, and has 112,500 miles on the odometer. I paid $320.00 for the chip at Kragen Auto Parts. I just installed a new Hyperteccoilthat has 55,000 volts. I think the stock coil has 38,000. I haven't towed anywhere yet to see how that will work out.
 
  #3  
Old 04-27-2004, 11:06 PM
faroffthetrack's Avatar
faroffthetrack
faroffthetrack is offline
Elder User
Join Date: Aug 2003
Location: Houston
Posts: 545
faroffthetrack is starting off with a positive reputation.
Did the truck start sucking down oil as a result of the chip?
 
  #4  
Old 04-28-2004, 09:24 PM
natewoz's Avatar
natewoz
natewoz is offline
Elder User
Join Date: Feb 2003
Location: MN
Posts: 887
natewoz is starting off with a positive reputation.
JohnSacF-250,
Did you run 87 octane or did you run premium?
 
  #5  
Old 04-28-2004, 09:54 PM
JohnSacF-250
JohnSacF-250 is offline
Freshman User
Join Date: Apr 2004
Posts: 26
JohnSacF-250 is new and has a neutral reputation at this point.
Originally Posted by faroffthetrack
Did the truck start sucking down oil as a result of the chip?
No, the truck just uses oil. I use Chevron 30wt. I tried 10/40 last week, but chainged it back to 30wt. because the oil gauge display was lower.
 
  #6  
Old 04-28-2004, 09:55 PM
JohnSacF-250
JohnSacF-250 is offline
Freshman User
Join Date: Apr 2004
Posts: 26
JohnSacF-250 is new and has a neutral reputation at this point.
Originally Posted by natewoz
JohnSacF-250,
Did you run 87 octane or did you run premium?
I use the 91 premium unleaded.
 

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.