Random 3V 5.4 starting problem - Ford Truck Enthusiasts Forums

Notices

Random 3V 5.4 starting problem

  #1  
Old 02-12-2016, 01:04 AM
twigsV10's Avatar
twigsV10
twigsV10 is offline
Posting Guru
Thread Starter
Join Date: Jun 2010
Location: Iowa
Posts: 2,111
twigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud oftwigsV10 has much to be proud of
Random 3V 5.4 starting problem

My 05 Expedition 5.4 will completely randomly start and rev then die fast with what sounds like preignition pinging, the second attempt at start up is even more random, sometimes it will start and other times it will cough, sputter and pop but will always start the third time? It doesn't matter if the engine is hot or cold and only happens on a rare occasion otherwise it runs perfectly with no codes???

Any ideas would be appreciated, I love the truck and it's my wife and kids transportation so reliability is a big deal to me.
 

Last edited by twigsV10; 02-13-2016 at 12:03 AM. Reason: Wording
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
'02 F250
1999 to 2016 Super Duty
16
08-20-2018 10:48 AM
jakeharp
Modular V8 (4.6L, 5.4L)
3
11-11-2017 07:47 PM
treynolds4961
1999 to 2016 Super Duty
3
10-31-2017 06:16 PM
Ford_Six
1997-2006 Expedition & Navigator
6
01-07-2017 12:48 PM
broncoholic
1997-2006 Expedition & Navigator
14
03-21-2016 11:02 AM


Thread Tools
Search this Thread
Quick Reply: Random 3V 5.4 starting problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.