electrical question for a '65 F-100 - Ford Truck Enthusiasts Forums



1961 - 1963 F100 Unibody 1961, 1962 and 1963 Ford F100 Unibody trucks

electrical question for a '65 F-100

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-08-2014, 12:47 PM
peter sipp peter sipp is offline
Junior User
Thread Starter
 
Join Date: Jan 2014
Posts: 96
peter sipp is starting off with a positive reputation.
electrical question for a '65 F-100

I cannot find the Instrument cluster voltage regulator next to the speedometer or any where in that area. Out in the engine compartment close to the 3"X3" regular voltage reg. is a small similar looking little box to what is supposed to be in the cab, near the speedo. It is about 1&1/2" long X5/8" thick X 1" wide. There are 3 prongs coming out of it. there is one, mmm, 1/4" self tapping screw holding. Thank you fellow/gal slick 60's enthusists, cheers, Pete
Reply With Quote
  #2  
Old 02-08-2014, 12:54 PM
Tedster9's Avatar
Tedster9 Tedster9 is online now
Post Fiend
 
Join Date: Apr 2002
Location: Waterloo, Iowa
Posts: 10,619
Tedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputation
That sounds like the relay - for the horn, on the inner fender apron. The constant voltage regulator "should" be installed on the back of the speedo meter ? Dunno. Not sure for 65s though.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
problem with instrument cluster three on the tree 1973 - 1979 F-100 & Larger F-Series Trucks 45 10-14-2016 10:27 AM
Gas guage and temp guage not working. Voltage regulator? Frmnsal 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 7 06-23-2016 06:40 PM
need an engine control module ?? H_Talon 1994.5 - 1997 7.3L Power Stroke Diesel 6 06-21-2015 08:46 PM
Will not charge mnmark Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 2 03-08-2015 12:01 PM
1988 f250 No spark! bluetruk88 1987 - 1996 F150 & Larger F-Series Trucks 2 12-02-2012 06:50 AM


Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 02:56 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send