Rough Idle? - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Rough Idle?

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-05-2012, 01:06 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Rough Idle?

Anyone have experience with a rough idle? Seems to be much worse with A/C on. Can feel it vibrate the steering wheel a bit. Fuel and air filter have been changed. Has 98K maybe time for spark plugs.
Reply With Quote
  #2  
Old 04-05-2012, 01:54 PM
TCAS007's Avatar
TCAS007 TCAS007 is offline
Senior User
 
Join Date: May 2011
Location: Perry, Utah
Posts: 253
TCAS007 is starting off with a positive reputation.
Quote:
Originally Posted by berry1234 View Post
Anyone have experience with a rough idle? Seems to be much worse with A/C on. Can feel it vibrate the steering wheel a bit. Fuel and air filter have been changed. Has 98K maybe time for spark plugs.
Only had it on old cars where he spark plugs or coil packs failed. Or the MAF sensor.

Does it read an error code out?
Reply With Quote
  #3  
Old 04-05-2012, 01:55 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
No, no error code. It's not horrible, but I can feel the vibration for sure. If I raise the idle a bit it goes away.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough IDLE kcole64 1997-2006 Expedition & Navigator 5 07-11-2015 09:01 AM
2003 4.6 rough idle mainefordman 1997 - 2003 F150 10 07-11-2015 08:39 AM
Rough idle and stalls BrentElliott0093 1997 - 2003 F150 3 04-14-2014 05:33 PM
rough idle when starting.. MentalState 1999 - 2003 7.3L Power Stroke Diesel 9 04-10-2014 11:34 AM
Not idleing smooth. Al T 1973 - 1979 F-100 & Larger F-Series Trucks 1 04-08-2014 07:28 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2005, classic, codesrough, erratic, explorer, fault, idle, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:57 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send