Where am I screwing up with my setup? - Ford Truck Enthusiasts Forums



Where am I screwing up with my setup?

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-26-2011, 06:35 PM
curbill4 curbill4 is offline
New User
Thread Starter
 
Join Date: Sep 2011
Posts: 12
curbill4 is starting off with a positive reputation.
Where am I screwing up with my setup?

On my 93 7.3 dually auto I have a twin tank system. I have 2 electric fuel pumps and a 3 way manual switch on the floor to send the right fuel to the right tanks. I have a centrifuge and I heat my oil to 160 and then run the wvo thru the centrifuge. I prefilter the oil thru socks before it goes into the centrifuge drum. One tank is a 50/50 blend of vwo/diesel. I am in SO FL and the temp does not go to below 45 degrees at any time. If I am going to run the truck in the cold (to me 45 is cold) I will just use diesel. I make a 500 mile trip with the truck over 4days. My oil comes right from the fryer into cubes. I have used this oil for 7 years and I tip the people who control how the oil is transfered. I also have used the same oil in our 300 mercedes with a 20% diesel to 80% wvo for the 7 year period. I have a little over 120,000 miles on wvo so I am comfortable with my oil. I have started up on this blend for 2 years now and have never used straight wvo in the truck. 2 weeks ago as I drove to the store with the truck I got about 1 mile from th3e house and the IP busted. In opening up the pump at the diesel pump repair place they found water and rust in the pump. How do I prevent this from happening again. What type of additive should I be adding to my tank? Should I add a water separator to the diesel side or should both tanks empty into the separator before the injector pump. I only got 10,000 miles on this pump. Any help would be appreciated.
Reply With Quote
  #2  
Old 11-26-2011, 09:04 PM
TxFordGuy TxFordGuy is offline
Senior User
 
Join Date: May 2006
Location: Katy, TX
Posts: 190
TxFordGuy is starting off with a positive reputation.
Your stock tank should be Poly and should never get anything but diesel in it. Is you 2nd tank steel or aluminum? You should only use a SS or aluminum tank with WVO. Is your secondary tank heated? if not, that is another problem. Pulling the thick oil casues extreme wear on the pumps
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
water in my wvo? onthemoveactivist Bio-diesel, Propane & Alternative Diesel Engine Fuels 4 01-13-2014 12:42 AM
Best Injectors, Etc For WVO? linus72 Bio-diesel, Propane & Alternative Diesel Engine Fuels 3 05-08-2012 08:36 AM
WVO Blends IceboxFX Bio-diesel, Propane & Alternative Diesel Engine Fuels 31 06-29-2008 05:33 PM
Best Catalyst 6.0superduty Bio-diesel, Propane & Alternative Diesel Engine Fuels 2 03-19-2008 11:44 AM
The pros and cons of homemade biodiesel vs wvo. derherr65 Bio-diesel, Propane & Alternative Diesel Engine Fuels 66 04-23-2007 08:23 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:14 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send