Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-29-2009, 02:05 AM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
no throttle response and low idle

Hope all is well on the best forum on the web ! I have an 03 6.0 liter and it just died on the road i had a code , i cant remember what number p 2200 or something but i looked it up and is was the icp too low so i replaced it and the truck is still doing the same it starts but idles at 200 and no throttle response what so ever ! Could it be my TPS ! I sure do appreciate all the Help !!
03 6.0 350 lariat 6 inch procomp lift afe intake arp studs edge evolution
Reply With Quote
  #2  
Old 03-29-2009, 08:41 AM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 14,463
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
Could be a number of things -
It would be nice to have the exact code number.
Have you noticed that it has trouble hot, but not cold?
You said it starts, but does it struggle to start?

Possible issues -
ICP system leak
IPR sensor or system leak
High Pressure Oil Pump or system leak
Injector o-ring leak
__________________
Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270AXP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD BilletWaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
Reply With Quote
  #3  
Old 03-29-2009, 11:37 AM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,073
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
There is also an updated connector for the ICP sensor,it has 3 purple wires.
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #4  
Old 03-29-2009, 12:15 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
ill get the code today but the truck was running fine when all of the sudden it felt like it ran out of fuel but it still idled just no throttle response! ill get them after church!!
Reply With Quote
  #5  
Old 03-29-2009, 05:07 PM
yz400f yz400f is offline
Senior User
 
Join Date: Oct 2008
Posts: 225
yz400f is starting off with a positive reputation.
I have an 05, did the same thing. I was going to replace the ICP and unplugged it, looked into the connector, blew in it, plugged it back in. The motor smoothed right up! I do not know if I had a connector problem, if unplugging it while it was running (well sort of running) reset something or what. That was about 10k miles ago. It has been running great ever sense.

My ICP is in the passenger valve cover. Very easy to get at.
Reply With Quote
  #6  
Old 03-29-2009, 07:41 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
Ok my code reader said i had a p 2290 and p 0102 !!! i cant find a p 2290 most codes stop at 1999 !! does anyone know what these codes are ? Thanks
Reply With Quote
  #7  
Old 03-29-2009, 07:45 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
Hey yz 400 was that plug hard to get to i had fun changing mine i used a 1 1/16 socket after unpluging mine , the plug was full of black oil that smelled like fuel ! it was a round plug with three wires and it was behind the turbo !
Reply With Quote
  #8  
Old 03-29-2009, 07:46 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
sorry i didnt see the part where yours was easy !!! I guess they changed it on the o5 model!!!
Reply With Quote
  #9  
Old 03-29-2009, 07:50 PM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,073
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
I posted the code list yesterday.http://www.ford-trucks.com/forums/83...-dtc-info.html
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #10  
Old 03-29-2009, 07:52 PM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 14,463
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
P2290 Injector Control Pressure Too Low
P0102 Mass/Volume Air Flow Circuit Low Input
__________________
Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270AXP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD BilletWaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
Reply With Quote
  #11  
Old 03-29-2009, 07:54 PM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,073
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
The early 04 had them under the turbo,you found your problem. Ford put it on the valve cover in 04,so yours is a early 04 witch has a late 03 motor. Replace the connector if it hasn't been done all ready,the updates are less prone to let that oil climb up the harness when the ICP sensor fails.
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #12  
Old 03-29-2009, 07:58 PM
bigredtruckmi's Avatar
bigredtruckmi bigredtruckmi is offline
Postmaster
 
Join Date: Jan 2005
Location: Grand Ledge, Michigan
Posts: 4,632
bigredtruckmi has a good reputation on FTE.bigredtruckmi has a good reputation on FTE.bigredtruckmi has a good reputation on FTE.
A couple of ears ago we had something similar. But it was the wiring from the throttle to the computer was chaffed at the pedal area. Ran great then nothing but idle. Glad the warranty took care of the problem.
__________________
red 04 F250 build date 04/04 6.0 PSD
2013 gulfstream canyon trail fifth wheel Aztec edition 40 ft
Vietnam Vet/ OS1 USN/USNR retired 26 years
Reply With Quote
  #13  
Old 03-29-2009, 08:00 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
Yep pain in the but but i changed out the icp sensor for 180 bucks put the plug back on and found another problem the heater core outlet hose that runs up against the fire wall was rubbing on the nut on the ecu on the valve cover so i advise everyone to make sure you arent loosing water out of that hose! Also the truck is still doing the same low idle around 200 and no throttle response!
Reply With Quote
  #14  
Old 03-29-2009, 08:01 PM
RMoore RMoore is offline
Junior User
 
Join Date: Feb 2008
Posts: 67
RMoore is new and has a neutral reputation at this point.
Dose anyone know the p 0102 code is !
Reply With Quote
  #15  
Old 03-29-2009, 08:04 PM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 14,463
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
Look at post #10
__________________
Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270AXP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD BilletWaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
Reply With Quote
Old 03-29-2009, 08:04 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
03 6.0 rough idle issue af11 Super Duty & Heavy Duty 2 04-20-2014 11:38 PM
2007 6.0 out of the blue problem???? mahd776 6.0L Power Stroke Diesel 3 01-30-2014 07:20 AM
6.0 No throttle response to now wont start Bull_8878 6.0L Power Stroke Diesel 6 11-14-2011 06:38 AM
No Throttle!!!??? Risk176 6.0L Power Stroke Diesel 7 02-17-2011 07:31 PM
No throttle response kcphillips 6.0L Power Stroke Diesel 10 08-19-2010 09:47 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel

Tags
06, 2000, 2002, 2004, 2006, 60, 73, codes, cold, diagnosing, diesel, f350, ford, liter, response, throttle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 02:45 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup