Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 05-25-2008, 10:26 AM
expeditor expeditor is offline
Junior User
 
Join Date: Aug 2007
Posts: 51
expeditor is starting off with a positive reputation.
08 expy 6 disc stereo noise

I have an 08 expy with the 6 disk changer. More often than not when you start the vehicle and the stereo/radio is off it makes a noise that sounds as if the stereo is searching (clicking) for a cd. The stereo is off and there is no disk(s) in the unit.The sound usually lasts about 2 minutes, and it makes it near impossible to stop at the dealer when it does it. Anyone experience this? thanks chuck
Reply With Quote
  #2 (permalink)  
Old 05-25-2008, 12:00 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
You have no discs in the unit? Try loading 6 discs and see if it happens. About once a month when I start the car, it will cycle through the discs. Takes about 30 seconds. I don't see why it should do it every time though.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3 (permalink)  
Old 05-25-2008, 06:28 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 536
montecarlo31 is starting off with a positive reputation.
I believe that all my vehicles with the multi disc player make that same noise, I think it's common
Reply With Quote
  #4 (permalink)  
Old 05-27-2008, 11:58 AM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
I have not noticed any noise BUT I have not been looking for one either. I will check over the next week or so and see if I hear anything like the sound you are describing.
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
Old 05-27-2008, 11:58 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2010, disc, f250, specs, stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 12:37 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup