Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Ranger & B-Series
Sign in using an external account
Register Forgot Password?


Ranger & B-Series All Ford Ranger and Mazda B-Series modelsSPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-25-2007, 10:22 PM
vburke vburke is offline
New User
 
Join Date: May 2004
Posts: 24
vburke is starting off with a positive reputation.
Blinking O/D OFF light

I've got an 05 Ranger Edge 4x4. 4.0, 5spd auto, 47Kmiles. Just did a fluid and filter change on the transmission, fluid levels fine and as far as I can see, the transmission is working just fine, however at varying intervals, I get a blinking O/D OFF light.

I'm presuming this is a transmission warning, any suggestions where and what I should look for?

Vern
Reply With Quote
  #2  
Old 12-25-2007, 10:45 PM
JeremyJ JeremyJ is offline
Junior User
 
Join Date: Jul 2006
Posts: 91
JeremyJ is starting off with a positive reputation.
my 94 probe started doing that, eventually the car would start revving at highway speeds. i was told on a probe website that when the o/d light starts blinking on the automatic probes, the tranny is on its way out.

i eventually got rid of it and got myself a civic.
__________________
1994 Ford Ranger 3.0 4x4 supercab xl 5-speed
166,300 miles - STOCK!!!!!

2000 Honda Civic EX Coupe 5-speed
85,350 miles - STOCK!!!!!

2002 Suzuki DR-Z400S
1850 miles - STOCK!!!!!
Reply With Quote
  #3  
Old 12-26-2007, 07:57 AM
cmoore cmoore is offline
Freshman User
 
Join Date: Oct 1999
Location: Dallas, Tx
Posts: 39
cmoore is starting off with a positive reputation.
+1 on what JeremyJ said. I had a Windstar that started doing that. The transmission eventually failed big time on a fine Thanksgiving morning. I would take it in and have it looked at. Is it still under warranty.
Reply With Quote
  #4  
Old 12-26-2007, 09:13 AM
Rockledge's Avatar
Rockledge Rockledge is offline
Post Fiend
 
Join Date: Jan 2003
Location: Connecticut
Posts: 9,487
Rockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to behold
I'd bring it to the Ford dealer and have them diagnose the problem ASAP. Your '05 is either under warranty, or its close enough time-wise, where there's a good chance the dealer can still make the repair through the warranty program with much less cost to you.
__________________
'98 Ranger XLT 4x4 (4.0L)
'94 Taurus SHO (MTX)
'03 Sable LS (Duratec)
Reply With Quote
  #5  
Old 12-26-2007, 10:51 PM
Bob K. Bob K. is offline
Senior User
 
Join Date: Nov 2004
Posts: 136
Bob K. is starting off with a positive reputation.
This occurred in my '97 after a fluid and filter change. The fluid was a little over a quart low and the flashing O/D went away after I added fluid.
Reply With Quote
Old 12-26-2007, 10:51 PM
 
 
 
Reply


Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Ranger & B-Series

Tags
2006, change, fluid, ford, od, ranger, transmision

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 03:54 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup