Ford Truck Enthusiasts Forums - View Profile: Rockledge

Notices
Rockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to beholdRockledge is a splendid one to behold

Rockledge Rockledge is offline

Post Fiend

About Me

  • About Rockledge
    Location
    Connecticut
    Interests
    talkin' Fords
    2 Letter State/Province (use "--" for outside USA/
    CT
    Country of Residence
    US
    Make
    Ford
    Model
    Ranger
    Year
    1998
    Current Mileage
    125,000 - 149,999
    Miles per year
    Rather not say
  • Signature
    '98 Ranger XLT 4x4 (4.0L)
    '94 Taurus SHO (MTX)
    '03 Sable LS (Duratec)

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-18-2019 09:34 PM
  • Join Date: 01-18-2003
  • Referrals: 0

Friends

Showing Friends 1 to 6 of 6

Visitor Messages

Showing Visitor Messages 1 to 10 of 23
  1. 03-31-2018 05:05 AM - permalink
    I posted a question on the Ranger forum the other day and I was told maybe you could help me. My father in law swapped engines in his 2000 Ranger. He used a Tarus engine ( 3.0). Don't know what Vin it was. His old engine had been poping and missing as well as had very little power. He swapped engines and didn't not pay attention to where the Cam Synch was at. Now I believe it is out of time. The new engine had a TDC pointer but it was made into the timing cover. How can I go about getting this thing back in time with out a pointer and what degree is the timing supposed to be on the Cam Synch? 15 degrees or 60 degrees?
  2. 01-20-2016 01:13 AM - permalink
    I am getting a cylinder 3 misfire along with gradual coolant loss. I am guessing lower intake manifold. The link to your tutorial for this repair seems to be dead. can you PM me with the correct link?
  3. 11-18-2015 12:47 PM - permalink
    Hi Rockledge! I just wanted to thank you for your post (https://www.ford-trucks.com/forums/2...ke-gasket.html), as I found it very helpful. For the past 10 years, our 1994 Ranger 4.0L has been losing coolant at a slow rate, runs rough at startup and slightly hesitates under a load. So last week I bought an Actron 7827 compression tester --- thinking that it may have a partially blown head gasket. But five cylinders reported 150 PSI and the odd one came in at 165 PSI. So I have ruled out the heads --- at least for now. Before reading your post , I did not consider the possibility that the lower intake manifold may be loose/worn/cracked or that the gasket is compromised. So, figuring I would still need to remove the intake manifold to access the heads, I ordered a new gasket set from 1aauto.com and am getting ready to tear into our royal Ranger. (From the picture at 1aauto, the main gasket is a single sheet.) Thanks again for your post!
  4. 09-27-2014 11:38 PM - permalink
    Maybe you can help me with my truck. Codes 172, 175 and 1405. Really could use some help.

    https://www.ford-trucks.com/forums/1...any-parts.html

    Thanks,

    Evan
  5. Rockledge
    06-07-2014 04:51 PM - permalink
    Send the info to [email protected]

    Thanks!
  6. ATS Junior
    06-05-2014 10:43 PM - permalink
    Hey Rockledge! Sorry for taking so long to respond. I didn't see that you left me a visitor message. Do you have an email? I'd be more than happy to send you a estimate with all pricing for the parts you are looking for!

    -Junior
  7. 10-01-2013 06:55 PM - permalink
    Thanks for your response! FYI I don't have a PC at home so i use the public library, my response time will be slow. Great "spark" video!
  8. 08-27-2012 10:08 PM - permalink
    rockledge my name is Derek i have read about a hundred of posts that you have posted on but unfortunantly i have yet to fix my problem i have a 98 ford ranger 2.5 and yes the code p1404 is on but that seems to be the least of my problem. every time i go or rev my engine above about 3k rpm and let off of the gas pedal the engine stutters and dies. i can not figure this out and it makes it very inconvienent because i cant get out into fast flowing traffic due to i cant rev to high cause once i push in the clutch and let off the accelerator the engine shakes and stalls. please help me
  9. 06-20-2011 06:36 AM - permalink
    I am getting this same code. My truck just doesn't have any power. Sometimes though it runs fine and just out of the blue it starts losing power and falling on its face. I have changed several parts and still can not find the solution. Also when I am filling up with gas, the gas keeps kicking off like the fuel is coming back up the neck. Someone please help me.
    Here are the parts I have changed already.
    Fuel pump
    Fuel filter
    Fuel relay
    Idle Air Control
    Mass Air Flow
    Both Oxygen Sensors
    Muffler
    plugs
    plug wires
    I think thats everything. Any input would be greatly appreciated. It's kinda funny cause somedays it runs great and others I can barely pull out and can't pull out on hills because it just doesn't have the power.

    Very Confused,
    James
  10. 10-25-2010 09:47 AM - permalink
    I have an issue with my 98 ranger 4x4. While I was deployed my daughter managed to put my truck in reverse and turn the 4x4 on, ever since it does not work. I have changed the transfer case motor, and now whenever I turn my 4x4 on the lights flashes, and it will only go into low. I have to manual take it out. Could it be a relay issue and if so where is the relay located. ANy help would be greatly appreciated.

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.