Water on dash, now no start.... - Ford Truck Enthusiasts Forums



1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage

Water on dash, now no start....

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2014, 09:09 AM
mgraveman mgraveman is offline
Elder User
Thread Starter
 
Join Date: Feb 2004
Posts: 869
mgraveman has a good reputation on FTE.mgraveman has a good reputation on FTE.mgraveman has a good reputation on FTE.
Water on dash, now no start....

I bought a fleet truck yesterday that had a funky smell to it. I hosed it out and like a moron I hosed the dash too. It started yesterday afterwards, but now it won't. For a while it would start and then die like it was a PATS problem, but now it won't even do that.


Where do I start looking? My odometer doesn't read properly, just lights up as dashes.
Reply With Quote
  #2  
Old 08-31-2014, 09:16 AM
projectSHO89 projectSHO89 is offline
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 12,036
projectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant futureprojectSHO89 has a brilliant future
Disconnect battery negative terminal.

Get a big box fan and point it up under the dash on the driver's side with the doors open. Let it dry out for a day (or as long as possible) like that, then connect everything back up and try again.

There's a fair chance that the water may have caused a short circuit that blew one or more fuses, so get out the fuse diagram for your truck, whatever year and model it might be, and look up the fuses that would affect operation of dead circuits.
Reply With Quote
  #3  
Old 08-31-2014, 03:25 PM
mgraveman mgraveman is offline
Elder User
Thread Starter
 
Join Date: Feb 2004
Posts: 869
mgraveman has a good reputation on FTE.mgraveman has a good reputation on FTE.mgraveman has a good reputation on FTE.
Fuses are all good. There is a hissing noise in the back of the fusebox, sounds like water boiling off. I'm guessing my problem is there.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dash lights not always on when headlamps are on? '12 F250 troverman 1999 to 2016 Super Duty 48 08-21-2016 11:32 PM
New starter, now no start bc2sv 1999 - 2003 7.3L Power Stroke Diesel 3 05-29-2016 01:22 PM
Dash cam psrujak 1999 to 2016 Super Duty 13 02-01-2016 06:38 PM
HELP!!! 2012 EcoBoost won't start after collision balm426 2009 - 2014 F150 16 11-22-2015 08:00 PM
2009 Escape DEAD! Need help. fastwheeler Electrical Systems/Wiring 6 11-26-2014 11:09 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 03:48 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.