New here and having a problem. - Ford Truck Enthusiasts Forums

Notices
Georgia Chapter Join Chapter, Leader: ChiefM SPONSORED BY:

New here and having a problem.

Reply

 
 
 
  #1  
Old 07-21-2010, 08:00 PM
PastorPaul
PastorPaul is offline
Junior User
Thread Starter
Join Date: Jul 2010
Posts: 87
PastorPaul is starting off with a positive reputation.
New here and having a problem.

I bought a 1999 F-350 a little over a year ago. I too it to jiffy lube for an oil change. After the oil change it started to run rough and had a lot of rapping and tapping comming from the top front of the engine I thought. I replaced the idler pulley and the tensioner. Some of the noide went away. the truck still ran rough. After asking for help in the main 7.3 forum I ended up here. I drained the fuel bowl 2 times and refilled it. all the noise has gone away but it still idles rough. I have only driven it 12 miles since doing this. Does anybody have a scanner that lives close to Augusta? There are no warning lights showing on the dash.
 
Reply With Quote
  #2  
Old 08-18-2010, 08:20 PM
toddn78
toddn78 is offline
Senior User
Join Date: Nov 2004
Location: Hephzibah Ga
Posts: 255
toddn78 is starting off with a positive reputation.
Your problem reminded me of the time I had the oil changed in my 94 7.3 work truck. when the service man refilled it with oil he stuck the filler nozzle in the valve cover and broke an injector wire. It seems that the injector wires are made into the valve cover gaskets. Just a thought. Sorry no scan tool.
 
Reply With Quote
  #3  
Old 08-23-2010, 06:44 AM
glruff's Avatar
glruff
glruff is online now
Super Moderator
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 46,055
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Do you have an AutoZone or similar parts store near you?

They can check codes for you and it's usually a free service.
 
Reply With Quote
  #4  
Old 08-26-2010, 12:26 PM
PastorPaul
PastorPaul is offline
Junior User
Thread Starter
Join Date: Jul 2010
Posts: 87
PastorPaul is starting off with a positive reputation.
Problem found! Does anyone have a good flexplate laying around they are not using? I have a 99 PSD with 7.3 diesel.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.