Notices
Modular V10 (6.8l)  
Sponsored by:
Sponsored by:

Buying another V10 - This one whistles...

 
  #1  
Old 06-26-2019, 12:45 AM
V8Notch
V8Notch is offline
Freshman User
Thread Starter
Join Date: Oct 2012
Posts: 35
V8Notch is starting off with a positive reputation.
Buying another V10 - This one whistles...

Looking to replace my 2005 that was stolen.

Test drove a clean 2008 the other day. Drove well but when accelerating hard it whistled. I'm assuming it was from the intake. Is this typical for the 2008+? Only has 80k miles on it. My 05 had 160+ but didn't make any noise like this. Owner is happy for me to take it to a shop but says its' always made this noise since they got it 5 years ago.

Thanks!
 
  #2  
Old 06-26-2019, 06:49 AM
Krewat's Avatar
Krewat
Krewat is online now
Admin Newbie
Join Date: Jul 2002
Location: Long Island USA
Posts: 40,127
Krewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputation
Make sure the air cleaner is OK?
 
  #3  
Old 06-26-2019, 07:32 AM
Im50fast's Avatar
Im50fast
Im50fast is offline
Humblest guy ever
Join Date: Apr 2013
Location: Central Florida
Posts: 3,042
Im50fast has a great reputation on FTE.Im50fast has a great reputation on FTE.Im50fast has a great reputation on FTE.Im50fast has a great reputation on FTE.Im50fast has a great reputation on FTE.
My 07 v10 e350 makes a bit of a whistling sound upon acceleration. I think itís in the transmission though. Never had any issues
 
  #4  
Old 06-26-2019, 01:47 PM
johnfist
johnfist is online now
Senior User
Join Date: Dec 2017
Posts: 440
johnfist is starting off with a positive reputation.
My 08 doesn't do that. Likely something with the intake. I'd assume not major. I'd check the entire air intake path. Filter might be clogged/crappy. Something maybe got sucked up, or maybe there's a blockage from a nest of some kind. Or maybe the actual intake isn't tight enough on the manifold.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.