5.0l electrical issue - Ford Truck Enthusiasts Forums

Notices
1968-2013 Full Size Vans Econolines. E150, E250, E350, E450 and E550

5.0l electrical issue

  #1  
Old 10-02-2018, 01:39 PM
mbowyer
mbowyer is offline
New User
Thread Starter
Join Date: May 2011
Posts: 2
mbowyer is starting off with a positive reputation.
5.0l electrical issue

I have a 1994 ford E150 conversion van with a 5.0l. My dad hit a bump and it shut down. it cranks but won't start. checked the shut off switch and it's fully functional, I tried to scan it ,but it wouldn't test, the check engine light didn't even come on, there is power at the dtc so tried it with a jumper wire still no self test or engine light. I then separately tested for spark -no spark at coil or distributor nor was I getting fuel. replaced the icm got fuel back but no spark,injector pulse or power at the knock sensor checked power relays,fuses and ecm all have power, dtc still not functional but has power when I try to run the test with the dtc the test light stays solid on any idea's where to start thank you for any help
 

Last edited by mbowyer; 10-02-2018 at 01:40 PM. Reason: added important information
  #2  
Old 10-05-2018, 10:30 AM
subford's Avatar
subford
subford is online now
Post Fiend
Join Date: Aug 2005
Location: Easton,Ks
Posts: 21,496
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
What are you calling the dtc? The EEC Self-Test Connector?
If so what pin has power on it?
Kinda sounds like the PCM Power relay is not making (closing) when the key is turn to run or start.
Check the Ignition switch connector for good connection.

If you replaced the ICM make sure it was Black in color like the old one should have been.
 
  #3  
Old 10-07-2018, 06:48 AM
jeffreyclay's Avatar
jeffreyclay
jeffreyclay is online now
Senior User
Join Date: Nov 2015
Location: Bedford, Va
Posts: 438
jeffreyclay is starting off with a positive reputation.
Have you tried resetting the "impact detector" device? It's located behind the passenger side kick panel. An up close inspection will show the molded channel you are to place your finger in to find the button. This is a safety device to shutdown the van in case of a wreck. It can sometimes be set with a good smack while sitting in a parking lot.
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.