Need help! Airbag light. - Ford Truck Enthusiasts Forums

Notices
1968-2013 Full Size Vans Econolines. E150, E250, E350, E450 and E550

Need help! Airbag light.

  #1  
Old 11-13-2017, 01:29 AM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Need help! Airbag light.

96 Ford E-150 351w

When I bought my van, the airbad light was blinking. I had ignored it and i think the bulb went out. Now it has been beeping non stop.

So I pulled the dash and replaced the bulb.

Well that didn't do anything. The new bulb isn't working and the beeping continues. I've checked all fuses and they are ok.

Is there something I need to reset after changing the bulb or do I have a more serious problem?

TIA


-----



UPDATE:
So I've finally had enough and decided to just remove the airbag module

If anyone reads this, make sure you disconnect your battery and wait a few minutes while all the power is drained from the unit. Also I assume that your airbags will not work anymore.

Here are some pictures. The module is the blue box. In my van it was located under the steering wheel. I should've known better because the previous owner had some crazy CD changer, stereo setup and there are a massive amount of wires under the steering wheel. Probably the source of the problem but I am not knowledgeable enough to troubleshoot it.




This is the actual unit. I circled where the beeper actually is. As jeffreyclay stated, that is what you want to solder off.




As my van's final FU to me, the airbag light came back on and is now solid. LOL




Last question,

Now since I removed my Airbag module, can the airbag accidentally ever go off?

That has always worried be a little bit since I bought the van. The blinking airbag light always made me just a tad worried, not I would like to think that since the module is gone, the airbags will never accidentally deploy. I am ok with having no airbags. Drove cars without them before.
 
  #2  
Old 11-13-2017, 03:23 AM
maples01's Avatar
maples01
maples01 is offline
Postmaster
Join Date: May 2004
Location: Maryville
Posts: 3,747
maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.
Air bag doesn't beep, and thank god for that, mines been on 10+ years, I think the seat belt is to blame, the beeping is when you open the door with the key in, mine did that while driving one day, thank god it corrected itself, I wanted to rip out that chime.
I changed my bulbs, are you sure you got it in right, sometimes the tab will go under the contact instead of on it, so it'll not work.
 
  #3  
Old 11-13-2017, 11:40 AM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Originally Posted by maples01 View Post
Air bag doesn't beep, and thank god for that, mines been on 10+ years, I think the seat belt is to blame, the beeping is when you open the door with the key in, mine did that while driving one day, thank god it corrected itself, I wanted to rip out that chime.
I changed my bulbs, are you sure you got it in right, sometimes the tab will go under the contact instead of on it, so it'll not work.
Thanks for the response.

The thing is, the beeping sound started after the airbag light went out.

I replaced both of the 2 bulbs next to the right turn signal, they both are not turning on.

[X] [airbag] [rightturnsignal]

I'm not sure what the X light is. I'm guessing seat belt?

I took out the bulb and reseated them multiple times to be sure.

Maybe it is the seat belt. I'm get 5 beeps, 5 beeps then a long pause.

Sometimes it just continuously beeps until I stop the car.
 
  #4  
Old 11-13-2017, 12:34 PM
WarrensE350's Avatar
WarrensE350
WarrensE350 is offline
Senior User
Join Date: Aug 2013
Posts: 358
WarrensE350 is gaining momentum as a positive member of FTE.
  #5  
Old 11-13-2017, 01:53 PM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Originally Posted by WarrensE350 View Post
I've read that thread and it is what led me to replace the airbad bulb, which I have done, but the light doesn't come on and the beeping continues.

Do you know if I need to do something extra after replacing the bulb, like a reset?
 
  #6  
Old 11-13-2017, 01:54 PM
maples01's Avatar
maples01
maples01 is offline
Postmaster
Join Date: May 2004
Location: Maryville
Posts: 3,747
maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.
Shortly after buying mine, I had to take it in to the dealer, the gauges would quit working, I can't recall what was done to fix it, but the warning lights in the cluster were out. You could have a short.
 
  #7  
Old 11-13-2017, 01:55 PM
WarrensE350's Avatar
WarrensE350
WarrensE350 is offline
Senior User
Join Date: Aug 2013
Posts: 358
WarrensE350 is gaining momentum as a positive member of FTE.
I don't know. Further in the thread it does mention a passenger seat connector that was loose, may be worth looking into something like that for a root cause.

Thought I saw somewhere about disconnecting the battery to reset things?
 
  #8  
Old 11-13-2017, 04:41 PM
maples01's Avatar
maples01
maples01 is offline
Postmaster
Join Date: May 2004
Location: Maryville
Posts: 3,747
maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.
With the bulbs out I wonder that the bell could be due to the short causing the lights not to function.
 
  #9  
Old 11-13-2017, 05:03 PM
jeffreyclay's Avatar
jeffreyclay
jeffreyclay is offline
Senior User
Join Date: Nov 2015
Location: Bedford, Va
Posts: 438
jeffreyclay is starting off with a positive reputation.
I ran into the same thing on my '94. Light was randomly coming and going then it burned out. Beeps started and I read that it was a warning the the airbag system was disabled and it recognized a bad bulb. I too replaced the bulb only to find it not lighting and the darn beeping continued. Was about to go crazy from the "morse code like" beeping. I pulled the air bag control module (under dash, close to steering column) and unsoldered the beeper module and threw it away. Reconnected the control unit and continued to drive. Too big a headache to troubleshoot and I've already spent $350 on a clockspring (only the 94 model cost this much)
 
  #10  
Old 11-13-2017, 05:12 PM
maples01's Avatar
maples01
maples01 is offline
Postmaster
Join Date: May 2004
Location: Maryville
Posts: 3,747
maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.maples01 has a good reputation on FTE.
The light is on in my 99, I ignore it, I had to replace the belt buckle on the drivers seat because the stupid steel cable Ford used broke, never in all my years scouring junkyards have I ever seen a belt fail, guess thats why they went to steel cable, since it's to a piston unit Ford gave me a $300 quote, I told them I'm not buying a failed safety device, they're liable, I ended up going to the junkyard, they don't care. I figured my light is due to that but the extension cord connecting it, for my 6 way power seat could have a short, I just pray it's not the clock spring. I did have a bong driving years ago, I thought it was the door indicator, it quit, you guys have me worrying that it was the airbag sensor, how do you find out? Where are the codes for a blinking airbag light?
 
  #11  
Old 11-13-2017, 06:08 PM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Originally Posted by jeffreyclay View Post
I ran into the same thing on my '94. Light was randomly coming and going then it burned out. Beeps started and I read that it was a warning the the airbag system was disabled and it recognized a bad bulb. I too replaced the bulb only to find it not lighting and the darn beeping continued. Was about to go crazy from the "morse code like" beeping. I pulled the air bag control module (under dash, close to steering column) and unsoldered the beeper module and threw it away. Reconnected the control unit and continued to drive. Too big a headache to troubleshoot and I've already spent $350 on a clockspring (only the 94 model cost this much)
now that you mention clockspring.

Sometimes when turning a left my door lock switch engages. Is that a symptom of a bad clockspring?

Also, how simple is it to remove the beeper from the module? Is it pretty self explanatory or do you really need to know what to look for.

Also, if I don't mind driving without airbags (there already seems to be a problem), can I just pull a fuse?
 
  #12  
Old 11-13-2017, 06:12 PM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Originally Posted by maples01 View Post
The light is on in my 99, I ignore it, I had to replace the belt buckle on the drivers seat because the stupid steel cable Ford used broke, never in all my years scouring junkyards have I ever seen a belt fail, guess thats why they went to steel cable, since it's to a piston unit Ford gave me a $300 quote, I told them I'm not buying a failed safety device, they're liable, I ended up going to the junkyard, they don't care. I figured my light is due to that but the extension cord connecting it, for my 6 way power seat could have a short, I just pray it's not the clock spring. I did have a bong driving years ago, I thought it was the door indicator, it quit, you guys have me worrying that it was the airbag sensor, how do you find out? Where are the codes for a blinking airbag light?
The airbag light in my 96 used to blink a code. I wish I would've remembered it. That was last on my list of things, but the bulb burned out.

It used to blink repeatedly while driving.
 
  #13  
Old 11-13-2017, 08:04 PM
NICKSAN
NICKSAN is offline
Senior User
Join Date: Oct 2014
Location: Pasadena, California
Posts: 416
NICKSAN is starting off with a positive reputation.
I fixed my blinking air bag light with a piece of Electrical tape.
 
  #14  
Old 11-13-2017, 08:37 PM
kennyfzj80
kennyfzj80 is offline
Senior User
Thread Starter
Join Date: Jul 2015
Posts: 150
kennyfzj80 is starting off with a positive reputation.
Originally Posted by NICKSAN View Post
I fixed my blinking air bag light with a piece of Electrical tape.
Once the bulb burns out you'll get the beeping like me.
 
  #15  
Old 11-13-2017, 09:38 PM
NICKSAN
NICKSAN is offline
Senior User
Join Date: Oct 2014
Location: Pasadena, California
Posts: 416
NICKSAN is starting off with a positive reputation.
Originally Posted by kennyfzj80 View Post
Once the bulb burns out you'll get the beeping like me.
Yes, but I`ll just turn up the volume on the radio, That fixes all types of odd sounds coming from any vehicle, I think its on page 19-4 of the haynes manual.
 

Thread Tools
Search this Thread
Quick Reply: Need help! Airbag light.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.