No start - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

No start

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-21-2012, 06:01 PM
reg1952's Avatar
reg1952 reg1952 is offline
Senior User
Thread Starter
 
Join Date: Nov 2007
Location: Guelph
Posts: 477
reg1952 is gaining momentum as a positive member of FTE.reg1952 is gaining momentum as a positive member of FTE.
No start

Hey guys I am always over on the old truck side of this site but I got a proplem with a 07 Expedition.Once in a while it wont start.Will not crank and insturment cluster is dead.Get out close door get back in and if I/C is back working it will start.Also once in a while door ajar,TPMS,and brake light come on but it runs fine. Any ideas?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Door Locks not working properly tlolesen 2004 - 2008 F150 6 12-26-2013 09:59 PM
Passenger Rear door lock KTMcrazy 1987 - 1996 F150 & Larger F-Series Trucks 0 12-17-2012 12:45 AM
barn door with Handle question Eastland Excursion - King of SUVs 1 06-05-2012 12:45 AM
"Door Open" Message? Ford_Pete 2009 - 2014 F150 3 08-24-2010 05:58 AM
Something to revitalize the interior Chaosracing Appearance & Dress-Up 3 11-11-2009 01:37 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 10:52 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send