Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Reload this Page >

"CLEANING EXHAUST FILTER" NOW STAYING ON

Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

"CLEANING EXHAUST FILTER" NOW STAYING ON

 
  #16  
Old 05-28-2011, 07:41 PM
Ian123's Avatar
Ian123
Ian123 is offline
Posting Guru
Join Date: Sep 2009
Location: Virginia beach, VA
Posts: 1,714
Ian123 has a very good reputation on FTE.Ian123 has a very good reputation on FTE.Ian123 has a very good reputation on FTE.
Originally Posted by galaxie641 View Post
Tell me a "manual regen" isn't them turning it on and letting the truck idle. Would make sense why my LOM reads around 3-4 every time I get the truck back from the dealer, also explains all the oil it makes.
The probably put it on high idle (1200 rpm)
 
  #17  
Old 05-28-2011, 10:38 PM
03SD6L
03SD6L is offline
Freshman User
Join Date: Oct 2006
Location: Lethbridge
Posts: 28
03SD6L is starting off with a positive reputation.
Hi guys this is what i noticed with the latest flash. Today i got the message "drive to clean exhaust" so i took the truck on the highway then the "cleaning exhaust" came on and stayed on for the whole cleaning, when it finished the message saying the exhaust cleaning is finished came on. So maybe when it goes into a full regen now it stays on, had a lot of passive regen that the cleaning exhaust message came on for about 4-5 seconds and you don't see anything once it complete.
 
  #18  
Old 05-28-2011, 10:54 PM
Super08's Avatar
Super08
Super08 is offline
Posting Guru
Join Date: Aug 2005
Location: Alberta, Canada
Posts: 2,051
Super08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to behold
Since I got flashed last week mine no longer shows when it is in regen. I am so used to it I can tell. I am not sure if it is a sound I pick up on or what as I even notice in cruise when it kicks in. a quick glance down confirms it by the low boost pressure. A system check also confirms.
 
  #19  
Old 05-29-2011, 07:20 AM
senix's Avatar
senix
senix is offline
Moderator
Join Date: Aug 2008
Location: Frederick, MD
Posts: 29,653
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
Originally Posted by 03SD6L View Post
Hi guys this is what i noticed with the latest flash. Today i got the message "drive to clean exhaust" so i took the truck on the highway then the "cleaning exhaust" came on and stayed on for the whole cleaning, when it finished the message saying the exhaust cleaning is finished came on. So maybe when it goes into a full regen now it stays on, had a lot of passive regen that the cleaning exhaust message came on for about 4-5 seconds and you don't see anything once it complete.
You were not passively regening. What happened is because the message normally just stays on a few seconds, there is no way to tell when finished unless you cycle thru the screens. So after so many of the regen imcompletes it gave you the "Drive to Clean" one.

This is the problem with the lastest flashes. It would be better to show the message all the time.
 
  #20  
Old 05-29-2011, 08:26 AM
Super08's Avatar
Super08
Super08 is offline
Posting Guru
Join Date: Aug 2005
Location: Alberta, Canada
Posts: 2,051
Super08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to behold
I think ford took the full time msg away to try and cut down on how often some people see their trucks regen. Maybe they can slip some through without people noticing and cut down on complaints.
 
  #21  
Old 05-29-2011, 08:47 AM
StanleyZ's Avatar
StanleyZ
StanleyZ is offline
Postmaster
Thread Starter
Join Date: Nov 2001
Posts: 3,444
StanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to behold
Originally Posted by senix View Post
You were not passively regening. What happened is because the message normally just stays on a few seconds, there is no way to tell when finished unless you cycle thru the screens. So after so many of the regen imcompletes it gave you the "Drive to Clean" one.

This is the problem with the lastest flashes. It would be better to show the message all the time.
Sennix I hesitate to say this because you always seem to know what you are talking about but, my one and only "DRIVE TO CLEAN" came at the end of a two or so hour run on the interstate up the mountain into cheyenne WY. I never have been able to account for why it did that. On that same trip I had two "CLEANING" messages that stayed on, just like the two that caused me to start this post. All of these abberations happened while towing my heavy (17,000 +/-) trailer. but that may not mean anything as I seldom drive it when I'm not towing. I'm thinking there is some kind of small bug in my program. Otherwise, it doesn't make sense.
 
  #22  
Old 05-29-2011, 08:50 AM
senix's Avatar
senix
senix is offline
Moderator
Join Date: Aug 2008
Location: Frederick, MD
Posts: 29,653
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
Stanley, you maybe right on the bug in the programming. I would say that is more the case then now..wonder if they are using windows vista?

I just think in the post above it was probably more of because of incompletions.
 
  #23  
Old 05-29-2011, 11:25 AM
parkland
parkland is offline
Post Fiend
Join Date: Jan 2006
Posts: 6,181
parkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud ofparkland has much to be proud of
Originally Posted by senix View Post
wonder if they are using windows vista?
LOL
 
  #24  
Old 05-29-2011, 02:45 PM
Ian123's Avatar
Ian123
Ian123 is offline
Posting Guru
Join Date: Sep 2009
Location: Virginia beach, VA
Posts: 1,714
Ian123 has a very good reputation on FTE.Ian123 has a very good reputation on FTE.Ian123 has a very good reputation on FTE.
I have Vista and dont see why everyone hates it, although it comes out with updates almost as often as the re-flashes for the 6.4. Maybe there is a connection lol
 
  #25  
Old 05-29-2011, 03:33 PM
03SD6L
03SD6L is offline
Freshman User
Join Date: Oct 2006
Location: Lethbridge
Posts: 28
03SD6L is starting off with a positive reputation.
i get the "cleaning filter" message about every 200-400 km, i take the truck on the highway and drive it until the message does not come up, this is going through the message screen hitting the set up button then reset and when the cleaning filter message is not shown any longer (about 20-30 km) the cycle is complete. You get the Drive to clean exhaust message any where between 2000-4000 km that is a full regen. That is what a Ford tech told me when i got the flash before the latest flash he alos printed out how that flash worked, i'll see if i can find it and post it. Now what is see happening with my first Drive to clean exhaust since the new flash is that it stays on for the entire cleaning and you get the message at the end that the filter is clean.
 
  #26  
Old 05-29-2011, 06:12 PM
MexicanScaper987's Avatar
MexicanScaper987
MexicanScaper987 is offline
Postmaster
Join Date: Nov 2007
Location: Bucks county PA
Posts: 2,556
MexicanScaper987 is a splendid one to beholdMexicanScaper987 is a splendid one to beholdMexicanScaper987 is a splendid one to beholdMexicanScaper987 is a splendid one to beholdMexicanScaper987 is a splendid one to beholdMexicanScaper987 is a splendid one to behold
Since my truck has been flashed, it seems to be cleaning itself more often as well. The message does not stay on during the duration though but I kinda wish it did. I always try to run the truck until its finished and it would sure make it easier to monitor.
 
  #27  
Old 05-31-2011, 11:29 AM
kl817
kl817 is offline
New User
Join Date: May 2011
Posts: 1
kl817 is starting off with a positive reputation.
No message when cleaning

Since the update it no longer says cleaning exhaust. There has always been a distinctive odor when it is cleaning. Now the only way I can tell that it is cleaning is by the odor. It never last long either. Is anyone else getting the odor, or do I have some kind of leak while it is cleaning?
 
  #28  
Old 05-31-2011, 01:47 PM
Super08's Avatar
Super08
Super08 is offline
Posting Guru
Join Date: Aug 2005
Location: Alberta, Canada
Posts: 2,051
Super08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to beholdSuper08 is a splendid one to behold
I never smell anything unless I am outside right after stopping.
 
  #29  
Old 05-31-2011, 03:31 PM
StanleyZ's Avatar
StanleyZ
StanleyZ is offline
Postmaster
Thread Starter
Join Date: Nov 2001
Posts: 3,444
StanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to beholdStanleyZ is a splendid one to behold
Originally Posted by kl817 View Post
Since the update it no longer says cleaning exhaust. There has always been a distinctive odor when it is cleaning. Now the only way I can tell that it is cleaning is by the odor. It never last long either. Is anyone else getting the odor, or do I have some kind of leak while it is cleaning?
If you watch for it I think you will find that the CLEANING EXHAUST FILTER message comes up on your message center for just a few seconds when the regen starts. It is easy to miss. Also, when you suspect you are in regen you can verify it by pushing the middle button on the message center and then the top button. The message center will go through the normal checks and at the end display the cleaning exhaust filter message. And, yes if you are smelling the exhaust in the cab either in regen or not there is something wrong. Based on comments on here I would say it will be difficult to get the dealer to fix it but there is something wrong.
 
  #30  
Old 06-01-2011, 01:31 AM
aquaman
aquaman is offline
Posting Guru
Join Date: Jul 2005
Location: San Jose, CA
Posts: 1,001
aquaman is gaining momentum as a positive member of FTE.aquaman is gaining momentum as a positive member of FTE.
I think the algorithm that runs the regens is not just based off a simple pressure differential across the DPF. It likely takes in account how much air mass is supposedly moving though the engine as well.

I once made a run with the back loaded up the I-5 Grapevine with 25psi boost most of the way just to be welcomed with a regen right after I got over the top and shortly after I let off the throttle. Nice... instead of squirting in a little more fuel on the way up on a hot engine, it chose to do it on light throttle on the way downhill. Similar thing happened on another trip up I80 leaving Reno going toward Sacramento.
 

Thread Tools
Search this Thread
Quick Reply: "CLEANING EXHAUST FILTER" NOW STAYING ON


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: