Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs
Sign in using an external account
Register Forgot Password?


Excursion - King of SUVs 2000 - 2005 Ford Excursion

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-28-2010, 07:32 AM
Skip1970's Avatar
Skip1970 Skip1970 is online now
Semper Fi MOFO!
 
Join Date: Nov 2008
Location: Lost in Alaska
Posts: 8,987
Skip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputation
greythorn3
security from factory?

I believe i have a factory security system, when i push the lock key fob 2x it beeps the horn, but there is no light on the dash, is there no light or is the bulb burned out or what? anyone know what bulb number it might be if there is one? and where the light is at?

2000 excursion 7.3 limited.
__________________
00EX7.3 powerstop rotors, coated calipers, pads, 6337 filter, FRX, HPX, cobalt gauges, riff raff intercooler boots, plenum inserts. alternator 1/30/2012 199226 miles
air filter, oil filter 213673 miles.fuel filter 4/14/2013 212221 Miles.

Praise the Lord and Pass the Ammunition. Semper Fi
Reply With Quote
  #2  
Old 08-28-2010, 08:23 AM
Shepherd2 Shepherd2 is offline
Senior User
 
Join Date: Sep 2009
Posts: 467
Shepherd2 has a good reputation on FTE.Shepherd2 has a good reputation on FTE.
I dont think there is one. On my 02 the only light that flashes is the Theft indicator on the cluster for the Pats.
Reply With Quote
  #3  
Old 08-28-2010, 08:47 AM
Snowseeker's Avatar
Snowseeker Snowseeker is offline
Post Fiend
 
Join Date: May 2005
Location: Stevens Point, WI
Posts: 9,758
Snowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputationSnowseeker has a superb reputation
My 03 also beeps the horn if I press the lock twice.
__________________
http://www.ford-trucks.com/forums/image.php?type=sigpic&userid=272341&dateline=13273  66346
03 7.3 EB AIH delete, jetted dead head fix, 06 front end with custom fab bumper, oil changes.
04 6.0 XLT Studs, stealth egr delete, and some other stuff. 'Chitty'
Reply With Quote
  #4  
Old 08-28-2010, 11:38 AM
Helidriver's Avatar
Helidriver Helidriver is offline
Freshman User
 
Join Date: Jul 2010
Location: Avondale, AZ
Posts: 33
Helidriver is starting off with a positive reputation.
Unless you have added an alarm there isn't one (at least on the 2000). The theft light refers to the transponder key anti theft system, not an alarm. When you double click your fob the horn beeps confirming your lock doors command. There is an anti theft system but it's passive and only has to do with the ignition key.

I had the same question and actually found the answer in the owners manual.

Now I'm trying to find an alarm that will work in my Ex without butchering the factory wiring harness.
Reply With Quote
  #5  
Old 08-28-2010, 11:52 AM
RPEX RPEX is offline
New User
 
Join Date: Aug 2010
Posts: 22
RPEX is starting off with a positive reputation.
I have a 2000 and I bought it with a viper system already installed and I wouldn't reccomend that peticular one. I had a mechanic friend look at it because I was having problems with the door locks and he told me that some vehicles just have problems with certain systems. He said once he ripped out his viper system things went back to normal (he was having the same issues). I don't know if it is actually the system itself or the way it was installed but I do know I have issues with mine.
Reply With Quote
  #6  
Old 08-28-2010, 04:15 PM
Shepherd2 Shepherd2 is offline
Senior User
 
Join Date: Sep 2009
Posts: 467
Shepherd2 has a good reputation on FTE.Shepherd2 has a good reputation on FTE.
Quote:
Now I'm trying to find an alarm that will work in my Ex without butchering the factory wiring harness.
You need to get one of these. http://www.xpresskit.com/product.aspx?productid=202

And more important than the alarm itself is the install.
Just got one of these with remote start for $150. C3 RS-915LCD - 2-Way Communications - AutoPage
Man there's alot of wires.
Reply With Quote
  #7  
Old 08-28-2010, 06:59 PM
Moto Mel's Avatar
Moto Mel Moto Mel is offline
Postmaster
 
Join Date: Jan 2009
Location: Chesapeake, Va.
Posts: 4,574
Moto Mel has a great reputation on FTE.Moto Mel has a great reputation on FTE.Moto Mel has a great reputation on FTE.Moto Mel has a great reputation on FTE.Moto Mel has a great reputation on FTE.
Quote:
Originally Posted by Shepherd2 View Post
You need to get one of these. http://www.xpresskit.com/product.aspx?productid=202

And more important than the alarm itself is the install.
Just got one of these with remote start for $150. C3 RS-915LCD - 2-Way Communications - AutoPage
Man there's alot of wires.
I've got a Viper in mine and I'm not happy with it. I'm very interested in how yours works out so make an update on it when it's installed and operating. Looks like a good system.
Reply With Quote
  #8  
Old 08-28-2010, 07:57 PM
AlaskanEx's Avatar
AlaskanEx AlaskanEx is online now
Post Fiend
 
Join Date: Apr 2009
Location: Anchorage Alaska
Posts: 9,076
AlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputation
how happy you are with a aftermarket remote start/alarm realllly depends alot on the installer. in my opinion, which luckly i have a guy i trust.

i had the older style 2 way remote start/alarm viper on my old '04

this monday im dropping my '00 off to get the new top of the line viper remote start/alarm with the cool color LCD key fob an all that jazz. i expect to be just as happy with the one. the one mile range on the viper worked great!
__________________
Russ-
2011 F-150 Limited #3679 6.2 V8 4x4, Retrax bed cover
2002 Excursion Limited V10 4x4, 2.5/2" lift, HIDs,20" DC wheels on Cooper LTZ, Daily Driver
1998 Expedition XLT 5.4 4x4,HIDs,16x8 ultra wheels,led taillights, Daily Driver
1991 F-250 lairat 4x4 5.0, 7'6" BOSS snow plow, Back Rack, Strobes, Work lights
Reply With Quote
  #9  
Old 08-28-2010, 09:45 PM
Shepherd2 Shepherd2 is offline
Senior User
 
Join Date: Sep 2009
Posts: 467
Shepherd2 has a good reputation on FTE.Shepherd2 has a good reputation on FTE.
I've always wondered about alarms that claim a one mile range, so it really works? Actually the Autopage I got can operated with a cell phone from Tokyo if you get the optional module. Kinda cool but it gets pricey. Even has gps tracking to keep an eye on the kids or spouse . What is C3?
Reply With Quote
  #10  
Old 08-28-2010, 11:28 PM
AlaskanEx's Avatar
AlaskanEx AlaskanEx is online now
Post Fiend
 
Join Date: Apr 2009
Location: Anchorage Alaska
Posts: 9,076
AlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputation
yeah i've been downtown before with the truck in the parking garage atleast 1/2 mile away(that walk sucked in the winter) and it worked, i got into a nice toasty warm truck. ofcourse that was with buildings..ect so in better conditions it should work at the stated 1 mile range. i'll say this i never had a situation where i did not have contact with the truck.
__________________
Russ-
2011 F-150 Limited #3679 6.2 V8 4x4, Retrax bed cover
2002 Excursion Limited V10 4x4, 2.5/2" lift, HIDs,20" DC wheels on Cooper LTZ, Daily Driver
1998 Expedition XLT 5.4 4x4,HIDs,16x8 ultra wheels,led taillights, Daily Driver
1991 F-250 lairat 4x4 5.0, 7'6" BOSS snow plow, Back Rack, Strobes, Work lights
Reply With Quote
  #11  
Old 08-28-2010, 11:32 PM
Skip1970's Avatar
Skip1970 Skip1970 is online now
Semper Fi MOFO!
 
Join Date: Nov 2008
Location: Lost in Alaska
Posts: 8,987
Skip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputation
greythorn3
alright, im trying to install my transponder data bypass module, XK04 and its not programming, i want to install it with my remote start before it gets cold. damn these transponders suck!
__________________
00EX7.3 powerstop rotors, coated calipers, pads, 6337 filter, FRX, HPX, cobalt gauges, riff raff intercooler boots, plenum inserts. alternator 1/30/2012 199226 miles
air filter, oil filter 213673 miles.fuel filter 4/14/2013 212221 Miles.

Praise the Lord and Pass the Ammunition. Semper Fi
Reply With Quote
  #12  
Old 08-28-2010, 11:43 PM
AlaskanEx's Avatar
AlaskanEx AlaskanEx is online now
Post Fiend
 
Join Date: Apr 2009
Location: Anchorage Alaska
Posts: 9,076
AlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputation
yeah thats one reason i wont touch remote starts/alarms. i love wiring and do alot at work but those just look like a pain in the ***. so i say goodluck! haha
__________________
Russ-
2011 F-150 Limited #3679 6.2 V8 4x4, Retrax bed cover
2002 Excursion Limited V10 4x4, 2.5/2" lift, HIDs,20" DC wheels on Cooper LTZ, Daily Driver
1998 Expedition XLT 5.4 4x4,HIDs,16x8 ultra wheels,led taillights, Daily Driver
1991 F-250 lairat 4x4 5.0, 7'6" BOSS snow plow, Back Rack, Strobes, Work lights
Reply With Quote
  #13  
Old 08-29-2010, 11:40 AM
Skip1970's Avatar
Skip1970 Skip1970 is online now
Semper Fi MOFO!
 
Join Date: Nov 2008
Location: Lost in Alaska
Posts: 8,987
Skip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputation
greythorn3
ok pulled the dash apart! there is no THEFT BULB in the hole! that why i wasent getting the dang light.. anyone know what socket it is and bulb becuase it different then the rest of them!

also come to find out my do ajar light was out so gonna replace the bulb. neat feature i didnt realize i had! hehehe

heres some pics
Attached Images
   
__________________
00EX7.3 powerstop rotors, coated calipers, pads, 6337 filter, FRX, HPX, cobalt gauges, riff raff intercooler boots, plenum inserts. alternator 1/30/2012 199226 miles
air filter, oil filter 213673 miles.fuel filter 4/14/2013 212221 Miles.

Praise the Lord and Pass the Ammunition. Semper Fi
Reply With Quote
  #14  
Old 01-03-2011, 05:58 AM
Skip1970's Avatar
Skip1970 Skip1970 is online now
Semper Fi MOFO!
 
Join Date: Nov 2008
Location: Lost in Alaska
Posts: 8,987
Skip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputationSkip1970 has a superb reputation
greythorn3
anyone know if the dash cluster is linked to pats? so you cant swap them out to a junkyard one?
__________________
00EX7.3 powerstop rotors, coated calipers, pads, 6337 filter, FRX, HPX, cobalt gauges, riff raff intercooler boots, plenum inserts. alternator 1/30/2012 199226 miles
air filter, oil filter 213673 miles.fuel filter 4/14/2013 212221 Miles.

Praise the Lord and Pass the Ammunition. Semper Fi
Reply With Quote
  #15  
Old 01-03-2011, 11:33 AM
jh818's Avatar
jh818 jh818 is offline
Postmaster
 
Join Date: Jul 2009
Location: Chino, California
Posts: 2,597
jh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputation
I think if you swap the instrument cluster, you'll need to have it reset or something at the dealer. Your odometer won't work right or something like that.
__________________
2002 Excursion XLT V10 2WD 4.30 Limited Slip
Bone stock with restrictive Y-pipe and Michelin AT/2
Front Hitch Reciver, Rear Hellwig Sway Bar 7643
Reply With Quote
Old 01-03-2011, 11:33 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs

Tags
alarm, alarms, auto, autopage, excursion, factory, ford, installing, key, security, series, system, transponder, trouble, van, work, xpresskit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 03:20 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup