Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 01-16-2005, 11:09 PM
IDF150Dude IDF150Dude is offline
New User
 
Join Date: Jan 2005
Posts: 1
IDF150Dude is starting off with a positive reputation.
Primary Battery Fuses

Hello Everyone.
This is my first time visiting your board, and I must admit its been very helpful in locating info on the many things wrong with my baby. I have a 1997 F-150 with the 4.6L V-8. Just recently it has been having a major miss problem. Ive read a few people have had this problem already. But it will hesitate, idle rough...when I accelerate nice and smooth, she shakes and rattles, and when I mash on the pedal, she goes...and will shake until she passes 40mph. The Check Engine Light blinks, and then stays on steady.
It has gotten severly worse, to where she has been hard to start...I just recently took her into a mechanic, and he hooked his computer up, and said that Cyl. 1-4 were misfiring. He pulled the plugs, all were fouled. Replaced them, did a pressure test...then some other kind of test (Cant rightly remember) said it should be ok from there...went away for a few days and is back again.
Then this evening, I went for a drive. She started up, ran kinda rough, but hey she was runnin'. Got home, parked her in the driveway went inside. The wife had to go somewhere, and wanted to take my rig. She went out to start it up...wouldnt fire...wont even try and turn over. There was a loud double pop noise...coming from the cover over the primary batt fuses...there is no power to the truck at all...no dome light...break lights wont come on...the dash lights are so dim, you can just barely see them. What do i do? Cant even take it to the dealer cause I cant get it started.

I know its long, but thanx for stickin with me here! You guys are awesome!
Thanx in Advance,
Josh

Last edited by IDF150Dude; 01-16-2005 at 11:15 PM. Reason: Orig. Posted wrong engine size
Reply With Quote
  #2 (permalink)  
Old 01-17-2005, 08:03 AM
projectSHO89 projectSHO89 is online now
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 8,864
projectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to behold
First, get primary power back. Check the 175 A mega-fuses under that cover. There are two of them. One provides protection between the alternator and the battery, the other provides power to the rest of the vehicle. Check them. Also check for burned or damaged cable connectors under the cover and at the battery.

Make certain you disconnect the negative battery cable before attempting any repair work on the mega-fuses or cabling.

Once power is restored, you can go back to the original problem.

Steve
Reply With Quote
  #3 (permalink)  
Old 01-17-2005, 08:05 AM
IB Tim's Avatar
IB Tim IB Tim is online now
Site Administrator
 
Join Date: Jan 2003
Location: 3rd Rock
Posts: 111,598
IB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputationIB Tim has a superb reputation
Quote:
Originally Posted by IDF150Dude
Hello Everyone.
This is my first time visiting your board, and I must admit its been very helpful in locating info on the many things wrong with my baby. I have a 1997 F-150 with the 4.6L V-8. Just recently it has been having a major miss problem. Ive read a few people have had this problem already. But it will hesitate, idle rough...when I accelerate nice and smooth, she shakes and rattles, and when I mash on the pedal, she goes...and will shake until she passes 40mph. The Check Engine Light blinks, and then stays on steady.
It has gotten severly worse, to where she has been hard to start...I just recently took her into a mechanic, and he hooked his computer up, and said that Cyl. 1-4 were misfiring. He pulled the plugs, all were fouled. Replaced them, did a pressure test...then some other kind of test (Cant rightly remember) said it should be ok from there...went away for a few days and is back again.
Then this evening, I went for a drive. She started up, ran kinda rough, but hey she was runnin'. Got home, parked her in the driveway went inside. The wife had to go somewhere, and wanted to take my rig. She went out to start it up...wouldnt fire...wont even try and turn over. There was a loud double pop noise...coming from the cover over the primary batt fuses...there is no power to the truck at all...no dome light...break lights wont come on...the dash lights are so dim, you can just barely see them. What do i do? Cant even take it to the dealer cause I cant get it started.

I know its long, but thanx for stickin with me here! You guys are awesome!
Thanx in Advance,
Josh
Welcome to Ford Truck Enthusiasts! If you have a minute check out the Guidelines, it will help you to navigate through and understand FTE.

We are pleased you have chosen the best source for Fords!
See you on the boards.
Enjoy FTE …..
__________________
Administrator
tim.lamkin@internetbrands dot com
Life is not only time……paradoxically, it is the denial of time!
What lies behind us and what lies before us are tiny matters compared to what lies within us.

When you are down...look up...get up...and don't ever give up....
Reply With Quote
Old 01-17-2005, 08:05 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150

Tags
2008, 46, accelerate, battery, blinking, check, f150, ford, fuse, light, mega, primary, purpose, truck, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 06:02 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup