Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-10-2003, 07:26 PM
cary200 cary200 is offline
Senior User
 
Join Date: Jul 2003
Posts: 126
cary200 is starting off with a positive reputation.
Question 2000 Ford Ranger 2.5l Ping

Hello,

My 2.5L Ranger pings less after replacing the plugs and wires... The drivers side is not as bad as it looks as long as you have the 11" 90 degree needle nose plyers. The hardest part was getting the wires back on the plugs...... you MUST have these in my opinion to get it done.

It still however pings when trying to accelerate up a grade or under load. My truck supposedly has 32K on it and I run 87 octane. My air filter is clean.

I have not checked codes but I don't get a check engine light either. The check engine light only comes on when I go to start the truck. When the truck starts it goes out immediately. I'm thinking this is normal.


My question:

Is there anything else I can check/do/clean to get rid of the ping completely?

Does the MAS need cleaning? It looked clean looking through the hole from the filter side.

Will getting a K/N filter help my truck out?

P.S. I got ~27 MPG even with bad plugs.

2000 FORD RANGER 2.5L

Thanks
Reply With Quote
Old 07-10-2003, 07:26 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration pinging with 2000 ranger 2.5l spalmer 4 Cylinder Engines 4 12-13-2009 08:27 PM
'98 2.5l Won't Stop Pinging XLT2.5L Ranger & B-Series 25 08-24-2009 08:08 AM
What's the cause of engine pinging, 98 2.5L? 1998Ranger25L153CID Ranger & B-Series 9 12-18-2006 08:58 AM
Pinging 4.9L, Newbie needs help opeterson 1987 - 1996 F150 & Larger F-Series Trucks 4 03-26-2006 06:20 PM
1999 2.5L idle and ping problems dhdew Ranger & B-Series 12 04-02-2004 03:58 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines

Tags
2000, 25, 25l, 40, engine, ford, heat, litre, make, performance, ping, pinging, pings, plug, range, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup