radio buttons don't illuminate - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

radio buttons don't illuminate

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-15-2014, 10:18 PM
diehard802 diehard802 is offline
New User
Thread Starter
 
Join Date: May 2003
Posts: 5
diehard802 is starting off with a positive reputation.
radio buttons don't illuminate

Hello all,
I just purchased a 2008 Expedition EL eddie bauer and it has the dreaded "CD error" problem. No biggie, I can deal with that. But,the audio controls on the steering wheel don't work and the buttons on the radio won't illuminate. All other buttons in that area (4WD, A/C, etc) light up just fine. Anyone have any ideas? I have disconnected and pulled the radio and reinstalled. Still no lights. I even tried another radio...still no lights. The display is fine, it's the back light for all the control buttons on the radio. Any help is appreciated.
Reply With Quote
  #2  
Old 06-20-2014, 06:58 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Need to get a wiring diagram then test the dimmer wire and see if it's getting power. Do the interior lights dim/come on when you roll the control all the way up?
Reply With Quote
  #3  
Old 06-21-2014, 08:06 AM
diehard802 diehard802 is offline
New User
Thread Starter
 
Join Date: May 2003
Posts: 5
diehard802 is starting off with a positive reputation.
Yes sir, the interior lights are good. It is only the control buttons on the radio itself. Also, steering control button"fan -" actually moves temperature down instead. And temperature - does nothing? Opposite sides of the wheel. Crazy stuff. There was an aftermarket remote start installed... Wonder if they screwed something up. Thanks for the reply.
Reply With Quote
  #4  
Old 06-23-2014, 10:09 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Sounds like they did. Prob. cross wired stuff at the SJB.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Interior backlights for buttons not working 2004 lincoln navigator Starry Night Expedition & Navigator 26 03-05-2016 04:56 PM
radio cd No lights mrwrench 1999 to 2016 Super Duty 3 10-22-2011 12:54 PM
windows,radio,dome light don't work Navy7797 1999 to 2016 Super Duty 2 01-13-2008 04:10 AM
Electrical Problem - Radio Stays On normrp 1999 to 2016 Super Duty 19 01-11-2008 08:07 PM
Cruise control illumination gamblerac Escape & Escape Hybrid 5 12-21-2004 11:14 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 05:16 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.