radio buttons don't illuminate - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

radio buttons don't illuminate

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-15-2014, 09:18 PM
diehard802 diehard802 is offline
New User
Thread Starter
 
Join Date: May 2003
Posts: 5
diehard802 is starting off with a positive reputation.
radio buttons don't illuminate

Hello all,
I just purchased a 2008 Expedition EL eddie bauer and it has the dreaded "CD error" problem. No biggie, I can deal with that. But,the audio controls on the steering wheel don't work and the buttons on the radio won't illuminate. All other buttons in that area (4WD, A/C, etc) light up just fine. Anyone have any ideas? I have disconnected and pulled the radio and reinstalled. Still no lights. I even tried another radio...still no lights. The display is fine, it's the back light for all the control buttons on the radio. Any help is appreciated.
Reply With Quote
  #2  
Old 06-20-2014, 05:58 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Need to get a wiring diagram then test the dimmer wire and see if it's getting power. Do the interior lights dim/come on when you roll the control all the way up?
Reply With Quote
  #3  
Old 06-21-2014, 07:06 AM
diehard802 diehard802 is offline
New User
Thread Starter
 
Join Date: May 2003
Posts: 5
diehard802 is starting off with a positive reputation.
Yes sir, the interior lights are good. It is only the control buttons on the radio itself. Also, steering control button"fan -" actually moves temperature down instead. And temperature - does nothing? Opposite sides of the wheel. Crazy stuff. There was an aftermarket remote start installed... Wonder if they screwed something up. Thanks for the reply.
Reply With Quote
  #4  
Old 06-23-2014, 09:09 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Sounds like they did. Prob. cross wired stuff at the SJB.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'07 radio BUTTONS do not illuminate w parking lights WWR 2004 - 2008 F150 0 06-09-2017 10:50 AM
Radio Display Light Brad Brown 1999 to 2016 Super Duty 7 12-17-2016 10:36 AM
Hotwire the radio wrhatt 1987 - 1996 F150 & Larger F-Series Trucks 5 03-30-2016 06:34 PM
Interior backlights for buttons not working 2004 lincoln navigator Starry Night 1997-2006 Expedition & Navigator 26 03-05-2016 03:56 PM
Dash lights don't work mzbh 1999 to 2016 Super Duty 1 08-24-2014 08:49 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:58 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: