Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-26-2012, 10:35 AM
theboze theboze is offline
New User
 
Join Date: Jun 2012
Location: Nuangola,Pa
Posts: 2
theboze is starting off with a positive reputation.
Theft Light Blinking, won't start...Help!

Hi everyone I have a 97 Eddie Bauer Expedition with the 4.6, I just replaced the heater core last week ( removed the dash and all) when I put it back together the truck started fine. I let it sit a few days and went out to use it on Sunday and the battery was dead, not sure what drained it, but I put the charger on it for 20 minutes and went to start it, and it cranked over but wouldn't start. I then noticed the "theft" light blinking like crazy and it won't start. I disconnected the battery for 1/2 hour, like I seen on some posts, but that did not work. I do have a friend that has the OBD scanner from snap on, and I have the owners manuals along with the 2 large factory manuals from Ford on this truck, is there anything we could do to get this thing going without going to the dealer? Right now I am checking things without the scanner because I am off today and he is at work. Any help would be greatly appreciated.
Reply With Quote
  #2  
Old 06-26-2012, 10:42 AM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,591
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by theboze View Post
is there anything we could do to get this thing going without going to the dealer?
Do you have a second key to try?

If not, only the dealer will be able to program your keys back into the security system. Make sure you bring all of your keys with you.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #3  
Old 06-26-2012, 11:18 AM
theboze theboze is offline
New User
 
Join Date: Jun 2012
Location: Nuangola,Pa
Posts: 2
theboze is starting off with a positive reputation.
I already tried the other key and same thing.
Reply With Quote
  #4  
Old 06-26-2012, 01:03 PM
projectSHO89 projectSHO89 is online now
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 9,384
projectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud of
Check the connector and harness that goes to the key cylinder transceiver. Since the dash was out, the connector may be loose or something else in the circuit may have been damaged.
__________________
2001 F250 SD V10 4x4
HVAC FAQs: http://www.ford-trucks.com/forums/75...xpedition.html
Owner's manuals: http://www.fleet.ford.com/maintenance/owner-manuals/
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.” - Mark Twain
Reply With Quote
  #5  
Old 07-14-2012, 08:38 PM
79250ranger 79250ranger is offline
New User
 
Join Date: Oct 2011
Location: Oxford, CT
Posts: 22
79250ranger is starting off with a positive reputation.
I had same issue with theft light blinking... Battery went dead...bought a new battery, problem solved...
Reply With Quote
Old 07-14-2012, 08:38 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anti-theft light jan g Super Duty & Heavy Duty 4 11-14-2014 08:29 AM
PATS issue? Truck won't start after changing plugs and COPS smashclash 1997 - 2003 F150 45 09-17-2014 03:17 PM
Flashing Theft light on 2005 Ford Escape Won't Start David Vox Mullen Escape & Escape Hybrid 7 03-09-2013 08:32 AM
Won't start, theft light blinks BigE383 Ranger & B-Series 22 06-04-2007 08:29 AM
98 Expedition won't start--Theft indicator tudelalb Expedition & Navigator 3 02-17-2005 05:16 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
2005, 60l, 99ford, blinking, core, escape, expedition, expediton, f150, flash, ford, heater, hybrid, light, lights, replaced, start, theft, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup