Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2009+ F150
Sign in using an external account
Register Forgot Password?


2009+ F150 Discuss the 2009 through 2014 Ford F150 SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-05-2011, 08:13 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 805
soundwave is starting off with a positive reputation.
Rear defroster issue

How long does it take, or SUPPOSED to take, for the rear deforster to de-fogg the window? The first winter I had the truck it seemed like it was pretty rapid, now it doesnt seem to be working at all. I asked the dealer to look at it last week when I was in for an oil change and he said Id have to leave the truck for 2 days, which I couldnt do (how the heck am I supposed to get to work?) He told me that it usually takes the rear defroster 15-20 minutes to work. That doesnt seem right AT ALL. This is the same dealer that still wont confirm or deny that theres a recall on the Sync microphone so who knows
__________________
Current ride: 2010 F150 FX4 SCAB Flame Blue
Past trucks:1) Black two tone grey, loaded 2007 F-150 XLT Supercab 4X4 with the chrome package!2) 1995 2WD Yellow Ranger Splash Supercab 3) 1999 4X4, Red Ranger Sport Flareside Supercab, 4) 2004 Sonic Blue FX4 Ranger

Reply With Quote
  #2  
Old 11-05-2011, 08:48 PM
brandon4 brandon4 is offline
Senior User
 
Join Date: Aug 2006
Location: Logan, Utah
Posts: 477
brandon4 is starting off with a positive reputation.
Takes mine less than a minute. Check fuse?
Reply With Quote
  #3  
Old 11-05-2011, 09:59 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 805
soundwave is starting off with a positive reputation.
but the sideview mirrow defrosters work fine. Its it seprerate fuses?
__________________
Current ride: 2010 F150 FX4 SCAB Flame Blue
Past trucks:1) Black two tone grey, loaded 2007 F-150 XLT Supercab 4X4 with the chrome package!2) 1995 2WD Yellow Ranger Splash Supercab 3) 1999 4X4, Red Ranger Sport Flareside Supercab, 4) 2004 Sonic Blue FX4 Ranger

Reply With Quote
  #4  
Old 11-07-2011, 02:46 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 805
soundwave is starting off with a positive reputation.
I called the dealer today to make an appointment to get it fixed and they said an outside company has to come in and fix the rear defrosters in the F-series trucks and I still may be there all day (and beyond) waiting for it. Really? An outside company has to fix the Ford defroster? This sucks.
Reply With Quote
  #5  
Old 11-08-2011, 05:50 PM
juneau76's Avatar
juneau76 juneau76 is offline
Postmaster
 
Join Date: Sep 2007
Posts: 3,050
juneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud of
I have three strips that don't work on mine...haven't since the day I bought it. I need to get it looked at and I'm not looking forward to it. Anyhow, it should start real quick. Mine does and my wife's '08 Taurus X does, also. It sucks that you have to leave it. Let us know how you make out.
__________________
Brad
2010 F-150 XLT Supercrew 4x4 5.4L
2013 Explorer Limited (The wife's family truckster)

Quote:
You haven't lived life until you've done 110mph in a Yugo
Reply With Quote
  #6  
Old 11-08-2011, 08:28 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 805
soundwave is starting off with a positive reputation.
I got it taken care of today. They had to replace the entire rear window of my truck. I arrived at the dealer at 730am and didnt leave until 330pm.

The only other option was to leave it and they said they dont have a loaner program and everyone I know was at work so I was stuck. Im glad I brought my charger with my iPhone otherwise I really would've went beserk.

They said it was a problem in the wiring, perhaps the same issue youre having, juneau76? I get to do this again next week as they replace the Sync microphone under a TSB recall. I was told this is another 3-4 hour job because they have to remove the headliner and run the wire to the roof antenna. UGH..trying to look at the positive side of all this is this is all under warranty and I dont have to pay a dime
__________________
Current ride: 2010 F150 FX4 SCAB Flame Blue
Past trucks:1) Black two tone grey, loaded 2007 F-150 XLT Supercab 4X4 with the chrome package!2) 1995 2WD Yellow Ranger Splash Supercab 3) 1999 4X4, Red Ranger Sport Flareside Supercab, 4) 2004 Sonic Blue FX4 Ranger

Reply With Quote
  #7  
Old 11-03-2013, 04:16 PM
Skinz Skinz is offline
New User
 
Join Date: Nov 2013
Posts: 1
Skinz is starting off with a positive reputation.
Quote:
Originally Posted by juneau76 View Post
I have three strips that don't work on mine...haven't since the day I bought it. I need to get it looked at and I'm not looking forward to it. Anyhow, it should start real quick. Mine does and my wife's '08 Taurus X does, also. It sucks that you have to leave it. Let us know how you make out.
Juneau76, Did you ever figure out why a few lines on your rear window defroster didn't work? I'm experiencing the same thing.
Reply With Quote
  #8  
Old 11-04-2013, 03:05 AM
PrinceValium's Avatar
PrinceValium PrinceValium is offline
Posting Guru
 
Join Date: Nov 2011
Location: Northern California
Posts: 2,234
PrinceValium has a great reputation on FTE.PrinceValium has a great reputation on FTE.PrinceValium has a great reputation on FTE.PrinceValium has a great reputation on FTE.
Glad to hear you got it resolved...what was the TSB about for the mic?
__________________
Rob, disabled VET USAF.

My Mod Thread 2013 F150 Platinum, Ego-Boost, 3.73, max tow, skid plates, and bed liner, 32% ceramic tinting.
Reply With Quote
  #9  
Old 11-04-2013, 09:29 PM
FireMe FireMe is offline
Elder User
 
Join Date: Nov 2008
Location: Northfield, MI
Posts: 666
FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.
Did they say why it took so long? I can usually swap them out in a little over an hour and we usually keep several in stock (I am at the Ford dealer in Livonia.) Not sure why they would have an outside company replace it as they are just bolted in.
Reply With Quote
Old 11-04-2013, 09:29 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2009+ F150

Tags
05, 2010, defrost, defroster, defrosters, excursion, f150, ford, fuse, issue, location, problems, rear, reported, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
super duty side mirror defrost bironacad Super Duty & Heavy Duty 16 03-15-2014 06:02 PM
All climate functions come out of defrost vents two4two Super Duty & Heavy Duty 10 07-01-2013 01:08 PM
Rear defroster doesnt seem to be working...again soundwave 2009+ F150 4 05-29-2013 01:31 PM
2012 f150 defrost problems Tomcat322 Cooling, Heating, Ventilation & A/C 6 03-17-2013 07:06 AM
Attaching Defrost Ducts to Vents FordIowan 1973 - 1979 F-100 & Larger F-Series Trucks 2 07-25-2012 08:56 PM



All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup