Rear defroster issue - Ford Truck Enthusiasts Forums



2009 - 2014 F150 Discuss the 2009, 2010, 2011, 2012, 2013 and 2014 Ford F150

Rear defroster issue

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-05-2011, 09:13 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
Thread Starter
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 822
soundwave is starting off with a positive reputation.
Rear defroster issue

How long does it take, or SUPPOSED to take, for the rear deforster to de-fogg the window? The first winter I had the truck it seemed like it was pretty rapid, now it doesnt seem to be working at all. I asked the dealer to look at it last week when I was in for an oil change and he said Id have to leave the truck for 2 days, which I couldnt do (how the heck am I supposed to get to work?) He told me that it usually takes the rear defroster 15-20 minutes to work. That doesnt seem right AT ALL. This is the same dealer that still wont confirm or deny that theres a recall on the Sync microphone so who knows
Reply With Quote
  #2  
Old 11-05-2011, 09:48 PM
brandon4 brandon4 is offline
Elder User
 
Join Date: Aug 2006
Location: Logan, Utah
Posts: 532
brandon4 is gaining momentum as a positive member of FTE.
Takes mine less than a minute. Check fuse?
Reply With Quote
  #3  
Old 11-05-2011, 10:59 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
Thread Starter
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 822
soundwave is starting off with a positive reputation.
but the sideview mirrow defrosters work fine. Its it seprerate fuses?
Reply With Quote
  #4  
Old 11-07-2011, 03:46 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
Thread Starter
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 822
soundwave is starting off with a positive reputation.
I called the dealer today to make an appointment to get it fixed and they said an outside company has to come in and fix the rear defrosters in the F-series trucks and I still may be there all day (and beyond) waiting for it. Really? An outside company has to fix the Ford defroster? This sucks.
Reply With Quote
  #5  
Old 11-08-2011, 06:50 PM
juneau76's Avatar
juneau76 juneau76 is offline
Postmaster
 
Join Date: Sep 2007
Posts: 3,050
juneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud ofjuneau76 has much to be proud of
I have three strips that don't work on mine...haven't since the day I bought it. I need to get it looked at and I'm not looking forward to it. Anyhow, it should start real quick. Mine does and my wife's '08 Taurus X does, also. It sucks that you have to leave it. Let us know how you make out.
Reply With Quote
  #6  
Old 11-08-2011, 09:28 PM
soundwave's Avatar
soundwave soundwave is offline
Elder User
Thread Starter
 
Join Date: Nov 2005
Location: Detroit 'burbs
Posts: 822
soundwave is starting off with a positive reputation.
I got it taken care of today. They had to replace the entire rear window of my truck. I arrived at the dealer at 730am and didnt leave until 330pm.

The only other option was to leave it and they said they dont have a loaner program and everyone I know was at work so I was stuck. Im glad I brought my charger with my iPhone otherwise I really would've went beserk.

They said it was a problem in the wiring, perhaps the same issue youre having, juneau76? I get to do this again next week as they replace the Sync microphone under a TSB recall. I was told this is another 3-4 hour job because they have to remove the headliner and run the wire to the roof antenna. UGH..trying to look at the positive side of all this is this is all under warranty and I dont have to pay a dime
Reply With Quote
  #7  
Old 11-03-2013, 05:16 PM
Skinz Skinz is offline
New User
 
Join Date: Nov 2013
Posts: 1
Skinz is starting off with a positive reputation.
Quote:
Originally Posted by juneau76 View Post
I have three strips that don't work on mine...haven't since the day I bought it. I need to get it looked at and I'm not looking forward to it. Anyhow, it should start real quick. Mine does and my wife's '08 Taurus X does, also. It sucks that you have to leave it. Let us know how you make out.
Juneau76, Did you ever figure out why a few lines on your rear window defroster didn't work? I'm experiencing the same thing.
Reply With Quote
  #8  
Old 11-04-2013, 04:05 AM
PrinceValium's Avatar
PrinceValium PrinceValium is offline
Postmaster
 
Join Date: Nov 2011
Location: Northern California
Posts: 2,918
PrinceValium is a name known to allPrinceValium is a name known to allPrinceValium is a name known to allPrinceValium is a name known to allPrinceValium is a name known to allPrinceValium is a name known to all
Glad to hear you got it resolved...what was the TSB about for the mic?
Reply With Quote
  #9  
Old 11-04-2013, 10:29 PM
FireMe FireMe is offline
Elder User
 
Join Date: Nov 2008
Location: Northfield, MI
Posts: 668
FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.FireMe has a very good reputation on FTE.
Did they say why it took so long? I can usually swap them out in a little over an hour and we usually keep several in stock (I am at the Ford dealer in Livonia.) Not sure why they would have an outside company replace it as they are just bolted in.
Reply With Quote
  #10  
Old 08-25-2015, 08:34 AM
ynot4me2 ynot4me2 is offline
New User
 
Join Date: Aug 2015
Posts: 1
ynot4me2 is starting off with a positive reputation.
2010 XLT SCREW, just started to have the same problem but no more warranty left. I don't really need the rear window defroster but I do use the side mirror defroster a lot. Does anyone know of a way that I can complete the circuit so the system comes on for just the mirrors? I don't really want to spend $400+ to fix the problem.
Reply With Quote
  #11  
Old 08-25-2015, 03:45 PM
SBV45's Avatar
SBV45 SBV45 is offline
Postmaster
 
Join Date: Aug 2003
Location: Central Texas
Posts: 4,439
SBV45 is gaining momentum as a positive member of FTE.
I believe the TSB for the mic dates back to '09-10.
Reply With Quote
  #12  
Old 08-25-2015, 06:28 PM
MIKE1646's Avatar
MIKE1646 MIKE1646 is offline
Elder User
 
Join Date: Dec 2003
Location: Florida
Posts: 688
MIKE1646 is starting off with a positive reputation.
The last time I used my defroster it blew the rear window, now I just don't use it.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Has anyone installed heated mirrors on a non rear defrost truck? flavo 2009 - 2014 F150 2 11-30-2016 06:17 PM
Rear Defrost / Heated Mirrors no-op 2012 TheNewman 2009 - 2014 F150 44 11-03-2016 04:37 AM
Rear defrost issue nnero 2009 - 2014 F150 5 11-17-2014 12:10 PM
2012 F150 Rear Defrost Electrical Circuit? F250GH 2009 - 2014 F150 4 11-07-2014 01:42 PM
Rear defroster doesnt seem to be working...again soundwave 2009 - 2014 F150 4 05-29-2013 02:31 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
05, 2010, defrost, defroster, defrosters, excursion, f150, ford, fuse, issue, location, problems, rear, reported, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 02:53 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.