Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

2008 Limited Rear Power Liftgate won't function.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-03-2010, 08:52 AM
2000F2504X4 2000F2504X4 is offline
Junior User
 
Join Date: Jun 2003
Location: Austin, Texas
Posts: 73
2000F2504X4 is starting off with a positive reputation.
2008 Limited Rear Power Liftgate won't function.

Yesterday the power liftgate on our 2008 Expy stopped working. I have checked all of the fuses. The sensors appear to be working also, because I get a beep when the tranny is out of "Park". I can manually open the gate using the latch behind the plastic access panel located just below the pull strap on bottom of the liftgate. When the door is open and I push the button, I get the "Beep, Beep, Beep" warning that the door is about to close, but nothing happens. When the gate is closed and I push the button, nothing happens. I can hear a light click at the base of the actuator arm when I press the button. Any suggestions other than taking it to the dealer. I can change parts myself, but don't want to buy the wrong parts. Anyone know the diagnostic procedures for the liftgate function?

Thanks,
Tom
__________________
2008 Expedition EL Limited
2008 F350 XLT 4X4
Reply With Quote
  #2  
Old 08-03-2010, 11:51 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
There was a TSB on this I think, but I don't have my Alldata access anymore or I would look at it.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 08-03-2010, 12:15 PM
2000F2504X4 2000F2504X4 is offline
Junior User
 
Join Date: Jun 2003
Location: Austin, Texas
Posts: 73
2000F2504X4 is starting off with a positive reputation.
Well I figured it out. It was all due to a low battery. We had our first 100+ degree day yesterday. The two year old motorcraft battery with 70k miles use has exceeded its life expectancy. There was enough power to start the car, but not enough for the liftgate. Liftgate wouldn't even open with the car at idle. Put a charger on the battery, and the liftgate started working. Got a new battery, and all is well. Too bad the instrument cluster can't tell me I have a low battery......

Later-
__________________
2008 Expedition EL Limited
2008 F350 XLT 4X4
Reply With Quote
Old 08-03-2010, 12:15 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reconfiguring keyless entry module - swapping out keyfob button actions TheyCallMeBT 2007 - 2014 Expedition & Navigator 6 12-30-2013 10:34 PM
whacky liftgate jawdoc 2007 - 2014 Expedition & Navigator 3 06-07-2013 05:54 PM
2007 Navigator power liftgate and power latch not working Jaylegger 2007 - 2014 Expedition & Navigator 1 03-10-2013 09:44 PM
Rear liftgate doesn't open? TexFinn Expedition & Navigator 12 08-12-2009 05:10 PM
Power Liftgate Problem Bornzo 2007 - 2014 Expedition & Navigator 21 06-04-2009 12:47 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
07, 2007, 2008, escape, expedition, explorer, ford, gate, hatch, liftgate, list, manually, open, parts, power, rear, tommy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »


All times are GMT -5. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup