Idle problems - Ford Truck Enthusiasts Forums
 
Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)
Sign In
Register Forgot Password?


Modular V10 (6.8l) SPONSORED BY:

Idle problems

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-20-2014, 08:26 AM
Fifty4F100's Avatar
Fifty4F100 Fifty4F100 is offline
Posting Guru
 
Join Date: Feb 2003
Location: Bartlett, TN
Posts: 1,134
Fifty4F100 is gaining momentum as a positive member of FTE.Fifty4F100 is gaining momentum as a positive member of FTE.
Idle problems

I've got a new problem with my 99 Holiday Rambler MH. Its on a Ford F53 chassis so it has the 6.8 V10. Its been a great engine and still goes down the road fine. But I noticed this past weekend that it has a definite lope when it idles. Hopefully this is an easy fix as we have plans for it over the next few weeks. What might be causing this? Its not throwing a "Service Engine Soon" light.
__________________
Please don't consider anything I say as coming from someone who knows what he's talking about!
Glenn in TN
05 PT Cruiser Convertible (RV Toad -- behind Holiday Rambler MH - Ford V10 content!)
Reply With Quote
  #2  
Old 08-21-2014, 01:01 PM
Fifty4F100's Avatar
Fifty4F100 Fifty4F100 is offline
Posting Guru
 
Join Date: Feb 2003
Location: Bartlett, TN
Posts: 1,134
Fifty4F100 is gaining momentum as a positive member of FTE.Fifty4F100 is gaining momentum as a positive member of FTE.
No help yet? I've gotten a few replies on an RV forum, but I would more trust guys here on FTE. Most are saying I might have a vacuum leak. Maybe, but wouldn't a vacuum leak make it miss over the whole RPM range? Its only loping at idle. And I've found this engine doesn't have a Idle Air Controller.
__________________
Please don't consider anything I say as coming from someone who knows what he's talking about!
Glenn in TN
05 PT Cruiser Convertible (RV Toad -- behind Holiday Rambler MH - Ford V10 content!)
Reply With Quote
  #3  
Old 08-21-2014, 07:17 PM
Wolfboro's Avatar
Wolfboro Wolfboro is offline
Senior User
 
Join Date: Feb 2006
Location: FL
Posts: 443
Wolfboro is gaining momentum as a positive member of FTE.
When I had an idling issue with my 2003 , the idling RPM was fluctuating . It turned out I had a bad (leaking) hose at PCV . Check all of your hoses, including plastic 90 degree elbow (cracked?) and a rubber 90 degree elbow (deteriorated ?) at throttle .
Good luck,
__________________
Beware of hip-shooters and faked experts.

2003 F-350 SD, XL SuperCab, SRW, 2x4, LB , V10, 4.3 rear axle w/LS , 6-spd manual -ZF Friedrichshafen AG, no mod.
Reply With Quote
  #4  
Old 08-25-2014, 11:20 AM
Fifty4F100's Avatar
Fifty4F100 Fifty4F100 is offline
Posting Guru
 
Join Date: Feb 2003
Location: Bartlett, TN
Posts: 1,134
Fifty4F100 is gaining momentum as a positive member of FTE.Fifty4F100 is gaining momentum as a positive member of FTE.
1.) I have my doghouse off and I see what might some good places to check. I have starter spray I'm going to use.
2.) I also see the Idle Air Control. I'm going to take it off and clean it. But I've been told these engines don't have one - what am I looking at? Wish I could get pics to post!!
__________________
Please don't consider anything I say as coming from someone who knows what he's talking about!
Glenn in TN
05 PT Cruiser Convertible (RV Toad -- behind Holiday Rambler MH - Ford V10 content!)
Reply With Quote
  #5  
Old 08-25-2014, 12:01 PM
Fifty4F100's Avatar
Fifty4F100 Fifty4F100 is offline
Posting Guru
 
Join Date: Feb 2003
Location: Bartlett, TN
Posts: 1,134
Fifty4F100 is gaining momentum as a positive member of FTE.Fifty4F100 is gaining momentum as a positive member of FTE.
Click the image to open in full size.

This is what I'm thinking is a Idle Air Control.

Now I've found this:
Click the image to open in full size.

Could this be my problem? I will put it back the way it should be regardless.
__________________
Please don't consider anything I say as coming from someone who knows what he's talking about!
Glenn in TN
05 PT Cruiser Convertible (RV Toad -- behind Holiday Rambler MH - Ford V10 content!)
Reply With Quote
  #6  
Old 08-25-2014, 12:01 PM
Fifty4F100's Avatar
Fifty4F100 Fifty4F100 is offline
Posting Guru
 
Join Date: Feb 2003
Location: Bartlett, TN
Posts: 1,134
Fifty4F100 is gaining momentum as a positive member of FTE.Fifty4F100 is gaining momentum as a positive member of FTE.
The pictures don't look that big on my iphone!
__________________
Please don't consider anything I say as coming from someone who knows what he's talking about!
Glenn in TN
05 PT Cruiser Convertible (RV Toad -- behind Holiday Rambler MH - Ford V10 content!)
Reply With Quote
  #7  
Old 08-25-2014, 09:11 PM
jh818's Avatar
jh818 jh818 is offline
Postmaster
 
Join Date: Jul 2009
Location: Chino, California
Posts: 2,628
jh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputation
Yes. That part with the black round thing is your IAC valve.
__________________
2002 Excursion XLT V10 2WD 4.30 Limited Slip
Bone stock with restrictive Y-pipe and Michelin AT/2
Front Hitch Reciver, Rear Hellwig Sway Bar 7643
Reply With Quote
Old 08-25-2014, 09:11 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wierd Idle issues MacPhly Super Duty & Heavy Duty 2 03-18-2015 08:06 AM
EOT problem andy's2000 1999 - 2003 7.3L Power Stroke Diesel 20 03-15-2015 05:56 PM
Idle problem 350v10 Modular V10 (6.8l) 2 12-30-2014 06:40 AM
1989 F250 Idle problems evansz95 1987 - 1996 F150 & Larger F-Series Trucks 1 04-16-2014 11:29 PM
89 f350 351 idle question... highntight 1987 - 1996 F150 & Larger F-Series Trucks 4 10-17-2013 09:49 AM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 09:42 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup