Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1957 - 1960 F100 & Larger F-Series Trucks
Sign in using an external account
Register Forgot Password?


1957 - 1960 F100 & Larger F-Series Trucks Discuss the Box Style Ford Trucks

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-17-2013, 09:43 PM
Custom66Cab Custom66Cab is offline
New User
 
Join Date: Sep 2012
Posts: 17
Custom66Cab is starting off with a positive reputation.
58 custom cab

I'm having a issue with my truck you guys are the gurus so ill ask y'all 1st. Here goes the truck starts and runs fine but when I go to turn it off and pull the key it stays running . Even with the key out what's he deal with that. Any help is greatly greatly appreciated ..
Reply With Quote
  #2  
Old 04-18-2013, 11:23 AM
FJones8668 FJones8668 is offline
Senior User
 
Join Date: Apr 2011
Posts: 127
FJones8668 is starting off with a positive reputation.
Ignition switch could be bad, someone could have wired the coil wrong so that something is back feeding power to it with the key off. How do you shut the pickup down? That would help diagnose your problem (maybe). If there was constant power to the coil I would assume it would burn out but if you are shutting the truck down by removing power to the coil it wouldn't be. I would get a test light and go to town under the hood. If you don't have one they are $2 from harbor freight. Do a google search for a wiring diagram, I know I have posted them on here before.

Let us know what you figure out!
Reply With Quote
Old 04-18-2013, 11:23 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1957 - 1960 F100 & Larger F-Series Trucks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help ! WolfB Super Duty & Heavy Duty 4 08-12-2014 02:46 PM
Power in cab but some things don't turn off 96ford250 1994.5 - 1997 7.3L Power Stroke Diesel 4 04-30-2013 04:48 PM
Can an IDI run with no lift pump? nofishbob Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 11 02-14-2013 06:26 AM
CHEEZIT.....LOOK 6.0techwannabe 6.0L Power Stroke Diesel 11 10-21-2012 09:27 AM
Removing Ignition Switch unit but no key bwalt11 1961 - 1966 F-100 & Larger F-Series Trucks 12 08-13-2012 02:52 PM



All times are GMT -5. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup