Ford Truck Enthusiasts Forums - Search Results

Notices
 
Search: Posts Made By: M fire
Showing results 1 to 15 of 47
Search took 0.23 seconds.
05-16-2015, 11:17 PM
Replies: 22
Views: 2,688
Posted By M fire

Thanks, I'm going to try and get under it this...

Thanks, I'm going to try and get under it this week.
05-15-2015, 02:01 PM
Replies: 22
Views: 2,688
Posted By M fire

what am I looking for with the cable exactly? ...

what am I looking for with the cable exactly? How would I be able to tell if it's adjusted correctly? Will there be slack? Thanks.
05-15-2015, 10:43 AM
Replies: 22
Views: 2,688
Posted By M fire

I'll take a look at that. Also, after reading...

I'll take a look at that. Also, after reading some other posts I was wondering if it could be the line pressure modulator valve and sleeve.
05-14-2015, 08:55 PM
Replies: 22
Views: 2,688
Posted By M fire

Actually had to tow about 3000#'s the other day...

Actually had to tow about 3000#'s the other day and it was fine. No slippage or hard shifting under that tow load. But, I wasn't running it with hard acceleration with the trailer.
05-14-2015, 08:53 PM
Replies: 22
Views: 2,688
Posted By M fire

Much harder than a normal full throttle shift....

Much harder than a normal full throttle shift. Actually it's abrupt with a screech sound.
05-14-2015, 01:03 PM
Replies: 22
Views: 2,688
Posted By M fire

Intermittent hard shifting 2nd to 3rd gear?

99 Expedtition, 5.4l, 4x4, EB. Intermittent hard shift from 2-3 usually under a full acceleration. Can back out of the throttle and generally will shift normal. Seems to hang on to the shift points...
11-03-2014, 08:35 PM
Replies: 14
Views: 1,533
Posted By M fire

Congrats with the fix!

Congrats with the fix!
10-01-2014, 11:25 AM
Replies: 14
Views: 1,533
Posted By M fire

Not sure about the Explorer. But, check to see if...

Not sure about the Explorer. But, check to see if you have a Turn signal relay under the steering column. The Expedition is blue. Takes about an hour at most for the replacement.
10-01-2014, 08:50 AM
Replies: 14
Views: 1,533
Posted By M fire

It's the blue relay under the steering column....

It's the blue relay under the steering column. Replace that and you're good to go.
07-10-2014, 11:24 PM
Replies: 0
Views: 3,566
Posted By M fire

1999 EB 5.4 AC blowing warm after +Battery cable became loose and wouldn't start

Today the positive battery cable loosened and when tightened back up all was normal but the AC was no blowing warm air. It was working perfect before hand. Is there a fuse or relay that could have...
06-29-2014, 02:06 AM
Replies: 41
Views: 72,333
Posted By M fire

Well took off the upper trim panel and lower dash...

Well took off the upper trim panel and lower dash panel. I was able to get a better hold of the relay and change it. All works now. Back to having turn signals. Thanks for your help.
06-28-2014, 06:23 PM
Replies: 41
Views: 72,333
Posted By M fire

13 and 23 in the fuse compartment left side of...

13 and 23 in the fuse compartment left side of the lower dash?
06-28-2014, 04:38 PM
Replies: 41
Views: 72,333
Posted By M fire

Thanks, I'll go try again.

Thanks, I'll go try again.
06-28-2014, 04:35 PM
Replies: 41
Views: 72,333
Posted By M fire

Alloro, so work on getting the Blue relay out?

Alloro, so work on getting the Blue relay out?
06-28-2014, 04:31 PM
Replies: 41
Views: 72,333
Posted By M fire

I thought there were two different relays because...

I thought there were two different relays because I still have Hazards just no turn signals a flash or two then they stop. same right or left. I can touch the relays and feel the clicking as if they...
Showing results 1 to 15 of 47
 


 
Forum Jump

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.