Ford Truck Enthusiasts Forums - Search Results

Notices
 
Search: Posts Made By: landtortise89
Showing results 1 to 15 of 57
Search took 0.36 seconds.
Replies: 36
Views: 50,128
Posted By landtortise89

just curious if anyone has tried running a dual...

just curious if anyone has tried running a dual plane manifold with stock edi
02-03-2019, 01:19 PM
Replies: 13
Views: 520
Posted By landtortise89

I have one of those too lol it was pre installed...

I have one of those too lol it was pre installed on my 460 truck so Iíll probably just leave it there lol
02-02-2019, 03:11 AM
Replies: 13
Views: 520
Posted By landtortise89

Yeah my 460 truck will never see water fording...

Yeah my 460 truck will never see water fording lol my bronco maybe but unlikely that deep. If I remember right on my 4.9 bronco I cut the little duck bill off the snorkel too
02-02-2019, 12:51 AM
Replies: 13
Views: 520
Posted By landtortise89

So on my 5.8 bronco it still has the factory box...

So on my 5.8 bronco it still has the factory box and the snorkel runs up between the hood and grille. Now if I remember correctly from my 4.9 bronco the snorkel was a lot bigger and was behind the...
02-01-2019, 08:38 PM
Replies: 13
Views: 520
Posted By landtortise89

Ram air

Anyone run one of these or have played with ram air on a 460 or other gas engines looking to get the most out of the air system. More air equals better atomization currently has the K&N open element...
01-21-2019, 08:59 PM
Replies: 0
Views: 113
Posted By landtortise89

Electronic transfer case questions

So I just bought another bronco 1992 with a 5.8 auto and an electronic transfer case. So I just got it running today and when I push the button on the dash nothing happens no light no 4wd nothing. ...
01-03-2019, 05:20 PM
Replies: 5
Views: 407
Posted By landtortise89

No there was no fuel pressure at the rail. ...

No there was no fuel pressure at the rail.

Turns inís out it was the fuel pump relay and itís soldered onto a board in the fuse box. I have it bypassed right now till I can get a new fuse box.
01-01-2019, 09:37 PM
Replies: 5
Views: 407
Posted By landtortise89

No Iím leaning towards a relay

No Iím leaning towards a relay
01-01-2019, 06:50 PM
Replies: 5
Views: 407
Posted By landtortise89

2003 expedition. No start please help

Hey guys. My 2003 expediton just quit had been running fine no issues. No cel since I changed the thermostat. However I. Discovered a coolant leak and was investigating that (water pump) didnít...
11-24-2018, 07:59 PM
Replies: 16
Views: 1,056
Posted By landtortise89

Well a new development tonight while driving home...

Well a new development tonight while driving home on the interstate the CEL came on only code was a P0128 which is coolant temp sensor blah blah blah. And I noticed the temp was rather low. Iím...
11-24-2018, 05:47 PM
Replies: 16
Views: 1,056
Posted By landtortise89

The front lines seem to be fine my front heat...

The front lines seem to be fine my front heat works great. The rear just blows cold air plugged rear heater core? Is what Iím thinking cuz itís not circulating? Engine temp seems normal just below...
11-24-2018, 01:35 PM
Replies: 16
Views: 1,056
Posted By landtortise89

So I checked the lines under the car while...

So I checked the lines under the car while running errands today one line is at like 120 degrees while the other is at 60 degrees doesnít seem nomal to me. Any input?
11-22-2018, 06:13 PM
Replies: 16
Views: 1,056
Posted By landtortise89

The actuators sounds like they are working but I...

The actuators sounds like they are working but I can double check. Which one is for the temp? Green or red? Iíll have to check the line
11-22-2018, 12:41 PM
Replies: 16
Views: 1,056
Posted By landtortise89

Well it was held in the open position by the...

Well it was held in the open position by the spring Iím trying to Diagnose a no rear heat condition but everything seems to be working the blend doors I can hear them change position the valve was...
11-22-2018, 11:58 AM
Replies: 16
Views: 1,056
Posted By landtortise89

On the little valve under the hood I found the...

On the little valve under the hood I found the vacuum line was unhooked probably by P.O. when he changed plugs. Anyway I hooked it up and it did nothing is it supposed to pull that arm back to move...
Showing results 1 to 15 of 57
 


 
Forum Jump

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.