Ford Truck Enthusiasts Forums - Search Results

Notices
 
Search: Posts Made By: GRNMSTR
Showing results 1 to 15 of 98
Search took 0.45 seconds.
02-10-2019, 07:47 PM
Replies: 1
Views: 153
Posted By GRNMSTR

Check Brake System and IP Brake Light ON

Have a unusual problem on my 2014 F150 FX4 with ABS, Traction Control and the 3.5L ecoBoost, on my way home the truck was not slowing down when the brakes were applied and the pedal felt really hard...
04-04-2017, 07:19 PM
Replies: 2
Views: 427
Posted By GRNMSTR

Well after a weekend of smelling like a Fuel...

Well after a weekend of smelling like a Fuel Tank, I found out that the problem was not the FPDM or the Fuel Pump (Being that the truck has 280K on it I replaced both) found out that the "Hot" Wire...
04-04-2017, 07:12 PM
Replies: 32
Views: 11,496
Posted By GRNMSTR

That is all fine and Dandy but they didn't make...

That is all fine and Dandy but they didn't make it easy to fix.... I have a 04 5.4L that has 280K on it and just replaced the Fuel Pump, now the Pressure Fuel Line will not stay seated on the Fuel...
03-31-2017, 08:16 PM
Replies: 2
Views: 427
Posted By GRNMSTR

2004 F150 XLT SCAB 5.4L 3v Fuel Problem

I have a 2004 F150 that I drive Daily, it has 280,000 miles on it. While driving to work (70mph) my throttle became unresponsive and it felt like the transmission was downshifting. Made my way to...
06-02-2016, 11:13 PM
Replies: 3
Views: 736
Posted By GRNMSTR

Instrument Cluster Problems....

I have a 2004 F150 (New Body Style) with 5.4L 3v and about 266k miles. My Alternator finally bit the dust and my instrument cluster went from reading speed, temp level, odometer, RPMs to being blank...
05-26-2016, 08:18 AM
Replies: 1
Views: 671
Posted By GRNMSTR

08 Explorer Sport Trac WHeel Bearing/Hub Replacement

I am looking for the FORD SPECS for the installation of Wheel Bearing Hub Assys, Torque settings for Mounting Bolts and Spindle Nut.


Any Information is greatly appreciated.
05-26-2016, 08:09 AM
Replies: 6
Views: 1,189
Posted By GRNMSTR

DO NOT BUY FROM Detroit Axel!!!!

There sales people are great at taking your money and sending you out crap parts quickly. Their Materials are crap and I can confirm that they are from China. I have had multiple sets fail from...
01-09-2016, 02:58 PM
Replies: 2
Views: 6,522
Posted By GRNMSTR

2009 Escape Tire Pressure Sensor Fault

I have a 2009 Escape Limited with 3.0L, 160k miles. When traveling to work (Highway, 70 Mph) my Display will show "Tire Pressure Sensor Fault" everyday after driving about 30 Miles at 70+MPH (pretty...
08-25-2015, 06:33 PM
Replies: 3
Views: 677
Posted By GRNMSTR

The Owners Manual for the 2004 is different from...

The Owners Manual for the 2004 is different from the 2007... Fuse number 37 is for the Rear Power Point and 41 is for the Cigar Lighter, Diagnostic Connector Power. I also have a Aux Power Point on...
08-23-2015, 05:22 PM
Replies: 3
Views: 677
Posted By GRNMSTR

rear Power Point and Dianostic Connector Not working

Fired up my 2004 F150 4x4 5.4L 3v that had sat for 1.5 years while I was out of town. Just to find out that both the Rear seat Power Point, the Front Power Point and Cigar Lighter plug are not...
10-08-2014, 06:44 PM
Replies: 6
Views: 7,256
Posted By GRNMSTR

The Battery light is now staying on, except when...

The Battery light is now staying on, except when first started the light will come back on after a few minutes and stay on....
10-08-2014, 06:42 PM
Replies: 6
Views: 7,256
Posted By GRNMSTR

I took it to NAPA today and they tested the...

I took it to NAPA today and they tested the Alternator and the Battery both passed and the Alternator is generating 14.28v and the CCA of the battery passed at 700CCA. Any other Ideas????
10-06-2014, 08:32 PM
Replies: 6
Views: 7,256
Posted By GRNMSTR

2009 Escape Battery Light problem

I have a 2009 Ford Escape Limited with 3.0L. When Idling the Battery Light will turn on and stay on and when driving above 45Mph the light will turn off and then turn back on several miles down the...
06-03-2014, 09:07 PM
Replies: 262
Views: 132,490
Posted By GRNMSTR

04' F150 5.4L

I am the original owner of a 04' F150 5.4L XLT 4x4 with 298K miles on it and up till a month ago it was running strong. Darn Chipmunks chewed the Main Engine harness to the COPs. I am in the...
05-14-2014, 11:59 AM
Replies: 9
Views: 2,307
Posted By GRNMSTR

No, I asked them about it the last time it was in...

No, I asked them about it the last time it was in and they said they couldn't duplicate the problem. And that was when it was still under warranty. Now they want a small fortune just to diagnose the...
Showing results 1 to 15 of 98
 


 
Forum Jump

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.